Announcement

Collapse
No announcement yet.

R7 370 MSI Armor 2X 2GB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • R7 370 MSI Armor 2X 2GB

    Following your article about MSI R7 370 Gaming 4G http://www.phoronix.com/scan.php?pag...Source-Support working with open source drivers, I decided to buy the lower cost version: http://www.msi.com/product/vga/R7-370-2GD5T-OC.html.

    Unfortunately it doesn't work at all, after the radeon driver is loaded, my pc becomes completely unresponsive with a black screen or no signal. I tried Debian testing, Ubuntu 15.04 with oibaf's PPA, Fedora 22 with no success.

    Am I missing something?

  • #2
    IIRC the ID was added after 15.04 and F22 were shipped. Suspect you need a newer kernel, don't think oibaf's PPA updates the kernel does it ?

    Comment


    • #3
      Or (same question as in my thread) could he just add the ID to the radeon kernel driver, recompile, install and be done ?

      By copying/inserting the code of its 200 series counterpart ?

      Assuming all code/firmware of this card is basically already present, just not the ID ?
      Last edited by ossuser; 07-09-2015, 07:13 AM.

      Comment


      • #4
        Yep, that should work. I assumed (perhaps wrongly) that OP didn't want to get into modifying kernel source & rebuilding.

        I was thinking more along the lines of picking up a rolling release distro or WIP U15.10/F23 build, but didn't have time to identify one which I was sure included the IDs.

        Comment


        • #5
          You are right, oibaf's PPA doesn't update the kernel. I tried to install a more recent kernel on Ubuntu from http://kernel.ubuntu.com/~kernel-ppa/mainline/. I tied 4.1.1, drm-next (both failed like before), daily and 4.2 (both immediately resulted in a kernel panic).

          I can only boot with nomodeset. I'd like to avoid modifying the kernel. How can I check if a distro includes the IDs? In the meantime I am going to try Fedora Rawhide.

          Thank you.

          Comment


          • #6
            Fedora Rawhide didn't work either. But I could see a "Invalid ROM content" and "can't load radeon/TAHITI_vce.bin" firmware message before the crash, so it seems to be a firmware problem. But why would it want to load tahiti firmware? Isn't it supposed to be a Cura?ao?

            Comment


            • #7
              I don't see a PITCAIRN_vce.bin so guessing that Tahiti & Pitcairn use the same microcode image for VCE.

              EDIT yep - Tahiti, Pitcairn, Cape Verde, Oland and Aruba all use the TAHITI_vce.bin microcode image (see lines 41-42, 67-82):

              http://cgit.freedesktop.org/~agd5f/l...-fixes-4.2-wip

              You can get the firmware from : http://people.freedesktop.org/~agd5f/radeon_ucode/
              Last edited by bridgman; 07-09-2015, 01:07 PM.

              Comment


              • #8
                Maybe you're also experiencing this:
                https://bugs.freedesktop.org/show_bug.cgi?id=76490

                Try booting with radeon.dpm=0 in your kernel cmd line.

                Comment


                • #9
                  Yes! radeon.dpm=0 made my system bootable again. Thanks!

                  So now I have to find out how to make it work with DPM on...

                  Comment


                  • #10
                    You could register at bugs.freedesktop.org and share your bios like we did (I'm Tobias Droste) so that maybe Alex can find what's wrong with the pitcairns.

                    Other than that you can try to find if there's a working combination of max. sclk and max. mclk where DPM works.
                    Add a line in the kernel for your card (with the correct vendor/device id) and try different clocks like we did:
                    drivers/gpu/drm/radeon/si_dpm.c (line 2926-2927)

                    My working combination is:
                    { PCI_VENDOR_ID_ATI, 0x6810, 0x174b, 0xe271, 85000, 90000 },

                    Last value is mclk and the other is sclk. 0=use bios default. Values are in 10kHz (not sure why ) so 85000=850MHz.

                    Comment

                    Working...
                    X