No announcement yet.

fglrx crashes Xorg if the fglrx kernel module is loaded

  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx crashes Xorg if the fglrx kernel module is loaded

    Hi, i have slamd64 12.1 (so 64-bit), when i try installing fglrx (tried 8.7 and 8.6) Xorg just crashes, no errors, nothing, and it does right when the driver loads. The only workaround i have found is to force no hardware acceleration by not installing the kernel module.

    I tried this with both xorg 1.4.0 and 1.4.1, on both the and kernels ( required this patch to compile, and thus i only tested the 8.7 driver with it), i tried all combinations of all products listed that i could get installed

    the crash generates this backtrace:

    0: X(xf86SigHandler+0x6a) [0x48664a]
    1: /lib64/ [0x7f25b848cf70]
    2: /lib64/ [0x7f25b84d5f30]
    3: /usr/lib64/xorg/modules/drivers// [0x7f25b66342df]
    4: /usr/lib64/xorg/modules/drivers// [0x7f25b6633cfe]
    5: /usr/lib64/xorg/modules/drivers// [0x7f25b6616b7f]
    6: /usr/lib64/xorg/modules/drivers// [0x7f25b661176a]
    7: X(InitOutput+0xa31) [0x461981]
    8: X(main+0x29f) [0x43017f]
    9: /lib64/ [0x7f25b8479164]
    10: X(FontFileCompleteXLFD+0x279) [0x42f699]

    the full Xorg.0.log

    My system specs in case it helps

    vid card: Diamond ATI RadeonHD 3870 w/512MB
    mobo: tyan i5400pw
    RAM: 8GB
    CPU: 2x e5410

  • #2
    At least your computer doesn't totally freeze....

    I got a problem look:

    edman007, do you know how I can get a backtrace/debug info in my situation ?

    Thanks in advance.
    Last edited by israel_miranda; 08-05-2008, 12:39 PM.


    • #3
      I am using archlinux (64 bit) and the same error occurs.

      The complete Xorg.0.log:

      My xorg.conf: