Announcement

Collapse
No announcement yet.

"ati" on Intrepid

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • sastraxi
    started a topic "ati" on Intrepid

    "ati" on Intrepid

    I'm looking to get the ati driver with DRI and textured video and such working on my R500 based notebook (X1400). Intrepid comes with the ati driver but no DRI (apparently a DRI version problem).

    (EE) RADEON(0): [dri] RADEONDRIGetVersion faileed because of a version mismatch.
    [dri] radeon.o kernel module version is 8.51.3 but version 1.17.0 or newer is needed.
    [dri] Disabling DRI.

    And I need that for EXA not to be slow, and for "CP" to work for compositing... et cetera et cetera. I'm just not sure what I need to upgrade in order to make sure I don't break my system.

    Not that it would REALLY matter that much, though... It's been installed for a total of an hour!

  • krazy
    replied
    Originally posted by shoofy View Post
    I've gotten most components of compiz working with intrepid on an X1400, but I can't get transparent cube or skydome to work at all. Has anyone else gotten these to work? Is it more likely a compiz issue or a driver issue?
    I'd say compiz, as the kwin cube works well on my X1600 with the intrepid "ati" drivers.

    Leave a comment:


  • shoofy
    replied
    I've gotten most components of compiz working with intrepid on an X1400, but I can't get transparent cube or skydome to work at all. Has anyone else gotten these to work? Is it more likely a compiz issue or a driver issue?

    Leave a comment:


  • tormod
    replied
    ATI cards on laptops are currently blacklisted. If your desktop card doesn't work, it must be a capability issue, I don't think there is any card specific blacklist.

    Leave a comment:


  • sastraxi
    replied
    It's not completely stable -- I think that the enhanced zoom desktop manages to crash my desktop most times I use it. Could be the reason for it still being blacklisted. Agreed though it might be nice to have it un-blacklisted for the release.

    Leave a comment:


  • oibaf
    replied
    I tried intrepid alpha 4 LiveCD and I was expecting to have compiz working out of the box with my R500 based card. However I don't get it to work unless I did a (I found that suggestion at http://ubuntuforums.org/showthread.php?t=845236):
    Code:
    mkdir -p ~/.config/compiz/ && echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager
    There is probably some blacklist for my ATI card somewhere (/usr/bin/compiz only blacklist an intel chip).

    Maybe that blacklist should be revised now that 3D is supported in R500.

    Leave a comment:


  • Execute_Method
    replied
    Originally posted by sastraxi View Post
    What prompted me to install fglrx was that it did not work out of the box and put me in software rasterization mode. However having reinstalled the ati drivers and uninstalling fglrx, it works. Which is odd to say the least. I am getting quick 2D (flash player can play full screen. which is a nice change) and, I THINK, textured video. However compiz causes the X server to crash and restart, and that is after SKIP_CHECKS="yes" is added to the environment. Any thoughts on that one?
    have you tried starting compiz with "LIBGL_ALWAYS_INDIRECT=1"

    I had to with my x1650 (rv535)

    Leave a comment:


  • sastraxi
    replied
    Good news! The latest Intrepid update fixed my issue. This means that r500 users have compiz that can work out of the box. Amazing. Now all I need is powerplay!

    Leave a comment:


  • sastraxi
    replied
    What prompted me to install fglrx was that it did not work out of the box and put me in software rasterization mode. However having reinstalled the ati drivers and uninstalling fglrx, it works. Which is odd to say the least. I am getting quick 2D (flash player can play full screen. which is a nice change) and, I THINK, textured video. However compiz causes the X server to crash and restart, and that is after SKIP_CHECKS="yes" is added to the environment. Any thoughts on that one?

    Leave a comment:


  • RealNC
    replied
    At least for Windows there are cleaning tools to wipe out all the left-behind junk from ATI :P

    Leave a comment:

Working...
X