No announcement yet.

AMD Catalyst 8.6 Linux Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • I can confirm that there are no "special" or hidden settings in the BIOS of the GA EP45-DS4. Pressing CTRL+F1 in the main BIOS screen does not unlock anything at all. All available settings are accessible by default. And the BIOS has no memory management options that allow remapping or anything similar.

    Anyway, I decided to keep the HD4870 but sent my GA EP45-DS4 back today. I will collect some more information over the week but most probably get myself a X38 based mainboard. But not a Gigabyte again. There were far too many things that annoyed me (the memory access problem, slow boot, several restarts after changes in the BIOS and the fact that it lost its connection to my firewall (or vise-versa) when I turned my box off).


    • the new ati linux driver 8.6 and diablo 2 lod, starts with half screen


      With the new ati linux driver 8.6 the problems with opengl-applications are fixed, but now i cannot play diablo 2 lod with linux and the driver 8.6, because the game starts in a half screen and not correctly. This Problem has started with the release of this ati linux driver 8.6, with 8.4 and 8.5 there was not this problem with diablo 2 lod(version 1.12a). I hope, that with the new release of the ati linux driver 8.7 the problem is fixed...


      • Got totally burned with this driver. Got myself a Radeon HD 4870 and now everything I get are random crashes on starting X, doing common things like moving cursor around or shutting X down.

        - Asus M3N-HT Deluxe ( nForce 780a SLI )
        - AMD Athlon 64 X2 6400+ ( Windsor )
        - 2x 1GB Kingston HyperX DDR2-1066 CL5
        - Sapphire Radeon HD 4870 ( 512MB )

        Tried anything on my Gentoo amd64 machine but nothing helped. I looked through this topic but it can not be memory problem since I have only 2GB and it is recognized as one 2GB memory chunk. I also tried 1.4.* version of X-Org yet still I can't blink my eyes before this crap locks up again... HARD!

        Can't be true to state your drivers support your new cards and all you get are endless lockups. What could cause this? Why does it not work? Anything "special" you have to know about this driver to get it working? I used no fancy setups ( as the editors here used it out-of-the-box as they claimed ).


        • 8.7 has been released yesterday. Have you tried it yet?


          • I've to wait until it's in portage. I tried once installing ati-drivers manually into Gentoo and this cause huge havoc.


            • I know what you mean

              I'm waiting for 8.7 to appear in Arch Linux AUR too.


              • I tried now Kubuntu 8.04.1 64bit with the 8.7 driver ( since the initial Gentoo install had anyways been wrecked already so I can also play around a bit ) and it still freezes on me midst while doing innocent things like moving windows.

                EDIT: Tried kicking off UT2k4 Demo. Freezes on the nVidia logo ( rofl... how ironical you driver coder heros U_U ). Looks like 3D freezes. Not really usable so far... damn it.
                Last edited by Dragonlord; 22 July 2008, 04:26 PM.


                • Hi,
                  Since catalyst 8.3 i have this problem with new catalyst.
                  I have connect PC to TV (dvi-hdmi) and there is a black border aroud. It is in all resolution. When i change ref. rate from 60Hz to 50Hz i doesn't help.Only in res. 1920x1080_30Hz all is correct but this ref. rate is to small.