No announcement yet.

Catalyst 8.5 not compiling on Hardy 64-bit

  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 8.5 not compiling on Hardy 64-bit

    I get this error when I tried to compile:
    dpkg-shlibdeps: warning: symbol XauFileName used by debian/xorg-driver-fglrx/usr/sbin/atieventsd found in none of the libraries.
    dpkg-shlibdeps: warning: debian/xorg-driver-fglrx/usr/sbin/atieventsd shouldn't be linked with (it uses none of its symbols).
    dpkg-shlibdeps: failure: couldn't find library needed by debian/xorg-driver-fglrx/usr/bin/fglrx_xgamma (its RPATH is '').
    Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
    To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
    dh_shlibdeps: command returned error code 512
    make: *** [binary] Error 1
    dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
    How do I fix it?
    Why can't it find ''? Obviously this library is part of the Ati driver. Are the scripts broken?

  • #2
    I found 2 solutions:

    Solution A:
    Instead of
    sudo sh --buildpkg Ubuntu/hardy
    sudo sh --buildpkg Ubuntu/8.04
    Solution B:
    doing little googling and found a solution:

    Extract the archive and navigate to the new folder:
    sudo sh --extract driver
    cd driver
    Navigate to where the libs are for 64 bit and make a symlink
    cd arch/x86_64/usr/X11R6/lib64
    ln -s
    Build the package(the command doesn't contain errors the script just behaves wrongly):
    cd cd /home/<username>/driver
    sudo sh -- --buildpkg Ubuntu/hardy
    replace <username> with your username

    It built the packages and they installed. But after reboot the monitor goes black. I switch to a console, login and do a "dmesg|grep fglrx". 5-10 lines come up and they that the driver is loaded and working!!!

    Do you know how to solve this problem now?
    Last edited by SledgeHammer_999; 24 May 2008, 07:30 AM. Reason: Corrected an error in the last command


    • #3
      I found for that too. But for me is a bit strange:

      sudo modprobe -r radeon
      sudo modprobe fglrx
      I restarted X and it worked!!! And I only had to do it once(why?!?!?)
      But I have another problem:
      It displayer everything in 1920*1080. My monitor's manual says that it can go only up to 1024*768. Even the Catalyst for Windows recognize it up to 1024*768. Even older versions of Linux catalyst.

      What lines should I put to my xorg.conf file to limit the available resolutions to 1024*768?
      Last edited by SledgeHammer_999; 23 May 2008, 03:17 PM.


      • #4
        So you were actually able to use the driver???

        I worked my way through this whole installation process and everything seemed to compile and install properly?no error messages?but when I restart X server, the display hangs after the restart, probably because of the very high resolution setting (my monitors limit is 1600X1280).

        So my question is were you actually able to use Ubuntu after you did modprobes or does your display hang too? Also did you ever learn how to reset the resolution to a different value?


        • #5
          Add the desired resolution to xorg.conf. Fglrx sets my monitor to 1920x1200 despite it being only able to do 1680x1050. If I specify that max resolution in xorg.conf, then fglrx uses that as the default.


          • #6
            yeah luckily I found a fix for that too(thank god I'm not the only one having problems with the resolution)

            in older versions of ubuntu all you had to do was
            sudo dpkg-reconfigure -phigh xserver-xorg
            But those idiots have removed the resolution-related-stuff from 'dpkg-reconfigure' and put it into 'displayconfig-gtk'
            sudo displayconfig-gtk
            And I say idiots because you cannot run a GUI app when you don't have a screen. The 'dpkg-reconfigure' worked nice in the console.

            How you solve that? Change the driver to 'vesa', boot into gnome(GUI), run displayconfig-gtk,select an appropriate monitor, change back the driver to 'fglrx', reboot.

            For me I had to run displayconfig-gtk multiple times in order to apply the new selections.

            If you don't know how to change the driver to 'vesa' then tell me to write more instructions.

            PS. vesa is not mandatory, use anything that gives you access to GUI.


            • #7
              Max res line

              So I just add a line like the one below??

              Maximum resolution = 1600X1280



              • #8
                Here are my fglrx sections in xorg.conf:
                Section "Monitor"
                    Identifier   "aticonfig-Monitor[0]-0"
                    Option        "VendorName" "ATI Proprietary Driver"
                    Option        "ModelName" "Generic Autodetecting Monitor"
                    Option        "DPMS" "true"
                Section "Device"
                    Identifier  "aticonfig-Device[0]-0"
                    Driver      "fglrx"
                    BusID       "PCI:1:0:0"
                Section "Screen"
                    Identifier "aticonfig-Screen[0]-0"
                    Device     "aticonfig-Device[0]-0"
                    Monitor    "aticonfig-Monitor[0]-0"
                    DefaultDepth     24
                    SubSection "Display"
                        Viewport   0 0
                        Depth     24
                        Modes      "1680x1050"
                You add the resolution under the Display subsection of the Screen section.


                • #9

                  Thanks to both of you?I'll give it a try back later in the day when I have some time!

                  Thanks again!


                  • #10
                    EDIT: I am refering to your earlier post

                    Obviously you need more instructions:

                    1.boot normally and when your display hangs press "Ctrl+Alt+F1"
                    sudo cp /etc/X11/xorg.conf /etc/X11.xorg_mybackup
                    sudo nano /etc/X11/xorg.conf
                    5. scroll down (with the down arrow key) and replace [quote]Driver "fglrx"[/quote[ with
                    Driver "vesa"
                    6. Press Ctrl+O to save and Ctrl+X to exit.
                    7. reboot
                    8. now your screen shouldn't hang. login and run
                     sudo displayconfig-gtk
                    9. choose the required settings.
                    nano /etc/X11/xorg.conf
                    and replace 'vesa' back to 'fglrx'
                    11.reboot and everything should work.

                    PS. If you made a mistake with the xorg.conf file you can restore the bakcup you make earlier with
                    sudo cp /etc/X11/xorg.conf_mybackup /etc/X11/xorg.conf