Announcement

Collapse
No announcement yet.

AMD Catalyst 8.5 For Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Kano View Post
    I highly doubt that this kernel is xen enabled.
    Seems like I'm not the only one that it works for.

    http://blog.creonfx.com/linux/how-to...ernel-with-xen

    Comment


    • Maybe that works for 2.6.25 but not for 2.6.24 server kernel from hardy. Try if you like.

      Comment


      • big desktop screwed

        I used 8.4 in big desktop mode, with two screens. One is 1680x1050, the other 1280x1024. This worked almost perfectly. But after updating to 8.5 the 1280-screen only shows a distorted image. It seems the driver refuses to drive two panels with different resolutions.

        Neither AMDCCCLE nor aticonfig can solve the problem.

        I had to downgrade to 8.4 again.

        Anyone else had this problem, and maybe found a solution?

        I can't tell you how much I beg for decent xrandr support in fglrx! Xrandr would also reduce the hassle of switching screen configs and resolutions when using a projector. This is a major problem for me, because I have to use my laptop (with X1300 mobility gfx) for presentations!

        Comment


        • I'm also running a primary 1680x1050 monitor + secondary 1280x1024 monitor, and in 8.5 I have to re-set the resolution to "2960x1050" twice before everything is OK. It seems that it tries to run the second panel at 1400x1050 resolution, even though I "force" it to run 1280x1024???

          Comment


          • Originally posted by grigi View Post
            I'm also running a primary 1680x1050 monitor + secondary 1280x1024 monitor, and in 8.5 I have to re-set the resolution to "2960x1050" twice before everything is OK.
            Do you use aticonfig for that?

            The funny thing is that with 8.4, xrandr -q tells me that the resolution is 3360x1050, but the windowmanager (kwin) correctly uses only the available area on the second screen (1280x1024). Except for the mouse pointer which can move beyond the screen limit, but I can live with that

            With 8.5 and the same xorg.conf, it tries to use the 1680 res on the second screen as well, and the panel tries to interpolate it, with little success.

            Please, ATI, give us full xrandr support with true dynamic switching of resolution and display mode! Please!

            Comment


            • I just want to add that I have problems playing games with my X1950XTX card with the 8.5 drivers and Kubuntu Hardy KDE 3.5.9

              I'm getting artifacts (polygon-mesh vertex positions gets messed up). Very irritating. This happens in TMNationsForever (run under Wine), Beyond the Red Line. I've seen a very little in Doom3 but not much.

              Sample: http://pici.se/273510/

              Maybe I should notice you that I've installed the 8.5 drivers like this:
              Code:
              sh ati-driver-installer-8-5-x86.x86_64.run --buildpkg Ubuntu/Hardy
              sudo dpkg -i fglrx-amdcccle_8.493.1-0ubuntu1_i386.deb fglrx-kernel-source_8.493.1-0ubuntu1_i386.deb xorg-driver-fglrx_8.493.1-0ubuntu1_i386.deb
              It seemed the installation worked very well.
              Last edited by Vantskruv; 27 May 2008, 11:57 AM.

              Comment


              • No, I set the options in xorg.conf
                Then import the options to aticonfig:
                aticonfig --input=/etc/X11/xorg.conf --tls=1

                Section "Device"
                Option "MonitorLayout" "LVDS,AUTO"
                Option "PairModes" "1680x1050+1280x1024"
                Option "EnableMonitor" "auto"

                And the 2 screens:

                Section "Screen"
                Identifier "aticonfig-Screen[0]"
                Device "aticonfig-Device[0]"
                Monitor "aticonfig-Monitor[0]"
                DefaultDepth 24
                SubSection "Display"

                #Virtual 2960 1050
                Viewport 0 0
                Depth 24
                Modes "1680x1050" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
                EndSubSection
                EndSection

                Section "Screen"
                Identifier "aticonfig-Screen[1]"
                Device "aticonfig-Device[1]"
                Monitor "aticonfig-Monitor[1]"
                DefaultDepth 24
                SubSection "Display"
                Viewport 0 0
                Depth 24
                Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
                EndSubSection
                EndSection

                I have the same issue with KDE knowing where the screen borders are, but that the mouse can go to far. xrandr defaults to 3360x1050, but I just set it to 2960x1050 after every bootup. The issue with Catalyst 8.5 is that it messes up on the second monitor, until I set the resolution again. Then, it works fine again...


                Vantskruv: Try disabling Catalyst AI, AI is a new option on the 8.5 driver, that seems to cause graphical glitches on some systems.

                Comment


                • Originally posted by metala View Post
                  I installed brand new Debian/lenny amd64.
                  ...
                  When I start the X with fglrx driver, system hangs. Blank/black screen.
                  ...
                  CPU: Intel E6750
                  MB: Asus P5K (1006 BIOS version) (P35 Chipset + ICH9)
                  VC: Sapphire 2600 XT 256MB GDDR3

                  Thanks in advance.
                  Please read this thread. There is a issue between Asus mainboards and fglrx. Please report if changing the mtrr table fix your problem.

                  Comment


                  • Originally posted by djdoo View Post
                    Hey man read a couple of posts before...

                    SET TexturedXrender to "false" or "off"!!!

                    Then as su give aticonfig --input=/etc/X11/xorg.conf --tls=1
                    Then restart X and you will find out what am I talking about...
                    Didn't change a thing.

                    Regards

                    Andr?

                    Comment


                    • Originally posted by djdoo View Post
                      Hey man read a couple of posts before...

                      SET TexturedXrender to "false" or "off"!!!

                      Then as su give aticonfig --input=/etc/X11/xorg.conf --tls=1
                      Then restart X and you will find out what am I talking about...
                      Are you sure it works on your box?

                      Comment

                      Working...
                      X