Announcement

Collapse
No announcement yet.

Installing latest Open Source ATI drivers under Ubuntu 8.04

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Originally posted by greebothecat View Post
    Did I miss something important?
    I don't see anything obvious. Can you please try the live CD? I also have an X1300 and I tested the live CD successfully today. You'll have to change to "EXA" manually (do that before starting the script).

    Comment


    • #42
      My problems are solved!

      not on live CD
      I simply used System > Administration > Hardware Drivers
      Installed default ati proprietary driver (fglrx)
      Added EXA

      Code:
      [email protected]:~$ glxinfo|grep direct
      direct rendering: Yes
      [email protected]:~$ glxinfo|grep OpenGL
      OpenGL vendor string: ATI Technologies Inc.
      OpenGL renderer string: Radeon X1300 / X1550 Series
      OpenGL version string: 2.1.7412 Release
      OpenGL extensions:
      [email protected]:~$ glxgears
      22872 frames in 5.0 seconds = 4574.399 FPS
      25008 frames in 5.0 seconds = 5001.595 FPS
      25001 frames in 5.0 seconds = 5000.017 FPS
      24960 frames in 5.0 seconds = 4992.000 FPS
      [email protected]:~$
      Compisite and AIGLX are both on and Compiz works, FPS around 3000 now

      not sure how this happened ^^
      Last edited by greebothecat; 06-06-2008, 03:12 PM.

      Comment


      • #43
        first post here guys.
        I have a x1800gto R520 [Radeon X1800]
        i followed post #1 to the letter and yet when i reboot i get a black screen when using the ati driver. when i change the driver to radeonhd the computer boots fine. any reason that this could be happening. and this is on a fresh install. installed ubuntu. update/upgrade , reboot and then did everything in post #1.
        thanks alot in advance

        Comment


        • #44
          Originally posted by funnypanks View Post
          first post here guys.
          I have a x1800gto R520 [Radeon X1800]
          i followed post #1 to the letter and yet when i reboot i get a black screen when using the ati driver. when i change the driver to radeonhd the computer boots fine. any reason that this could be happening. and this is on a fresh install. installed ubuntu. update/upgrade , reboot and then did everything in post #1.
          thanks alot in advance
          try adding

          Code:
          Section "Extensions"
          	Option		"Composite"	"0"
          EndSection
          to xorg.conf, I had the same problem but screen was white

          Comment


          • #45
            Originally posted by greebothecat View Post
            try adding

            Code:
            Section "Extensions"
            	Option		"Composite"	"0"
            EndSection
            to xorg.conf, I had the same problem but screen was white
            thanks but it looks like the videocard stops sending a signal altogether. the monitor goes into suspend mode. pressing buttons and doesnt wake it. and the comp is still on.

            Comment


            • #46
              As the author of the packages being used, I can not recommend the procedure in post #1. Please use the live CD script that I posted in another thread, that's a safe and reproducible way of testing. If that works, see inside the script for how to install permanently. If you don't understand enough to figure it out from there, maybe installing experimental packages is not recommended for you

              Comment


              • #47
                Last time it worked better but now i don't get GUI. Only textmode.
                Errors:
                Errno 104: unable to connect to xserver
                Errno 3: server error

                Dunno if this is related but this week i got 2 new kernels. I'm using ...19 now. I just installed these drivers so it went fine.

                Got it fixed... one endsection was missing.
                Last edited by mal13; 06-08-2008, 08:03 AM. Reason: Add info

                Comment


                • #48
                  Don't forget to run the easy-drm-modules-installer after every kernel update. And use the drm sources corresponding to the libdrm2 that you have installed. So if you got libdrm2 from the xorg-edgers archive:

                  1. Add "deb-src http://ppa.launchpad.net/xorg-edgers/ubuntu hardy main" to your /etc/apt/sources.list and run "sudo apt-get update"
                  2. Standing in the same directory as where you have easy-drm-modules-installer, run
                  Code:
                  apt-get source libdrm2
                  ./easy-drm-modules-installer -y radeon

                  Comment


                  • #49
                    Originally posted by tormod View Post
                    As the author of the packages being used, I can not recommend the procedure in post #1. Please use the live CD script that I posted in another thread, that's a safe and reproducible way of testing. If that works, see inside the script for how to install permanently. If you don't understand enough to figure it out from there, maybe installing experimental packages is not recommended for you
                    i just tried that method. right when i press ctrl+alt+f1 the screen goes black and doesn't come back on. it blinks a few times and turns off.

                    Comment


                    • #50
                      Originally posted by funnypanks View Post
                      i just tried that method. right when i press ctrl+alt+f1 the screen goes black and doesn't come back on. it blinks a few times and turns off.
                      Does the live CD boot up with the -vesa or -ati driver with your card? If it's the original -ati driver that breaks on console switching, you can choose "Safe Graphics Mode" on the CD boot menu (press F4) which selects the -vesa driver. You can also try "sudo killall gdm" instead of switching with crtr-alt-f1.

                      Comment

                      Working...
                      X