No announcement yet.

Installing latest Open Source ATI drivers under Ubuntu 8.04

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by oibaf View Post . I would not keep the repositories enabled unless you really need all other packages (note that also an updated experimental xserver is included).
    I'm seeing:

    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/ undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering
    Which I've been told means I need to upgrade my xserver. I re-enabled
    the xorg-edgers source and there is a new xserver-xorg-core, but it looks like it's going to uninstall more than I want:

    $ sudo apt-get install xserver-xorg-core
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    The following packages will be REMOVED:
    ubuntu-desktop xorg xserver-xorg xserver-xorg-input-all
    xserver-xorg-input-evdev xserver-xorg-input-kbd
    xserver-xorg-input-mouse xserver-xorg-input-synaptics
    xserver-xorg-input-vmmouse xserver-xorg-input-wacom
    xserver-xorg-video-all xserver-xorg-video-amd xserver-xorg-video-apm
    xserver-xorg-video-ark xserver-xorg-video-ati
    xserver-xorg-video-chips xserver-xorg-video-cirrus
    xserver-xorg-video-cyrix xserver-xorg-video-dummy
    xserver-xorg-video-fbdev xserver-xorg-video-geode
    xserver-xorg-video-glint xserver-xorg-video-i128
    xserver-xorg-video-i740 xserver-xorg-video-i810
    xserver-xorg-video-imstt xserver-xorg-video-intel
    xserver-xorg-video-mga xserver-xorg-video-neomagic
    xserver-xorg-video-newport xserver-xorg-video-nsc
    xserver-xorg-video-nv xserver-xorg-video-openchrome
    xserver-xorg-video-radeonhd xserver-xorg-video-rendition
    xserver-xorg-video-s3 xserver-xorg-video-s3virge
    xserver-xorg-video-savage xserver-xorg-video-siliconmotion
    xserver-xorg-video-sis xserver-xorg-video-sisusb
    xserver-xorg-video-tdfx xserver-xorg-video-tga
    xserver-xorg-video-trident xserver-xorg-video-tseng
    xserver-xorg-video-v4l xserver-xorg-video-vesa xserver-xorg-video-vga
    xserver-xorg-video-via xserver-xorg-video-vmware
    I don't mind removing all the drivers I don't need, but I suspect I need mouse, ubuntu-desktop and such to stay. So, that doesn't seem like the route to go for a new xserver.

    Any suggestions how to resolve the AIGLX issue?

    Again, I'm just trying to get compiz working like I had before.
    I might be asking for too much at this point.

    When I do try and start compiz I get:

    There is no available graphics driver for your system which
    supports the composite extension.
    Checking for Xgl: not present.
    Found laptop using ati driver.
    aborting and using fallback: /usr/bin/metacity
    Which I assume is because of the AIGLX failure.


    • #22
      mal13, freetime: the xserver packages from "PPA for xorg crack pushers" appear to be too experimental to use now. This is why this is only suggested with a big "WARNING" in the guide and no detailed procedure. We'll better wait until the newer xserver packages land in intrepid and get backported in the "PPA for xorg crack pushers".

      If you follow exactly the suggested procedure you should not have any problem.
      Last edited by oibaf; 28 May 2008, 04:57 AM.


      • #23
        Hi radeon-fans,
        I finally bit the bullet and registered to YetAnotherForum, since I discovered your thread and was itching to give some explanations and corrections.

        Thanks for a nice step-by-step how-to, but I really miss what should be number one: Read the web pages that are linked to before starting running the commands. I update those web sites regularly and things in this thread might get obsolete and wrong. This is the danger of providing too detailed steps, people just follow them without understanding the full picture.

        In general, is the entry point for this stuff.

        About the repositories:
        The ~tormodvolden repo contains driver updates to be used together with normal Ubuntu releases. I also have other packages in the repo, but nothing that hurts.

        The ~xorg-edgers repo (please see is for up-to-date packages of Xorg drivers, servers, libraries. You might keep that repo in your settings, but you will live on the edge for good and bad.

        So far I have uploaded the xserver-xorg-core 1.5 RC which is less experimental than the server git master head, and much less experimental than the mesa I uploaded. Maybe I'll update the server later, but for now 1.5 will do.

        The newest mesa needs server 1.5 to work fully. They go hand in hand, and in fact the old 1.4 server can not be built with the new mesa. Also, the new 1.5 server needs input and video drivers built for it, so the old installed drivers or the one in the ~tormodvolden repository will probably not work (well). In fact, the package system will ask to remove the old drivers when you install the new server. I have built -mouse and -kbd input drivers so far, in addition to the most common video drivers.

        The recommanded way of using the repository is from a live CD. This ensures a stable, reproducible platform, and I have a script to do all the downloads and installation with a single command. I'll post the instructions in a separate thread, since this can be interesting for people using other distributions as well.

        If everything works fine, you might go on and install the packages in your normal Ubuntu 8.04 installation. You just have to rerun the kernel module installer after every kernel upgrade.

        Hope this can be of help to you and that your testing can be of help to the Xorg developers!
        Last edited by tormod; 29 May 2008, 05:23 AM. Reason: link to live CD thread


        • #24
          Originally posted by tormod View Post
          Hi radeon-fans,
          Hi, thanks for your packages

          Just to let you know that mesa packages appears to be working very well here. The only problem is that AIGLX won't work with 8.04 default xserver, but this is not a problem for (at least) r500 users since AILGX never worked even before.

          The xserver packages, instead, seem to have some bigger problem: see e.g. comment #21 of this thread.

          Anyway, thanks for your suggestions.


          • #25
            Originally posted by oibaf View Post
            The xserver packages, instead, seem to have some bigger problem: see e.g. comment #21 of this thread.
            It's not really a problem. You just have to install the new -kbd and -mouse drivers from the repo. See how the live CD script does it. The drivers that will be removed are mostly for other graphic cards. The only things you might miss are the -synaptic and -evdev drivers, but the -mouse driver is enough and works on my laptop touchpad. (ubuntu-desktop is not critical either, it's just a meta-package.)


            • #26
              3d works, compiz on new xserver freezes


              Just to let know.

              I decided to experiment a bit this evening with my X1300 PCIE, so I installed all the stuff as described here and on

              The steps 1 t/m 4 of the xorg-edgers go well (3d works, nexuiz too), but the newer xserver causes my x server to freeze if I enable compiz.

              I will revert to the normal x server and wait a bit. But great work, since it is far more stable then fglrx was (only a bit slower)

              Keep up the great work!!


              • #27

                I have both of your repositories in my sources and do the upgrades all the time. I'm on 64-bit. I still don't get the right mesa drm driver. Do your latest packages include the r500 stuff? Is this supposed to work on 64-bit?

                I get some errors/warnings when I apg-get upgrade. For example, just now:

                The following packages have been kept back:
                f-spot xserver-xorg-core xserver-xorg-dev xserver-xorg-input-kbd
                xserver-xorg-input-mouse xserver-xorg-video-ati xserver-xorg-video-ati-dbg
                xserver-xorg-video-radeonhd xserver-xorg-video-radeonhd-dbg
                The following packages will be upgraded:
                cpp evolution evolution-common evolution-data-server
                evolution-data-server-common evolution-plugins g++ gcc gdb gij
                libcamel1.2-11 libebook1.2-9 libecal1.2-7 libedata-book1.2-2
                libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8
                libegroupwise1.2-13 libexchange-storage1.2-3 libgcj-bc libgcj-common
                libgdata-google1.2-1 libgdata1.2-1 libgl1-mesa-dri libgl1-mesa-glx
                libglu1-mesa libmysqlclient15off mesa-utils mysql-common x11proto-core-dev
                x11proto-input-dev x11proto-xext-dev

                I don't know if it's holding back the regular ubuntu X packages or your newer ones.


                • #28
                  I think you forgot step 2 on

                  You can read in the first post of this topic how to do that (together with the rest of the steps 1 till 4). For the further steps on the xorg edgers page you need a new xserver, as descibed there.

                  Do it only if you have some idea of what you are doing (or accept the consequences).

                  Mal13 (page 2):
                  Try to deinstall fglrx.


                  • #29
                    Originally posted by allartk View Post
                    I think you forgot step 2 on

                    You can read in the first post of this topic how to do that (together with the rest of the steps 1 till 4). For the further steps on the xorg edgers page you need a new xserver, as descibed there.

                    Do it only if you have some idea of what you are doing (or accept the consequences).
                    No, I did run the drm install script. It's the user-level mesa code that's the problem. It seems to not be using the new r500 mesa code (or maybe the new code still doesn't know about my chip id).


                    • #30
                      do you have fglrx installed?