Announcement

Collapse
No announcement yet.

Legacy ATI fglrx Drivers on Fedora Core 6 Zod (DISCUSSION)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Michael
    replied
    The unknown symbol error is likely why you are still getting Mesa, as those unknown symbol errors are due to incompatibility with the Linux 2.6.20 kernel. I can sync the firegl_public code this month with 8.36 and see if it will work with 8.28.8 due to proper 2.6.20 support.

    Leave a comment:


  • hyperplus
    replied
    Hi All!

    I know is my first post, but I have been following all the threads and still can get it completely working.

    I have Dell 600m with an ATI Mobility Radeon 9000 for which I am trying to install driver 8.28.8 (which is the last version that with support for my card).

    My kernel info is:
    [[email protected] ~]# rpm -qa kernel*
    kernel-module-ATI-fglrx-2.6.20-1.2933.fc6-8.28.8-1.fc6
    kernel-headers-2.6.20-1.2933.fc6
    kernel-2.6.20-1.2933.fc6
    kernel-devel-2.6.20-1.2933.fc6

    Driver performance ATI > Mesa?

    After using the script and getting the *.rpm files install when I look at fglrxinfo says the vendor is Mesa and not ATI. Why is that and how can I fix it?

    Also I currently have the "Unknown symbol firegl_.." issues reported. Will that be fix when I get the ATI driver install correctly?

    Let me know if you need more info.
    thanks

    Leave a comment:


  • Michael
    replied
    It looks like the 8.35 firegl_public may the not work with the 8.35 driver... still investigating.

    Leave a comment:


  • Nikola_
    replied
    Michael, can u help me please?
    I have FC6 with 2.6.20 kernel, and a lot problems making my ATI Radeon 9250 fglrx driver work.
    I have installed 8.28.08 drivers with ur script, and this is my out:

    fglrxinfo:
    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
    LIBGL_DEBUG=verbose fglrxinfo:
    Code:
    libGL error: XF86DRIQueryDirectRenderingCapable returned false
    libGL error: XF86DRIQueryDirectRenderingCapable returned false
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
    dmesg:
    Code:
    fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
    fglrx: Unknown symbol firegl_cail_powerdown
    fglrx: Unknown symbol firegl_cail_powerup
    fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
    fglrx: Unknown symbol firegl_cail_powerdown
    fglrx: Unknown symbol firegl_cail_powerup
    and my xorg.conf
    Code:
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    	Load  "dri"
    	Load  "glx"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "Monitor"
    
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
    	Identifier   "Monitor0"
    	ModelName    "LCD Panel 1280x1024"
    	HorizSync    31.5 - 67.0
    	VertRefresh  50.0 - 75.0
    	Option	    "dpms"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "fglrx"
    	Option	    "DesktopSetup" "clone"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1280x1024"
    	EndSubSection
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "Disable"
    EndSection
    also my Xorg.0.log
    Code:
    (II) Loading extension ATIFGLRXDRI
    (II) fglrx(0): doing DRIScreenInit
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    [drm] failed to load kernel module "fglrx"
    (II) fglrx(0): [drm] drmOpen failed
    (EE) fglrx(0): DRIScreenInit failed!
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    its quite anoying making this card work, only distro i made it work properly is Ubuntu 6.10, and u can just imagine what horror i had trying make it work in Slackware 11.0

    I really dont have money to buy some nvidia card now, and i literaly BEG u help me fix this problem

    Thanx

    Leave a comment:


  • wintermute
    replied
    Thread jump : radeon 9250+8.28.8 driver+FC6+dri+dual-head=1 head, no dri

    This post below was in the sticky thread for ATI drivers. I post it here, because it seems a more suitable thread.


    Well... I did "aticonfig --initial --force" as you told me, and it's not working either.
    I tried some more aticonfig debugging, here's what I have when I do a :

    aticonfig --dtop=horizontal --screen-layout=left --effective=now

    Error: Can't change option 'DesktopSetup' for running session.
    aticonfig: checking command options failed.
    and a :

    aticonfig --list-pairmode

    Get pair modes : 0
    and a :

    aticonfig --add-pairmode=12800x10240+12801x10241

    FGLRX_AddPairMode failed when try to add mode : 12800x10240+12801x10241
    Using xorg.conf
    Saved back-up to xorg.conf.fglrx-10
    and this :

    aticonfig --enable-monitor=crt1,tmds2

    ati_dm: FGLRX_EnableDisplays failed when try to enable display: 21.
    Using xorg.conf
    Saved back-up to xorg.conf.fglrx-11
    I forgot to mention that I have the same Xorg.0.log warnings, the same glxinfo and fglrxinfo as previously posted.

    Any idea Michael... or anyone ?

    Leave a comment:


  • MikeL
    replied
    I was not intentionally running the fc6PAE kernel-- it just sort of jumped on me while I wasn't looking.

    Anyway, I switched to the newest non-PAE kernel in the repo, and built the RPMs. Worked like a charm. Thanks a lot.

    Leave a comment:


  • Michael
    replied
    Originally posted by MikeL View Post
    Ah, figured I forgot something

    Anyway:
    2.6.18-1.2849.fc6PAE and a Radeon 9200SE.
    Oops, missed the kernel version in your previous message.

    Try running the legacy script again, I just updated the firegl_public code today but have just reverted it to the previous copy to see if that solves the issue.

    If that doesn't work, can you try updated your kernel (a newer one was released into the updates repo earlier this week)? And are you intentionally running the fc6PAE kernel?

    Leave a comment:


  • MikeL
    replied
    Ah, figured I forgot something

    Anyway:
    2.6.18-1.2849.fc6PAE and a Radeon 9200SE.

    Leave a comment:


  • Michael
    replied
    Originally posted by MikeL View Post
    I am unable to load the FGLRX kernel module for some reason.

    [[email protected] ~]# modprobe -i fglrx
    FATAL: Error inserting fglrx (/lib/modules/2.6.18-1.2849.fc6PAE/extra/fglrx/fglrx.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    [[email protected] ~]# dmesg | tail
    fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
    fglrx: Unknown symbol firegl_cail_powerdown
    fglrx: Unknown symbol firegl_cail_powerup
    [[email protected] ~]#


    Any suggestions?
    What kernel and graphics card are you using?

    Leave a comment:


  • MikeL
    replied
    I am unable to load the FGLRX kernel module for some reason.

    [[email protected] ~]# modprobe -i fglrx
    FATAL: Error inserting fglrx (/lib/modules/2.6.18-1.2849.fc6PAE/extra/fglrx/fglrx.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    [[email protected] ~]# dmesg | tail
    fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
    fglrx: Unknown symbol firegl_cail_powerdown
    fglrx: Unknown symbol firegl_cail_powerup
    [[email protected] ~]#


    Any suggestions?

    Leave a comment:

Working...
X