Announcement

Collapse
No announcement yet.

New RadeonHD driver and 3870 x2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • gotthard
    started a topic New RadeonHD driver and 3870 x2

    New RadeonHD driver and 3870 x2

    I am new with radeonhd driver and I just want to know is it possible to get 3D support on radeon hd 3870 x2 with new radeonhd driver , I really need 3D support for my card on linux...thanks

  • Kano
    replied
    You need at least basic ASM knowledge for that. Up to 8.40.4 (long ago) it was possible to automatically disable all logo code by replacing all calls with Logo in the name with nops (0x90). But now it seems to work differently.

    Leave a comment:


  • C-MoH
    replied
    Originally posted by Kano View Post
    Well if you want to do what I did before use objdump -d fglrx_drv.so and see what you find. I have absolutely not time/lust to put my ati card back into my pc. Maybe if it would be my x2 card, but not for a stupid X700 SE...
    I will definitely try, as soon as I get back into town. Probably, I will ask for further insight since I haven't yet heard of objdump

    Leave a comment:


  • Kano
    replied
    Well if you want to do what I did before use objdump -d fglrx_drv.so and see what you find. I have absolutely not time/lust to put my ati card back into my pc. Maybe if it would be my x2 card, but not for a stupid X700 SE...

    Leave a comment:


  • C-MoH
    replied
    Thanks, Kano, for the quick and helpful reply. I have XVideo back!!! *cheering*

    I dare to contradict - using the ChipID override (probably correctly this time) and the sed'ed drivers it worked, using ChipID 0x9501. I guess I may have messed up the ChipID command (or the BusID etc) in Xorg.conf the first time around.

    However, I am now at the logo phase - I have browsed the files in /etc/ati, but haven't found anything that would look like a logo-related setting.

    Any hints?

    Leave a comment:


  • Kano
    replied
    Well when you use sed you can not use the chip id override. In that case you have to use it "pure". Or dont sed the fglrx.ko (just reinstall driver) and use chip id override.

    Leave a comment:


  • C-MoH
    replied
    Originally posted by gotthard View Post
    It`s not working on Mandriva so I have installed openSuSE and it is working , I just had to put chipId in xorg.conf and it is ok now
    Unfortunately I have a working gentoo system for like 3 years, so I will not switch distributions. Did you notice anything relevant between Mandriva and OpenSuSE that could help on Gentoo?

    What I did was:
    1. sed'ed the fglrx_drv.so from the X libs.
    2. changed the header in the fglrx module to contain that hardware id (also compiled and installed the module)
    3. started X with ChipID=9501 and without. (Maybe I should try with ChipID=950F?)

    Did I miss anything of relevance?

    Leave a comment:


  • Kano
    replied
    Well I patched out the complete logo code until I discovered that in most cases there is a more easy fix - just to reuse files (in /etc/ati) from other drivers. In your case you would need a logo hack, but will not look into that. Currently I do not even put my old ATI card back in my pc, the new 8800 GTS is just too nice

    Leave a comment:


  • gotthard
    replied
    It`s not working on Mandriva so I have installed openSuSE and it is working , I just had to put chipId in xorg.conf and it is ok now Thank you very much

    P.S.
    I have a in a bottom right corner AMD Logo and it says Unsupported hardware, is there any chance to remove it

    Leave a comment:


  • Kano
    replied
    Did you recompile the kernel module after the change of the header file?

    Leave a comment:

Working...
X