Announcement

Collapse
No announcement yet.

AMD Catalyst 8.3 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • pchev
    replied
    Originally posted by Vighy View Post
    but why i still get the issue of the 8.1: the one that blocks Xorg and puts the cpu at 100% when killing X !?
    wasn't it fixed in 8.2!?
    maybe this can help you :
    http://www.phoronix.com/forums/showp...&postcount=126

    Leave a comment:


  • rahlquist
    replied
    Crud I always have issues getting these drivers running. Currently this is my error;
    Code:
    (II) LoadModule: "glx"
    (WW) Warning, couldn't open module glx
    (II) UnloadModule: "glx"
    (EE) Failed to load module "glx" (module does not exist, 0)
    and
    Code:
    [[email protected] ~]# fgl_glxgears
    Using GLX_SGIX_pbuffer
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't get an RGBA, Double-buffered visual
    Segmentation fault (core dumped)
    [[email protected] ~]#  fglrxinfo
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual!
    
    Segmentation fault (core dumped)
    [[email protected] ~]# locate libGL.
    /usr/lib/libGL.so
    /usr/lib/libGL.so.1
    /usr/lib/ati/FGL.renamed.libGL.so.1.2.8.452.1
    /usr/lib/ati/libGL.so
    /usr/lib/ati/libGL.so.1
    /usr/lib/ati/libGL.so.1.2
    /usr/lib/ati/libGL.so.1.2.8.452.1
    /usr/lib/mesa/libGL.so.1
    /usr/lib/xorg/FGL.renamed.libGL.so.1.2
    /usr/lib/xorg/libGL.so
    /usr/lib/xorg/libGL.so.1
    /usr/lib/xorg/libGL.so.1.2
    Any thoughts or suggestions?

    Leave a comment:


  • tiagobt
    replied
    Originally posted by bridgman View Post
    Thiago, the issue here is that you are using the overlay under a compositing manager. Here's what happens :

    1. Video driver paints a rectangle in the video window in a solid "key" colour (eg. magenta).

    2. Display circuitry switches to use the image stored in the overlay area whenever it sees the key colour. Video driver displays video in the overlay area.

    3. Compositing manager writes over your nice key colour rectangle with desktop background, killing your video image.

    4. When you move the window, the key colour rectangle is redrawn, so video reappears briefly until the compositing manager wipes it out again.

    There are different ways to stop the compositing manager from stomping your video window. One is to switch away from KDE/Compiz when playing video by wrapping the player app in a short script, another is to play full screen and tell KDE/Compiz to stop doing its compositing thing when you have a full screen app.

    The real solution is to use the Textured Video option since that *can* work with a compositing manager, but I don't think the TexturedVideo option works with tvtime right now. We support one set of video formats, tvtime supports another set of video formats, and there seems to be no common ground today.

    Compiz has a video plug-in which AFAIK uses OpenGL to display video under the compositor, but I think it needs a player patch (at least it does for mplayer).
    Thanks a lot for the explanation. I always wondered why that happened. I tried using TexturedVideo but, as you said, tvtime doesn't seem to support it. Kaffeine (xv) works, but flickers a bit.

    I often use tvtime in a window (as opposed to full screen), so the best solution for me would be wrapping the player app in a script that turns the effects off. Is there a tutorial/guide that explains how to do that?

    Just one more thing I'm curious about. Some time ago, I used to have Compiz Fusion running under XGL, using an older version of fglrx. XGL was not perfect either, but I remember having tvtime working with effects enabled. How did that happen? What's the difference between the two approaches?

    Thanks once again,
    Tiago

    Leave a comment:


  • Vighy
    replied
    but why i still get the issue of the 8.1: the one that blocks Xorg and puts the cpu at 100% when killing X !?
    wasn't it fixed in 8.2!?

    Leave a comment:


  • damentz
    replied
    - black screen with modelines (it was only a joke in the release notes that these would work some time ago, a bad one however)
    They probably had their calendar ahead a month or so and thought it was april fools.

    Leave a comment:


  • Andrew_S
    replied
    XGL + compiz fusion

    It seems that XGL + Compiz fusion with ati driver 8.40.4 no longer works, XGL support is droped in compiz ???

    Leave a comment:


  • hehe2
    replied
    Hi,

    got a crash with ati drivers and 3870

    (as described here)

    Need help please ... ;(

    Leave a comment:


  • bridgman
    replied
    Originally posted by tiagobt View Post
    Is anyone able to use XVideo with KDE effects enabled (or Compiz Fusion)? Tvtime works fine when the effects are off, but the screen gets blank as soon as I enable them. I found interesting that the image shows up when I move the window, even with effects enabled. I have an ATI Radeon X550 and I'm using AMD Catalyst 8.3 under Kubuntu Linux (KDE 4.0.2).
    Thiago, the issue here is that you are using the overlay under a compositing manager. Here's what happens :

    1. Video driver paints a rectangle in the video window in a solid "key" colour (eg. magenta).

    2. Display circuitry switches to use the image stored in the overlay area whenever it sees the key colour. Video driver displays video in the overlay area.

    3. Compositing manager writes over your nice key colour rectangle with desktop background, killing your video image.

    4. When you move the window, the key colour rectangle is redrawn, so video reappears briefly until the compositing manager wipes it out again.

    There are different ways to stop the compositing manager from stomping your video window. One is to switch away from KDE/Compiz when playing video by wrapping the player app in a short script, another is to play full screen and tell KDE/Compiz to stop doing its compositing thing when you have a full screen app.

    The real solution is to use the Textured Video option since that *can* work with a compositing manager, but I don't think the TexturedVideo option works with tvtime right now. We support one set of video formats, tvtime supports another set of video formats, and there seems to be no common ground today.

    Compiz has a video plug-in which AFAIK uses OpenGL to display video under the compositor, but I think it needs a player patch (at least it does for mplayer).
    Last edited by bridgman; 03-12-2008, 10:51 PM.

    Leave a comment:


  • larry
    replied
    Here's my fglrx report (X1400).

    Running with:
    TexturedVideo "on"
    TexturedVideoSync "on"
    VideoOverlay "off"
    OpenGLOverlay "off"


    Xv is much, much better. The diagonal tearing is gone. That said, there is still some minor tearing, but it's only visible in very high motion scenes. Video is now watchable on my laptop, so my biggest complaint with fglrx has now been taking care of. Awesome.


    Originally posted by NeoBrain View Post
    By the way, has anyone tried to run Warcraft 3 under Wine using 8.3?
    The graphics are quite broken for me, I hope this will get fixed in future fglrx versions... (though it could also be a wine regression, I am using 0.9.57)
    Try adding -opengl to the command line.

    Leave a comment:


  • tiagobt
    replied
    Is anyone able to use XVideo with KDE effects enabled (or Compiz Fusion)? Tvtime works fine when the effects are off, but the screen gets blank as soon as I enable them. I found interesting that the image shows up when I move the window, even with effects enabled. I have an ATI Radeon X550 and I'm using AMD Catalyst 8.3 under Kubuntu Linux (KDE 4.0.2). My xorg.conf is the following:

    Code:
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    	Option		"XkbVariant"	"intl"
    	Option		"XkbOptions"	"lv3:ralt_switch"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"stylus"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"eraser"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"cursor"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"ATI Technologies Inc RV370 [Sapphire X550 Silent]"
    	Driver		"fglrx"
    	Option		"XAANoOffscreenPixmaps" "on"
    	Option		"VideoOverlay" "on"
    	Option		"OpenGLOverlay" "off"
    	Busid		"PCI:1:0:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"LP717"
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc RV370 [Sapphire X550 Silent]"
    	Monitor		"LP717"
    	Defaultdepth	24
    	SubSection "Display"
    		Modes		"1280x1024"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen "Default Screen"
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    
    Section "Module"
    	Load		"glx"
    EndSection
    
    Section "Extensions"
    	Option	"Composite"	"on"
    	Option	"XVideo" 	"on"
    EndSection
    Thanks,
    Tiago

    Leave a comment:

Working...
X