Announcement

Collapse
No announcement yet.

8.02 "Another Cr*ppy Release Edition" ACRE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kano
    replied
    Is it normal that a bug, which was introduced with the new code base is still not fixed after 6 month? The gl2benchmark tests 3+4 which would use pointsprites do not work. Why not?

    Leave a comment:


  • bridgman
    replied
    The Bugzilla site is maintained at :

    http://ati.cchtml.com/

    Leave a comment:


  • Vighy
    replied
    Originally posted by bridgman View Post
    Cornelius, I added your questions to the Ask ATI Devs thread.

    Vighy, re: composite extension I don't think there is enough info in your question to repro the problem here, unless there is a Bugzilla ticket filed with more details. From your original post I think you're saying it worked properly in 8.41 and 8.42 but not in Cat 7.12, is that right ?

    Re: 32 bit apps / 64-bit OS, not sure. Again if there is a Bugzilla ticket with specifics the devs will be aware of it.

    Re: power management on laptops, that is probably the single hardest part of driver development, and it's particularly bad under Linux. Every laptop implements power management a bit differently, and there are essentially no useful standards.
    right! the problem of the colors appeared with the catalyst 7.12...

    where should i check for the bugzilla? :-) i'm sorry but i don't know it :-)

    for the power management.. ok you're right again. It would be nice that the laptop-houses would release their brand modified ati-driver based on their specs.. as it happens in windows.... i don't think it would be a too great deal for a corporation like asus, and others like that...
    ain't it possible for you to do this?

    Leave a comment:


  • ig-88
    replied
    I still have a lockup issue with 8.02. I disabled atieventsd, but it still crashes when i switch to the console.

    also i still have a color issue with skype and screenlets. those deranged colors also appeared to me in kde4, but only when composition in kwin was disabled.



    ig-88

    Leave a comment:


  • bridgman
    replied
    Cornelius, I added your questions to the Ask ATI Devs thread.

    Vighy, re: composite extension I don't think there is enough info in your question to repro the problem here, unless there is a Bugzilla ticket filed with more details. From your original post I think you're saying it worked properly in 8.41 and 8.42 but not in Cat 7.12, is that right ?

    Re: 32 bit apps / 64-bit OS, not sure. Again if there is a Bugzilla ticket with specifics the devs will be aware of it.

    Re: power management on laptops, that is probably the single hardest part of driver development, and it's particularly bad under Linux. Every laptop implements power management a bit differently, and there are essentially no useful standards.

    Leave a comment:


  • cornelius
    replied
    It looks like the quality of the driver is increasing indeed. For example, I can finally use Compiz with acceptable scrolling speed in Firefox and can see uninterrupted Compiz animations.

    bridgman, what I really would like to know is when we can expect some crucial basic functionality to be available, like:
    • Working suspend with Compiz: Currently suspend fails if Compiz is run at least once in the current session, whether or not Compiz is running when Suspend key is pressed.
    • Functional CRT/LCD button on laptops: I expect it to work just like in windows, i.e. switch between 3 configurations with different resolutions and clone settings. Currently the key does nothing. There is a thread about this here. Apparently it's only available on Lenovo laptops.


    These are not even mentioned in "known issues". Why not?

    - Ubuntu 7.10, Dell Inspiron 6000, Mobility X300, 1680x1050.
    Last edited by cornelius; 02-16-2008, 07:25 PM.

    Leave a comment:


  • Vighy
    replied
    Originally posted by karlpiuemeno View Post
    grazie Vighy
    vedo che sei italiano pure tu

    problema risolto..
    ehehe di niente!! :-) son contento sia and tutto a posto! :-)

    __________________________________________________ _______________


    Originally posted by Vighy View Post
    same with M76 = HD2600 mobility radeon with 512MB ram.

    running x86_64 gentoo linux.

    i think it's a 64bit problem.... like the fact that i cannot enable anti-aliasing in 32bit applications...

    @michael
    I'm sorry to say that it's not so evident they are making improvements: since 7.12 the drivers are introducing many bugs for my platform...

    nobody answered me when i asked why using the composite extensions i had a swap from warm colors to cold ones and viceversa.
    nobody told me why, running a 64bits system i cannot enable anti-aliasing and v-sync on 3D 32bit apps (while all the other effects work)
    nobody told me what's so difficult in implementing powerplay for mobile architectures.

    I'd really love to read an answer to each question.

    my trust in ati is not vanishing, i'm just wondering what's happening under the hood, if you say "could AMD be preparing for some major updates in the coming releases?"
    I'd just like to know what's happening so maybe i could say: ok it doesn't matter if there are some bugs now, it's just important that they finish what they're work soon, and then fix all the bugs.
    nobody got an answer to this!?
    expecially bridgman or michael that should know answers to these questions :-)
    thanks!

    Leave a comment:


  • brouhaha
    replied
    8.02 still won't generate an RPM on Fedora 8 x86_64

    As with the last several releases, using --buildpkg Fedora/F8 fails. After the "Checking for unpackaged file(s) stage, it reports:

    RPM build errors:
    File not found by glob: /tmp/ATI-fglrx-8.455.2-1-10952-eric/tmp/ATI-fglrx-8.455.2-1.f8-root-eric/usr/X11R6/lib/modules/dri/*
    Removing temporary directory: fglrx-install.T10877

    Is this a known problem? Is there some easy fix?

    Thanks!
    Eric

    Leave a comment:


  • wojtek5001
    replied
    strange

    I removed glesx.so and ... nothing happens. All things works like previously. I didn't found any notice about that module in Xorg.0.log or system logs. So it seems that this module is only used only for "higher" hardware that mine. Thats a reason why this works for me but causes problems for You.

    BTW: bug 1003 seems to come back. Further tests my new mixed-version driver shows that first run glxgears not hang, but first run fgl_glxgears hangs. Thats also happens for sauerbraten ;( . I'll try to replace libGL.so from previous version later today ... or downgrade fully to 8.01 with workaround, and patiently wait for version that will work (fglrx or mesa-r300, whichever will come first )

    Leave a comment:


  • djdoo
    replied
    Originally posted by wojtek5001 View Post
    So Your X-server works, but You can't connect? Or what?
    The problem is that if I change the fglrx_dri.so with the 8.1 one, GLESX module doesn't load(as it did with all previous drivers) and it doesn't allow me to connect to X server.

    I tried disabling it but still couldn't connect.

    I finally decided to keep 8.2 driver cause GLESX module's usage finally gave me acceptable scrolling and much better 2D behaviour.

    The strange thing is that all 3D games are corrupted except RACER! Cannot understand why...

    I also noticed that 8.2 fglrx_dri.so is a bit bigger than 8.1 one.

    Compiz-Fusion is working better and I can play RACER so I can hold on for another month I guess!

    Leave a comment:

Working...
X