No announcement yet.

AGP users, UNITE!!!!

  • Filter
  • Time
  • Show
Clear All
new posts

  • AGP users, UNITE!!!!

    Hi folks. I have a x700 AGP 256mb video card, and I haven't been able to get working a fglrx driver which supports AIGLX.

    I've lost about a hundred hours(since october 24th 2007) searching the web and making tests, trying to get AIGLX working since the first driver which supports is(8.42), and none of them worked nice in my card. In 8.42 driver I got it partially working, the bug of the driver not assigning and IRQ to the card, which makes it work very slow, and compiz was full of glitches, making it unusable. The later releases just freeze my entire system, catalyst 7.1, 7.2 and 8.1 . I really lost my patience and even decided to sell my card, to get an nvidia one, but nobody buys AGP cards anymore
    So I'm stuck with it.

    My point is:
    Maybe the agp users are not well represented in the beta testers team. I've talked to bridgman, a user on the forum who works on AMD/ATI, and he said he'd get me in their beta testers mailing list, so we at least make sure the developers know about the problem, they are aware of the problem with AGP cards, but they though it'd be a 2x00 series problem, and it seems not.

    All of you who use AGP cards, please make a post in this thread posting your system configuration:

    ATI Graphic card

    * Monitor type(lcd, crt, tv) and resolutions used

    * Motherboard/chipset model

    * Processor type

    * Ammount of memmory

    * Distro used

    * Kernel version

    * Xorg version

    * fglrx version

    * is AIGLX working ?

    And please, justify the choice of the version of your driver. I use 8.40 because it's stable in my system, even though it doesn't support AIGLX.

    After having this thread with many AGP users, we will be able to organize ourselves better to give more feedback about AGP cards. bridgman told me that there were a lot of AGP users in the beta testers group, but most of them migrated to PCI-E, so they're needing more.

    What I want is understand if it's a driver problem, a distro problem, a Xorg problem, the more reports we have, the easier it'll be to track it.

    Thanks in advance.
    Last edited by israel_miranda; 13 February 2008, 01:56 PM.

  • #2
    Your card is old enough to work without fglrx and you can use AIGLX using the free driver. You can easyly verify this by booting Kanotix and then start beryl-manager in system menu...


    • #3
      Hey israel_miranda, how about getting people to post what Ati AGP card they use also? Bit daft not to include that

      I'll bite:

      H.I.S. Radeon HD 2600 XT AGP 8x IceQ 'Turbo' 512 MB GDDR3

      * Motherboard/chipset model: Abit AV8 / Via K8T800Pro

      * Processor type : AMD Athlon 64X2 4800+ Socket 939

      * Ammount of memmory: 4GB DDR400

      * Distro used: Ubuntu 7.10 Gutsy Gibbon 64-bit

      * Kernel version: 2.6.22-14(.51)-generic with bootoptions "ro quiet splash nodmraid notsc noapic nolapic acpi=strict"

      * Xorg version: 7.2-5ubuntu1

      * fglrx version: none work so I stick with radeonhd 1.1.0


      • #4
        My system:

        Hi Kano, I know the radeonhd driver is very good and supports AIGLX, but AFIK, it doesn't support 3d acceleration for games. Is that right? I confess I never tried the open source drivers, since I've heard it doesn't support acceleration for games. I play some games once in a while, that's why I didn't try it.

        Swoopy, good point!!!
        I forgot the most important
        I corrected it in the above post

        BTW, here goes my system:

        Saphire Radeon x700 AGP 8x 128 bits 256 MB DDR1

        * CRT 19" monitor: model AOC 9klr Spectrum with a 1280x1024 resolution.

        * Motherboard/chipset model: Intel D865PERL / intel i865P

        * Processor type : Pentium 4 2.6ghz HT 512kb cache Northwood core socket 478

        * Ammount of memmory: 2GB DDR400

        * Distro used: Debian 4.0 Etch 32bit (stable)

        * Kernel version: 2.6.18-16-686 with bootoptions "ro"

        * Xorg version: 7.1.0-19

        * fglrx version: 8.40.4, the most stable and recent driver that worked on my system.
        Last edited by israel_miranda; 13 February 2008, 07:27 AM.


        • #5
          Originally posted by israel_miranda View Post
          Hi Kano, I know the radeonhd driver is very good and supports AIGLX, but AFIK, it doesn't support 3d acceleration for games. Is that right?

          You got it mixed around... RadeonHD doesn't support AIGLX nor 3D acceleration. The RadeonHD driver is JUST for the R500 and R600 series. The Radeon (non-HD) driver DOES support AIGLX and 3D acceleration and that goes back to the R100 series. Your card is supported by the Radeon driver.
          Michael Larabel


          • #6
            I've got a Sapphire Radeon X1950 pro 512MB on the following system:

            nforce3 motherboard chipset
            AMD Athlon 64 2800+
            2GB corsair PC400
            Ubuntu 7.10 (or, in fact Xubuntu 7.10)
            2.6.22-14 generic Ubuntu kernel
            xorg: 7.2-5ubuntu13
            fglrx: 8.37 (default in 7.10)


            • #7
              Hi israel_miranda. I'm a fellow AGP graphics card user, x800 pro 256. I had problems with it too and frankly I was stuck without hardware acceleration for quite a while. I'll be glad to help out. I'll have to check the driver version I use on mine since I got it working on Xubuntu without much trouble (also downloaded drivers straight from ubuntu, which almost never fails).

              Sadly, I think AGP users aren't getting enough attention anymore. Any of the driver issues, are likely to be left unresolved until I bit the bullet and decided to ditch everything I had and start fresh.


              • #8
                Not at the moment - But!

                Hi, I've been keeping an eye on this phorum due to my AGP card needs.

                I currently do not use an ATI/AMD Video card.
                I wish to purchase an AGP HD2600Pro, but I have been holding back due to problems others have been experiencing.

                But count me among the United!



                • #9
                  Great! Michael, I think a name change is required: Phoronix Phorums !!! Sheer genius!

                  Back on topic, my hardware setup is presently:

                  Sapphire X1950pro 512
                  nforce3 motherboard chipset
                  AMD Opteron 165
                  2GB OCZ PC400
                  2.6.23-gentoo-r2 (changes occasionally)
                  xorg: 7.1
                  fglrx: 8.452 (8.1)

                  Also having difficulty with aiglx.


                  • #10
                    Intel Pentium 4 3.4 Ghz
                    R420 JK Radeon x800
                    1.5Gigs ram
                    Ubunbtu Gutsy
                    fglrx: 8.452 (8.1)
                    X Window System Version 1.3.0
                    Build Operating System: Linux Ubuntu (xorg-server 2:
                    Last edited by Paroxysm; 14 February 2008, 04:24 PM.