Announcement

Collapse
No announcement yet.

AMD Will Release New Catalyst Linux Driver Update This Month

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Catalyst 15.3 Beta (fglrx 15.200) has been backported to Ubuntu 14.04 LTS due to important improvements and currently sits in updates-proposed. Enable the "Proposed" Sources and install fglrx fglrx-core fglrx-amdcccle fglrx-dev from the repositories.

    Comment


    • could not find the fglrx-core package. Im on Xubuntu 14.04. Turned on trusty-proposed, and updated. I get other updates from trusty-proposed.
      Anyone else not getting the updated package? Im actually getting the old 13.350 package....

      Comment


      • Originally posted by skvate View Post
        could not find the fglrx-core package. Im on Xubuntu 14.04. Turned on trusty-proposed, and updated. I get other updates from trusty-proposed.
        Anyone else not getting the updated package? Im actually getting the old 13.350 package....
        Me too, this morning i try : (i have enable proposed repo when i installed Ubuntu 14.04):




        No fglrx*15.2 packages available only old 13.350 package (very old catalyst package, i think before omega driver version this package).


        Regards

        Comment


        • The driver is built and ready, for some reason it hasn't onto the mirrors yet but should be very, very soon.

          In the meantime, you can get the four .debs for Ubuntu 14.04 here: https://launchpad.net/ubuntu/+source...+build/7309180 (see Built files)

          Comment


          • Originally posted by d2kx View Post
            The driver is built and ready, for some reason it hasn't onto the mirrors yet but should be very, very soon.

            In the meantime, you can get the four .debs for Ubuntu 14.04 here: https://launchpad.net/ubuntu/+source...+build/7309180 (see Built files)
            Thanks, now fglrx* 2.15.2000 is available through trusty-proposed repository.

            Code:
            [email protected]:~$ apt search fglrx
            Sorting... Hecho
            Full Text Search... Hecho

            fglrx/trusty-proposed 2:15.200-0ubuntu0.1 amd64
            Video driver for the AMD graphics accelerators


            fglrx-amdcccle/trusty-proposed 2:15.200-0ubuntu0.1 amd64
            Centro de control Catalyst para los aceleradores gr?ficos de AMD


            fglrx-amdcccle-updates/trusty-proposed 2:15.200-0ubuntu0.1 amd64
            Centro de control Catalyst para los aceleradores gr?ficos de AMD


            fglrx-core/trusty-proposed 2:15.200-0ubuntu0.1 amd64
            Minimal video driver for the AMD graphics accelerators


            fglrx-dev/trusty-proposed 2:15.200-0ubuntu0.1 amd64
            Controlador de v?deo para el acelerador de gr?ficos AMD (archivos de desarrollo)


            fglrx-pxpress/trusty-proposed 1:0.2.91.8 amd64
            transitional package for ubuntu-drivers-common

            fglrx-updates/trusty-proposed 2:15.200-0ubuntu0.1 amd64
            Video driver for the AMD graphics accelerators


            fglrx-updates-core/trusty-proposed 2:15.200-0ubuntu0.1 amd64
            Minimal video driver for the AMD graphics accelerators


            fglrx-updates-dev/trusty-proposed 2:15.200-0ubuntu0.1 amd64
            Controlador de v?deo para el acelerador de gr?ficos AMD (archivos de desarrollo)

            kubuntu-driver-manager/trusty-updates 14.04ubuntu10 amd64
            Driver Manager for Kubuntu

            kubuntu-driver-manager-dbg/trusty-updates 14.04ubuntu10 amd64
            Driver Manager for Kubuntu -- debug symbols

            ubuntu-drivers-common/trusty-proposed,now 1:0.2.91.8 amd64 [installed]
            Detect and install additional Ubuntu driver packages

            xvba-va-driver/trusty 0.7.8-1ubuntu3 amd64
            Interfaz basada en XvBA para VA API (implementaci?n fglrx AMD)
            Regards.

            Comment


            • Hello yesterday I was testing the new driver from ubuntu proposed repo, i usually work pretty well (especially 2D acceleration) ..but there is an error:

              Code:
              $ vainfo
              .................................................. ...............................
              libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
              libva: va_openDriver () returns -1
              .................................................. ......................
              I think that's because is not installed the package: xvba-va-driver 0.7.8-1ubuntu3

              if i try:

              Code:
              sudo ln -s /usr/lib/va/drivers/fglrx_drv_video.so /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so

              ..but do not works because the path /usr/lib/va/drivers/fglrx_drv_video.so do not exist (xvba-va-driver).

              Although I am not very knowledgeable in this ..but i must install xvba-va-driver ..i think VAAPI acceleration is supported by default from Catalyst 14.12 (i do not need anymore xvba-va-driver).

              Regards.

              Comment


              • Hi Hector

                Originally posted by hector View Post
                Hello yesterday I was testing the new driver from ubuntu proposed repo, i usually work pretty well (especially 2D acceleration) ..but there is an error:

                Code:
                $ vainfo


                I think that's because is not installed the package: xvba-va-driver 0.7.8-1ubuntu3

                if i try:

                Code:
                sudo ln -s /usr/lib/va/drivers/fglrx_drv_video.so /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so

                ..but do not works because the path /usr/lib/va/drivers/fglrx_drv_video.so do not exist (xvba-va-driver).

                Although I am not very knowledgeable in this ..but i must install xvba-va-driver ..i think VAAPI acceleration is supported by default from Catalyst 14.12 (i do not need anymore xvba-va-driver).

                Regards.
                The correct link is :

                sudo sudo ln -s /usr/lib/libXvBAW.so.1.0 /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so

                The link is missing so it's better to report this at Ubuntu if you have time.

                Regards

                Comment


                • Hi Hector

                  The correct link is:

                  sudo ln -s /usr/lib/libXvBAW.so.1.0 /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so

                  You don't need the xvba-va-driver.

                  It is better to report this to Ubuntu if you have time

                  Regards

                  Comment


                  • Originally posted by Tasev View Post
                    The correct link is :

                    sudo sudo ln -s /usr/lib/libXvBAW.so.1.0 /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so

                    The link is missing so it's better to report this at Ubuntu if you have time.

                    Regards

                    https://bugs.launchpad.net/ubuntu/+s...s/+bug/1442921


                    Regards

                    Comment


                    • Getting back to the main topic of this thread...it's June, now, what happened to the driver that was supposed to be released in March?! Has anybody heard anything about it? I'm going to be so disappointed, but not surprised, if it doesn't work on Linux kernel 4.x.

                      BTW, does anyone now if the open source driver has this problem keeping up with the kernel?

                      Comment

                      Working...
                      X