Announcement

Collapse
No announcement yet.

fglrx 8.01 - Breaks TV-OUT ? (and terrible! glxgears performance...)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx 8.01 - Breaks TV-OUT ? (and terrible! glxgears performance...)

    Has anyone else noticed two things with the latest 8.01 drivers?
    1) TV-OUT is totally broken
    - When I attach just the DVI-> Component video dongle to the 2nd dvi port, I'll get a display up until X launches. I can see the BIOS, the bootscrips, etc. But as soon as X launches, FGLRX explodes. See the log below. Before (<7.11), I was able to attach it, but my custom modelines to drive the display were ignored . The modelines in my xorg.conf below were copied out of Powerstrip in Win Vista.

    2) glxgears performance is awful (60 FPS!)

    I'm running Ubuntu 7.10 with an ATI x1900 XTX. I'm sure I'm missing something (especially on point 2), but I'm not sure what it is. If anyone has any suggestions / just wants to commiserate I'd love to hear from you.


    -Tony

    *~*~*~*~*~*~*~
    Various Interesting Logs/config files



    Relevant Xorg.4.log section (obtained by stopping gdm and then running startx -- -logverbose 6 :4)

    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.1.0, module version = 8.45.4
    ABI class: X.Org Server Extension, version 0.3
    (II) fglrx(0): Using adapter: PCI:1:0:0.
    (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR3
    (II) fglrx(0): PCIE card detected
    (II) fglrx(0): board/chipset is supported by this driver (original ATI board)
    (II) Loading sub module "ddc"
    (II) LoadModule: "ddc"(II) Module already built-in
    (II) fglrx(0): Connected Display1: Component Video [cv]
    (II) fglrx(0): Display1: No EDID information from DDC.
    (II) fglrx(0): Display1: Failed to get EDID information.
    (II) fglrx(0): Primary Controller - Component Video

    Backtrace:
    0: /usr/bin/X(xf86SigHandler+0x81) [0x80c95d1]
    1: [0xffffe420]
    2: /lib/tls/i686/cmov/libc.so.6(__strtol_internal+0x3f) [0xb7dbfaef]
    3: /usr/bin/X(xf86atoi+0x35) [0x80b4a15]
    4: /usr/lib/xorg/modules/drivers//fglrx_drv.so [0xb7964652]
    5: /usr/lib/xorg/modules/drivers//fglrx_drv.so [0xb7963e9f]
    6: /usr/lib/xorg/modules/drivers//fglrx_drv.so(swlDalHelperPreInit+0x5d3) [0xb7963153]
    7: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit+0xbbf) [0xb79365ef]
    8: /usr/bin/X(InitOutput+0x9a4) [0x80a8ea4]
    9: /usr/bin/X(main+0x27b) [0x8076ceb]
    10: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7da7050]
    11: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x8076241]

    Fatal server error:
    Caught signal 11. Server aborting
    Xorg.conf
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg
    # SERVER FLAGS
    #Section "ServerFlags"
    # Option "NoDDC"
    #EndSection


    Section "ServerLayout"

    # InputDevice "stylus" "SendCoreEvents"
    # InputDevice "cursor" "SendCoreEvents"
    # InputDevice "eraser" "SendCoreEvents"
    Identifier "Default Layout"
    Screen "Screen_VGA" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    Option "AIGLX" "false"
    # Uncomment if you have a wacom tablet
    EndSection

    Section "Files"
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "Monitor"
    #From VGA cable EDID info
    #From VGA cable EDID info
    # HorizSync 28-96 #From autoconf
    # VertRefresh 43-60 #From autoconf
    # Modeline "[email protected]" 73.78 1280 1312 1592 1624 720 735 742 757
    # Modeline "[email protected]" 77.60 1920 1952 2240 2272 1080 1104 1110 1135 interlace
    Modeline "1080iPstrip" 148.500 1920 1964 2005 2200 1080 1085 1095 1125 interlace +hsync +vsync
    Modeline "720pPstrip" 148.500 1280 1350 1387 1650 720 725 730 750 +hsync +vsync
    Identifier "PDP_VGA"
    HorizSync 24.0 - 61.0
    VertRefresh 55.0 - 76.0
    Option "DPMS"
    EndSection

    Section "Device"

    # Option "VideoOverlay" "on"
    Option "EnableMonitor" "cv"
    # Option "FSAAScale" "2"
    Identifier "ATI_VGA"
    Driver "fglrx"
    Option "TVFormat" "NTSC-M"
    Option "OpenGLOverlay" "off"
    # Option "FSAAEnable" "on"
    Option "Centermode" "on"
    Option "TVStandard" "VIDEO"
    Option "TexturedVideo" "on"
    Option "XaaNoOffscreenPixmaps" "on"
    BusID "PCI:1:0:0"
    EndSection

    Section "Screen"
    Identifier "Screen_VGA"
    Device "ATI_VGA"
    Monitor "PDP_VGA"
    DefaultDepth 24
    SubSection "Display"
    Modes "1080iPstrip" "1360x768" "1280x1024" "720pPstrip" "1024x768" "832x624" "800x600" "720x480" "640x480"
    # Modes "1360x768" "1280x1024" "1280x720" "1024x768" "832x624" "800x600" "720x480" "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "0"
    EndSection

  • #2
    Here is my AMDPCSDB as well - I'm sure there is something missing in here. I've tried all the aticonfig add cv mode / validate cv mode options, but to no avail.

    AMDPCSDBV1
    [AMDPCSROOT/SYSTEM/MCIL]
    PXACAutoSwitch=V0
    PXDCAutoSwitch=V0
    CVRULE_CUSTOMIZEDMODESENABLED=V1
    DALLinuxSupport=V1
    DALNonStandardModesBCD=R14001050000000601792134400 00006018001440000000601856139200000060160012000000 00601280076800000060144009000000006012800960000000 601680105000000060
    DALRULE_ADDNATIVEMODESTOMODETABLE=V1
    DALRULE_DYNAMICMODESUPPORT=V1
    DALRULE_GetLCDFakeEDID=V1
    DALRULE_GetTVFakeEDID=V1
    DALRULE_NOFORCEBOOT=V1
    DALRULE_POWERPLAYDISREGARDDISPLAY=V1
    DALRULE_RESTRICTDISPLAYSBASEDONPANELRES=V0
    GCORULE_FlickerWA=V1
    GCORULE_LCDValidatePixelClkOnly=V1
    GXOM5XDisableLaneSwitch=V1
    R6LCD_RETURNALLBIOSMODES=V1
    TVEnableOverscan=V1
    DALPowerPlayOptions=V1
    DALLastSelected=V1
    DALLastConnected=V33
    DALLastTypes=V221
    DALObjectData0=R0101000101000101000101000102000102 00030102030102010400010400030104030104010200010200 03010203010201080001080003080103080103080203080203 08010308010308040308040308010308010308020308020308 01030801011000011000031001031001031002031002031001 03100103100403100403100103100103100203100203100103 10010308100308100308100308100308100308100308100308 10030810030810030810030810030810030810030810030810 01200001200001010003012001020001020003010203010201 04000104000301040301040102000102000301020301020308 20030820030801030801030802030802030801030801030804 03080403080103080103080203080203080103080103102003 10200310010310010310020310020310010310010310040310 04031001031001031002031002031001031001030810030810 03081003081003081003081003081003081003081003081003 08100308100308100308100308100308100101000101000101 00000000010200000000010100020002010400000000010100 02000401020000000001010002000201080000000001080002 00010108000200020108000200010108000200040108000200 01010800020002010800020001011000000000011000020001 01100002000201100002000101100002000401100002000101 10000200020110000200010108000200100108000200100108 00020010010800020010010800020010010800020010010800 02001001080002001001200000000001010002002001020000 00000101000200020104000000000101000200040102000000 00010100020002010800020020010800020001010800020002 01080002000101080002000401080002000101080002000201 08000200010110000200200110000200010110000200020110 00020001011000020004011000020001011000020002011000 02000101080002001001080002001001080002001001080002 00100108000200100108000200100108000200100108000200 10000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000
    DALObjectData1=R0000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000000000000000000
    DALSelectObjectData0=R0101000101000101000101000102 00010200030102030102010400010400030104030104010200 01020003010203010201080001080003080103080103080203 08020308010308010308040308040308010308010308020308 02030801030801011000011000031001031001031002031002 03100103100103100403100403100103100103100203100203 10010310010308100308100308100308100308100308100308 10030810030810030810030810030810030810030810030810 03081001200001200003012003012001020001020003010203 01020104000104000301040301040102000102000301020301 02030820030820030801030801030802030802030801030801 03080403080403080103080103080203080203080103080103 10200310200310010310010310020310020310010310010310 04031004031001031001031002031002031001031001030810 03081003081003081003081003081003081003081003081003 08100308100308100308100308100308100308100101000101 00010100000000010200000000010100020002010400000000 01010002000401020000000001010002000201080000000001 08000200010108000200020108000200010108000200040108 00020001010800020002010800020001011000000000011000 02000101100002000201100002000101100002000401100002 00010110000200020110000200010108000200100108000200 10010800020010010800020010010800020010010800020010 01080002001001080002001001200000000001010002002001 02000000000101000200020104000000000101000200040102 00000000010100020002010800020020010800020001010800 02000201080002000101080002000401080002000101080002 00020108000200010110000200200110000200010110000200 02011000020001011000020004011000020001011000020002 01100002000101080002001001080002001001080002001001 08000200100108000200100108000200100108000200100108 00020010000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000
    DALSelectObjectData1=R0000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000000000000000000000000
    DALCurrentObjectData=R010100000000
    DALR6 CRT_MaxModeInfo=R000000005005000000030000000000004 B000000
    DAL_CRTColorTemperatureSource2F41009A=R02000000641 90000
    DALCV_MaxModeInfo=R0000000080070000380400000000000 03C000000
    DALR6 CRT2_MaxModeInfo=R00000000500500000003000000000000 4B000000
    DAL_CRTColorTemperatureSource00000000=R02000000641 90000
    DAL_CRT2NDDACColorTemperatureSource2F41009A=R02000 00064190000
    DALR6 DFPI 2_MaxModeInfo=R000000008007000038040000000000003C0 00000
    DAL_DFP2ColorTemperatureSource2F41009C=R0000000064 190000
    DALDTMCRTBCD1920x1080x60-2F41-009A=R000000000E0098088007AC072900650438043D040A00 023A0000000000000000000000000000000000000000
    DALDTMCRTBCD1280x720x120-2F41-009A=R000000000C007206000546052500EE02D002D5020500 023A0000000000000000000000000000000000000000
    [AMDPCSROOT/SYSTEM/DDX]
    VideoOverlay=Son
    OpenGLOverlay=Soff
    FSAAEnable=Son
    FSAAScale=S2
    Centermode=Son
    Capabilities=S0x00000800
    TexturedVideoSync=Son
    GammaCorrectionI=S0x06419064
    XAANoOffscreenPixmaps=Son
    TexturedVideo=Son
    AllowGLXWithComposite=Strue
    BackingStore=Strue
    DisableOvScaler=Sno
    DRI=Strue
    EnableDepthMoves=Syes
    EnableHPV=Syes
    EnableOpaqueOverlayVisual=Syes
    EnablePrivateBackZ=Sno
    ForceGenericCPU=Sno
    HWCursor=SOn
    PseudoColorVisuals=Soff
    RenderAccel=Strue
    SubPixelOrder=Snone
    TexturedXrender=Strue
    UseFastTLS=S0
    DesktopSetup=Ssingle
    EnableMonitor=Stmds2i
    GammaCorrectionII=S0x06419064
    TVFormat=SNTSC-M
    TVStandard=SVIDEO
    [AMDPCSROOT/SYSTEM/DDX/cv/attribute]
    brightness=V0
    contrast=V100
    saturation=V100
    hue=V0
    [AMDPCSROOT/SYSTEM/DDX/cv/CustomizedModeWithBaseMode]
    [email protected],1
    [AMDPCSROOT/SYSTEM/DDX/RECENTMODE/SCREEN00]
    Width=V1280
    Height=V720
    Refresh=V60
    [AMDPCSROOT/SYSTEM/LibXUtil/Display1]
    Map=V0
    Enable=V1
    [AMDPCSROOT/SYSTEM/LibXUtil/Display2]
    Enable=V0
    [AMDPCSROOT/SYSTEM/LDC]
    OverrideDongle=V0
    LastViewedPage=SWelcome
    HelpDisabled=V0
    LinkedAllSliders:1=V1
    LinkedAllSliders:2=V1
    [AMDPCSROOT/SYSTEM/OpenGL]
    VSyncControl=V3

    Comment


    • #3
      I have the same problem, though I have to say I've never had component out working. I'm guessing you have? If so, what was the last driver version for which it worked for you?

      My hardware: Sapphire 9600XT.

      Comment


      • #4


        Nope - never had it "working" - though the segfault on boot is totally new. At one point, I was able to get it to work at 480p by roughly following these steps:
        1. plug in both VGA and CV
        2. Boot into windows (damned if I know why it worked like this...)
        3. Enable both monitors - set resolution properly.
        4. Boot back into ubuntu.
        5. Enable both monitors - try to set resolution.
        6. Fail miserably - watch TV display garbage.
        7. Cry - get nagged by wife about $400 gfx card that doesn't work.
        8. Rinse - repeat with newest driver version.

        To be fair - I am able to get the card to drive my plasma over a VGA cable. The problem is my plasma doesn't apply any processing to the VGA signal, so I have a ton of tearing issues (even with vsync enabled). I'd love to be able to get the card to work via either component or DVI to HDMI.

        Comment


        • #5
          OK, I'm not getting a segfault - sorry about that false alarm. I can put out 1080i and 720p from Windows XP and that's fine. Can't get anywhere near that with linux (debian-based distro). Would love to dump Windows. Damn you ATI, I may have to go buy an nVidia card instead!

          Everything looks fine on the projector (it recognizes the inbound signal as 480p/60) until I start X. Then nothing works right until I quit out of X again, at which point the projector happily displays 480p/60 again.

          I'm presently hopping through various driver versions to see if anything can be made to work. Generally the projector will report "Frequency out of range!" which isn't helpful, since it won't tell me exactly WHAT frequency it's seeing when it does that

          I have a further problem in that the driver never recognizes the component dongle; it always claims it's:

          (II) fglrx(0): Connected Display1: CRT on secondary DAC [crt2]
          (II) fglrx(0): Display1: No EDID information from DDC.
          (II) fglrx(0): Display1: Failed to get EDID information.
          (II) fglrx(0): Primary Controller - CRT on secondary DAC

          regardless of my ForceMonitors settings. Weird, huh?
          Last edited by wohali; 21 January 2008, 08:43 PM.

          Comment


          • #6
            Out of curiosity, are you ever able to get X to indicate it recognizes any of your custom Modelines? Mine rejects all of them...which I think is the issue. (I don't think this projector can handle any of the standard modelines, just the various TV standards...)

            Comment


            • #7
              Agreed - everything works fine in Windows Well except for windows.

              I had a brief spell where the dongle wasn't recognized - I had to plug in the VGA, boot into X, run aticonfig --query-monitor
              Then plug in the cv dvi dongle, then run aticonfig --query-monitor and the CV would be reported. Though this was on 8.01 & 7.12 - if I ever tried to to enable the CV (aticonfig --enable-monitor=crt1,cv) I would crash X.

              I think the last driver version where I got "close" was 7.11 (or maybe 8.42.3)

              I'm debating the nvidia question in my head right now. I have an old 6600 GT that I might through in there just to see if I can get closer with the nvidia drivers....

              -- No I wasn't ever able to get X to recognize any of my custom modelines. Before it would ignore them, then it would ignore them (7.11 bug I believe...) and now X segfaults.

              Comment


              • #8
                FYI I gave up - went out and got an nVidia 6800XT card for about $30 from a local Chinese computer shop. It came with the component video dongle and a full warranty.

                Took me 10 minutes to download and install the nVidia driver, specify "HD720p" in the xorg.conf file, and fire up X. It worked perfectly the first time.

                I doubt I'll go back to my ATI card at this point.

                Comment


                • #9


                  Sorry to hear. I've stopped futzing for now. I have an old 6800 sitting in my closet that I think I'm going to have to give a whirl.

                  I'm sure the ATI devs are just as frustrated as everyone else. This is a crappy situation for all involved.

                  Comment


                  • #10
                    I have been battling with the ATI component video issue for months now. In previous posts I found others all having the same problems you guys describe.

                    I would also like to dump Windows but the component video issue has held me back.

                    It grates me to have to go out and purchase a lower performance nVidia card just to get to use Linux when this same ATI card works so well in Windows with my HDTV. The Catalyst Control Center set up for DTV under Windows makes setting up the HDTV/Component Video a snap. I sure wish ATI would add that same functionality to the Linux Catalyst Control Center.

                    Coincidently my HDTV has had to be repaired and as a result I spent all my recent computer time in Linux using an old monitor. If I had any oustanding concerns with the ability of Linux to satisfy my computer needs those questions have all been answered.

                    The few Windows programs that do not have a satisfactory a Linux equivalent work well under WINE. In fact one of them "NewsBin Pro" actually shows faster network/download speeds then under Vista.

                    For me the clock is ticking on my patience with ATI. Maybe just until the HDTV repair bill is paid.

                    Comment

                    Working...
                    X