No announcement yet.

AMD Catalyst 8.01 Linux Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by bridgman View Post
    Can you try turning off Textured Video ? It shouldn't make a difference, but we have at least one report that mentioned it.

    This obviously isn't a good workaround for you, since it *will* impact your xv playback, but it would be good to know if that makes a difference with the lockup.
    Tested as sugested and the problem was solved... This is however not an acceptable workaround, as you have already mentioned. XV playback stops working...


    • givemesugarr, thanks for helping. Much appreciated.

      I've uploaded my whole Xorg.0.log to pastebin:

      And my xorg.conf too:

      Sorry about the amount of logs, but I thought I would be better to include everything that to skip something. I'm really not that good at video subsystem of linux
      What should I do now ?


      • Originally posted by DirtyHairy View Post
        Observations on my T60 (mobility X1300):

        - Memory leak is gone
        - widescreen works
        - OpenGL speed is good
        - Textured2D has noticeably improved, some rendering operations still seem to cause minor slowdowns, but overall 2D speed is noticable improved by the option (I don't use compositing or AIGLX for now)
        - Suspend to RAM works nicely (as it has always done for me)

        - XV still is not working correctly
        - Strange "diagonal" tearing is still present when vsync is enabled
        - Powerplay has developed a tendency to cause deadlocks

        Overall, this is one of the most usable releases for me since I aquired this laptop one and a half years ago To elaborate a bit (in a hopefully constructive fashion) on the cons:

        XV has stopped working correctly somewhere around Summer last year. Since the it is crippled, only two color formats are available, and the only application that plays along nicely with it is mplayer - xine produces garbled output, and vlc can be made working by forcing the color format, but then scaling doesn't work correctly and is blocky. Also, there is a strange sort of "diagonal" tearing (also present with OpenGL and vsync) which looks like a "Z"with the top and bottom lines flipped to the outsides. I still am hoping for a version that fixes this (although I have noticed that xshm and software scaling is suprisingly good).

        Much worse is the breakage of powerplay which for the first time causes trouble in this release. If Textured2D is enabled, it causes reproducable deadlocks which affect nearly everything - ssh access isn't possible. However, magic sysrq is working for syncing and rebooting, so at least parts of the kernel are left alive. If I disable Textured2D, it only locks every 4-6 times or so, but of course, that's not really better, so I disabled it for now. Since powerplay makes the difference between ~22 and ~16 watts total power consumption on my notebook, I would consider this a blocker if I wouldn't detest the memory leak even more (not to speak of the widescreen bug, I am confident that pushing this out was meant to be a bad joke).

        When these critters get fixed (espeacially the last one), I for the first time will be tempted of assigning any level of "quality" to fglrx (at least on my configuration)

        If anyone is interested, my configuration is a thinkpad T60 core duo (no "2", so 32 bit) running gentoo stable (xorg-server 1.3).
        The same goes for my experience, been using Gentoo for about a year, running with AMD and with Ati, very stable, nice and very few issues. Looks like the problems are inherent to some distros (not for my Gentoo, though!)


        • Originally posted by thund3rman View Post
          Tested as sugested and the problem was solved... This is however not an acceptable workaround, as you have already mentioned. XV playback stops working...
          Spoke too soon... There was something that corrected the problem, but it appeared again... With both overlays and also textured video disabled...


          • thx sok-1, firefox scrolling improved, but the slowdown continues... It happens after a certain time, when i boot everything is fine, but later 2d rendering becomes choppy, i dont know if this is a distro issue, or a driver bug, the truth is that it is very annoying... restarting the x server fixes it, but after some time it appears again... please help... thx in advance


            • Update on the freeze-on-logout/restart problem


              I've mentioned in a previous post that I've got problems with X freezing on logout/restart. I also said that it helped to turn off VideoOverlay and OpenGLOverlay. Well, it turns out that's really not good enough, after some more testing. I get freezes even with all video-options turned off (that is: OpenGLOverlay off, VideoOverlay off and TexturedVideo off). I even disabled the XVideo extension completely. Also tried: disabled AIGLX and Composite (doesn't help) and I disabled a custom pair-mode (doesn't help). Not sure if the problem is related to dual-screen setup, haven't tested if the problem occurs on single-screen yet.

              It's not a kernel panic, and the laptop is responsive on other interfaces, so I logged in with ssh to do some investigating.

              Summary of state after a freeze has occured:
              - Xorg process spins and consumes 100% CPU
              - No error messages in Xorg log file
              - No error messages in kernel log
              - Attaching to Xorg process using strace works, but I get no output, so I assume no syscalls are being made in the loop gone wild (?).
              - Apart from the Xorg process, the system seems to be quite normal.
              - Rebooting the machine works, and it shuts down cleanly.

              My hardware/software: ATI X1400 (mobile), Lenovo Z61m laptop, Intel Core Duo, Ubuntu Gutsy 32bit.

              This is kind-of a new show-stopper for me, I cannot stand unstable behaviour like this, so I'll probably be heading back to fglrx 8.37.6 (disappointing .. ).

              Unless somebody has come up with other work-arounds ?



              • Originally posted by oyvind View Post
                I've mentioned in a previous post that I've got problems with X freezing on logout/restart.
                Now i have reverted to 8.40.4 fglrx drivers (i could not stand the slow 2d and logout freeze in the newest drivers), but yesterday, while testing, i did the logout procedure while in kde. I use kdm and have the "always restart X" option in it.
                I switched to a text console before the freezing, so i could look at the ongoing processes:
                i noticed the process /etc/ati/ there, stuck.....

                My instinct tells me that a call to this script could maybe be the cause to the actual freeze.......
                Anyone could please tell me what really this script should do?.....

                BTW: the X1400 Ati card in this laptop is DISGUSTING me. I'm one of the many who think "Ati: no more".



                • Originally posted by marcobrancalion View Post
                  Now i have reverted to 8.40.4 fglrx drivers (i could not stand the slow 2d and logout freeze in the newest drivers).
                  I'm back on fglrx 8.37.6 for now (not much different from 8.40.4 for me). I use this laptop at work, so I don't have the time to experiment too much during weekdays. Guess I won't be using suspend, after all .


                  • Originally posted by oyvind View Post
                    Guess I won't be using suspend, after all .
                    Oh, regarding suspension/hibernation: i made it work by recompiling the kernel (Ubuntu Gutsy) with the slab option.......


                    • X1600 512MB here. I have the same vlc problems as everyone else here, but at least widescreen does work in this version, unlike the abortion that was 7.12. No (EE) Errors in Xorg.0.log, only some warnings about a large range of visuals not working. Thanks alot ATI, now I can't even playback videos using OpenGL, so they aren't a blurry POS. Why can't I get basic functionality for a card I paid for, on an OS that isn't a unconfigurable POS like Windows? That's all I ask for, video playback that WORKS as well as Windows, using OpenGL, so scaling is not a problem.