No announcement yet.

AMD Catalyst 7.12 Linux Driver -- The Baby's In Surgery

  • Filter
  • Time
  • Show
Clear All
new posts

  • #81
    Please Santa Claus, bring me an nvidia and I will give you a radeon 9600 .
    You can use open source radeon driver instead of fglrx .


    • #82
      I'm not sure if I am doing something wrong but in my /var/log/Xorg.o.log I am still getting an unrecognized chipset error with my ATI 3870.


      • #83
        You can use open source radeon driver instead of fglrx
        at least the opensource driver team gave us a neat present today :]


        • #84
          To sum it up:

          Installation went fine (thanks to Dells(!) dkms)

          Thinkpad T43p:
          - gets sxga instead of sxga+ resolution ("Known Issues" tells only for wsxga+)
          - sxga+ mode ignored as described in "Known Issues" release notes
          - composite extension not available as already described in X log shows loading of COMPOSITE EXTENSION but the info about OPENGLOVERLAY too. OpenGLOverlay is disabled in xorg.conf!
          - suspend with gutsy still doesn't work

          So I didn't get to any further issues and am now back at 8.37 ... what a great ati experience


          • #85
            Originally posted by yoshi314 View Post
            at least the opensource driver team gave us a neat present today :]
            T60p - looking stable so far in terms of general usage with internal 1600x1200 + external DVI connected 1600x1200. dynamic screen changes work as does suspend/resume on RHEL 5.1.

            Will try AIGLX etc later -- first step for me was to ensure it was as stable as 8.35 for basic capabilities...


            • #86
              Originally posted by gazrang View Post
              Even in 7.12, I still have slow page-scrolling in firefox with Compiz on(via AIGLX). (Sigh...)

              I have ati9600 on my thinkpad t42.

              ATI developers, Please resolve this problem....
              Have you got smooth scrolling enabled in firefox? Try turning that off. I have heard that fixes it.

              I haven't tried 7.12 yet (I'd use Kano's script but for some reason console doesn't work for me when I ctrl-alt-f*. , should reboot and see if new kernel has fixed it). I'll give it a go tonite or tomorrow.


              • #87

                What a f*****g entangled mess the fglrx driver must be. How can they break widescreen and still release the driver!?

                This is amazing. Each and every driver release that fixes something seems to introduce some completely ad-hoc gotcha rendering it somewhat useless. Memory leak in 7.11 OR inability to run your LCD at native resolution in 7.12 - pick your poison! What an artificial choice!

                8.35 still "rules". Yay...


                • #88
                  I can also comfirm that widescreen resolutions aren't available with the new fglrx 7.12 driver. I'm using Gutsy Gibbon 7.10 (32 bit) with a Mirai 19" screen and I am stuck at 1280x1024. My normal resolution is 1440x900. So far the flickering in video playback has gotten better when compiz is running (using 3 day old git). Scrolling in firefox is still slow but useable for me. The worst is still (at least for me) that I get a black screen for 2 secs when I start a video file (even in a browser) though not when the file is embedded in flash. This should have been fixed by now, it is irritating as hell because I always get the feeling that my xserver is crashing when I start a video. Hoping for a hotfix too for the widescreen issue ASAP PLEASE!!!




                  • #89
                    Okay, to make it short:
                    Am I the only one for whom the driver does work as expected?

                    It is working nicely with my widescreen at 1920x1200, opengl is working (did play quite a lot UT2k4 yesterday and it did work like a charm, videoplayback with opengl does work in mplayer and kaffeine (I don't use VLC anymore since sound often is screwed up with VLC while it works in all the other players). ZSNES is working nicely just as expected, I did fire up chronotrigger at 1600x1200 using openGL and there are *no* problems/crashes/whatever. Yes, I am not using this strange stuff named aiglx/compiz/xgl/whatever since I want to *work* with my computer, not go blind on eye candy...

                    In short:
                    It looks like some widescreen resolutions (and 1400x1050) are broken, at least 1920x1200, 1920x1080 and 1280x720 are working. I don't know anymore which other ones my display does report as supported, so I won't say the work or don't.

                    BTW, I am currently writing this message from my comp with exactly that driver and a 3850 512MB from Sapphire and am running Gentoo x86. And it looks like this card is having by far less problems than my old 9800agp (sometimes I had image disortion in ut2k4 at high resolutions and when shutting down xorg when using fglrx sometimes the whole system would crash, all those problems seem to be solved with my new card). Basically I did get the new card to support AMD/ATI for supporting OpenSource by releasing specs without any NDA on them. And I think so far the card does work and the driver, too.


                    • #90
                      i still have got this damn problem:
                      /usr/bin/eselect opengl set --use-old xorg-x11
                      xorg cannot load the glx module (/usr/lib/xorg/modules/extensions/
                      this file is a symlink to: /usr/lib/opengl/ati/extensions/ .. but there's NOTHING in the directory!

                      i use gentoo ~x86 and used the ebuild to install the driver. when it installs it tells me all the files he copies, but there are no files in the dir. it copies no libglx AT ALL!!

                      please help me!

                      gentoo ~x86
                      ati radeon 9600xt AGP 128MB
                      athlon xp 3000+ barton (socket a)