No announcement yet.

AMD Catalyst 7.12 Linux Driver -- The Baby's In Surgery

  • Filter
  • Time
  • Show
Clear All
new posts

  • hmm. very very strange ...
    now i TRY to run compiz on xorg-1.3 .. ok , i have to admit: it does run! .. but it's f*****g unusable! i thought version 7.11 was a bit slow in compiz, but now it's really like you turn on slow motion when slow motion is already turned on!!

    The only possibility:
    Are there some options for xorg.conf that do improve the 3d-speed ? or: are there some options that do slow everything down ?

    please tell me .. else i have to buy a nvidia in 2 weeks

    EDIT: now i saw that X uses the WHOLE cpu-power when compiz is running! so i think it's no problem with the driver ?!
    when compiz isn't running X takes 6-9% cpu load
    any suggestions / hints ?

    EDIT2: when i don't run compiz and my 3D-screensaver is starting it's veeeerrry slow. i think every 3D app is slow.. glxgears only has HALF fps as before
    Last edited by benneque; 22 December 2007, 05:09 AM.


    • Hmm, I don't seem to have much of the problems what you guys are having. On my Ubuntu 7.10 (Gutsy), all I had to to was just install dkms (apt-get install dkms), then double-click on the .run file and "Run in Terminal". Everything works for the installation part.

      I'm using ATI Mobility Radeon X1400 with 1280x800 resolution (widescreen), Acer Aspire 5560, and everything worked perfectly (yep, even projector plugging etc.)

      The dkms magic worked perfectly, and I was having Compiz Fusion on the re-start. Performance for me was on par with 7.11/7.10, except for scrolling lags in Firefox. Frame rates in ET:QW didn't drop or increase (or maybe it was unnoticable).

      Suspend and hibernate worked perfectly with the modified acpi-support. No XVideo issues were observed too, except for some minor flicker when GTK windows are placed above the video window.


      • OK, so basically, they fixed one memory leak and added support for FireGL? No real accelerated Compiz? No video playback?

        Come on, they aren't poor open-source guys trying to do their job in free time. They are paid developers who suck at their work. No excuses.


        • Now installed the driver, here some impressions:

          1. +100 fps in fgl_glxgears on a Radeon 9550 (~612fps)
          2. Vlc with OpenGL output works fine (i could post my xorg.conf if anyone needs)
          3. Xvideo doesn't crashes xorg anymore, so i can play my favourite video in Vlc or Mplayer with Xvideo output

          4. I use an Ati's BigDesktop configuration with an LCD monitor at 1280x1024 and a Tv Color at 1024x768. Since 7.11 release i can't use this configuration because the LCD goes to 1024x768 as TV


          • People you do realise that the resolution issue was mentioned in the release notes as a known issue riht?


            • Originally posted by Raven3x7 View Post
              People you do realise that the resolution issue was mentioned in the release notes as a known issue riht?
              1. As far as I know release notes do not mention any problems with my resolution (1440x900).
              2. Even if they did, I would still complain because I do not feel that I should remain silent when drivers keep getting worse with every release. If 8.1 had some ridiculous known issues (lets say: '8.1 changes display to 256 colours') would you stay quiet only because they do know about this problem? I doubt it.



              • People you do realise that the resolution issue was mentioned in the release notes as a known issue riht?
                i think that this resolution issue is due to some non standard edid in the monitors. i've tried my lg and it works in 1440x900, my laptop samsung works at 1280x800. so, after reading some xorg logs around it seems that non standard edid have problems to be read. i'll try also the hdmi through dvi-hdmi converter on my lcd tv and see what happens. i'll let you know if this functions.


                • Fedora packages are failing to build for me.

                  Checking for unpackaged file(s): /usr/lib/rpm/check-files /tmp/ATI-fglrx-8.443.1-1-20858-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root
                  error: Installed (but unpackaged) file(s) found:
                  RPM build errors:
                      Installed (but unpackaged) file(s) found:
                  Removing temporary directory: fglrx-install.P20779
                  The RHEL packages fail even worse than this! Can someone tell me wha is supposed to happen to this unpackaged file, please?


                  • I'm having the same problem as above, and yet livna has not build a rpm for fglrx 7.12
                    Anybody can help?


                    • I'm having the same problem, and yet livna has not published catalyst 7.12
                      Anybody can help?