Announcement

Collapse
No announcement yet.

How to get Xv output working with my HD7790

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to get Xv output working with my HD7790

    I have an HD7790 and so far the rest of the open source driver seems to work fine. One issue though. I don't have Xv output. What gives? Does the driver support it?

    I am using debian unstable(sid) fully updated.

  • #2
    Originally posted by SledgeHammer_999 View Post
    I have an HD7790 and so far the rest of the open source driver seems to work fine. One issue though. I don't have Xv output. What gives? Does the driver support it?

    I am using debian unstable(sid) fully updated.
    IIRC the xv functionality used to be disabled by default so glamor had to be built with --enable-xv... no idea if this is still the case though.
    Test signature

    Comment


    • #3
      You need a new enough version of glamor to support Xv. I'm not sure debian packages glamor at all at the moment.

      Comment


      • #4
        You can check debian build logs, they have glamor explicitly disabled in sid.
        https://buildd.debian.org/status/pac...suite=unstable

        It looks however like they enabled glamor in xserver from experimental (though no radeon driver has been released yet that can use glamor when it is part of the X server).

        Comment


        • #5
          Great, so the open source driver is pretty much useless for me.
          Normally this should be the priority on new drivers:
          1. Get 2D working
          2. Get video acceleration working (Xv)
          3. Workout your 3D stack (opengl 4+)
          4. Opencl if we are lucky.

          Comment


          • #6
            Originally posted by SledgeHammer_999 View Post
            Great, so the open source driver is pretty much useless for me.
            Normally this should be the priority on new drivers:
            1. Get 2D working
            2. Get video acceleration working (Xv)
            3. Workout your 3D stack (opengl 4+)
            4. Opencl if we are lucky.
            First of all for any radeon on Debian make sure you have firmwares installed . Glamor as lib was/not/and never will be available in Debian . Debian will support glamor accel but as part of xserver not a lib, you need xserver 1.16 version for that .

            Basically you have two option right now, if you use xserver 1.15 compile and install glamor lib then just rebuild ddx deb with glamor enabled or install xserver 1.16 from experimentall and rebuild ddx .

            Comment


            • #7
              Originally posted by SledgeHammer_999 View Post
              Great, so the open source driver is pretty much useless for me.
              Normally this should be the priority on new drivers:
              1. Get 2D working
              2. Get video acceleration working (Xv)
              3. Workout your 3D stack (opengl 4+)
              4. Opencl if we are lucky.
              That sequence worked well when GPUs had dedicated hardware for 2D and video, but those days are long gone. Nowadays 2D and video acceleration uses the 3D hardware, and so 2D / video acceleration uses the 3D driver via GLamor.
              Test signature

              Comment


              • #8
                Originally posted by SledgeHammer_999 View Post
                Great, so the open source driver is pretty much useless for me.
                Normally this should be the priority on new drivers:
                1. Get 2D working
                2. Get video acceleration working (Xv)
                3. Workout your 3D stack (opengl 4+)
                4. Opencl if we are lucky.
                The open source driver has all the features you want right now and more (video decode via vdpau/openmax, video encode via openmax), it's just that debian chooses not to package it. It should work out of the box on other distros.

                Comment


                • #9
                  Ubuntu 14.04 on Kaveri :

                  Code:
                  [email protected]:~$ xvinfo
                  X-Video Extension version 2.2
                  screen #0
                    Adaptor #0: "GLAMOR Textured Video"
                      number of ports: 16
                      port base: 63
                      operations supported: PutImage 
                      supported visuals:
                        depth 24, visualID 0x21
                      number of attributes: 5
                        "XV_BRIGHTNESS" (range -1000 to 1000)
                                client settable attribute
                                client gettable attribute (current value is 0)
                        "XV_CONTRAST" (range -1000 to 1000)
                                client settable attribute
                                client gettable attribute (current value is 0)
                        "XV_SATURATION" (range -1000 to 1000)
                                client settable attribute
                                client gettable attribute (current value is 0)
                        "XV_HUE" (range -1000 to 1000)
                                client settable attribute
                                client gettable attribute (current value is 0)
                        "XV_COLORSPACE" (range 0 to 1)
                                client settable attribute
                                client gettable attribute (current value is 0)
                      maximum XvImage size: 8192 x 8192
                      Number of image formats: 2
                        id: 0x32315659 (YV12)
                          guid: 59563132-0000-0010-8000-00aa00389b71
                          bits per pixel: 12
                          number of planes: 3
                          type: YUV (planar)
                        id: 0x30323449 (I420)
                          guid: 49343230-0000-0010-8000-00aa00389b71
                          bits per pixel: 12
                          number of planes: 3
                          type: YUV (planar)
                  Test signature

                  Comment


                  • #10
                    Same here with Debian Sid on Kabini .

                    @SledgeHammer_999

                    If you want that combo for current Debian testing/sid as deb packages: builded trusty's glamor + rebuilded ddx with glamor enabled... i am pleased to share those labs , that is builded few months ago for me, should work fine .

                    https://www.dropbox.com/s/n0n9ypq2jr...bglamor-ddx.7z

                    Install debs or rebuild that again/alone if you don't trust me . So put ddx on hold an wait for xserver 1.16 - when that happens just unhold/upgrade ddx and remove libglamor .
                    Last edited by dungeon; 11 June 2014, 08:18 PM.

                    Comment

                    Working...
                    X