No announcement yet.

"Ask ATI" dev thread

  • Filter
  • Time
  • Show
Clear All
new posts

  • Now I just installed Catalyst 9.4 at my system openSUSE 11.1, Xorg 7.4, xserver 1.6.1, Radeon HD 3450, Radeon HD 3200...

    Yep indeed xserver 1.6 works now as long as Randr 1.2 with or without Texturedxrender option load but the previous problems remain unchanged here...

    I stil cannot enable the damn Crossfire chain to make Hybrid Crossfire work!!
    For one more time the X freezes upon load...
    And Xorg.0.log stops at this line:
    CF Ribbon Cable not connect trying SW Crossfire
    And the PC freezes for good...

    I could enable Hybrid Crossfire with Xorg 7.3 straight away!
    Please guys do something for that!
    I mean is it so difficult to port Hybrid Crossfire usage for Xorg 7.4??
    Xorg 7.3 works fine why not 7.4??

    After being tired of PC freezes I tried enabling HD 3200 chip via the command:
    aticonfig --adapter=all --initial
    Then desktop really came for the first time and when you gave:
    aticonfig --lsch
    Showed the chain enabled and working...
    But I was sure something wasn't correct here. I typed:
    aticonfig --lscc
    And it showed me that I had 2 primary adapters which is very wrong... And of course no sign of the word crossfire at Xorg.0.log file.

    If any friend has any ideas or knowledge on this I will be glad to hear anything!
    Last edited by djdoo; 18 April 2009, 10:46 PM.


    • Oh and something else... I am trying to help people back in Compiz forum to understand the way fglrx now works and communicates with amdpcsdb via aticonfig tool and how to make a better setup for their composited environments...
      I just do my best there informing our users by watching the news at Phoronix and from my experience with the various driver versions also.

      That's the thread's link and it has become way more popular than I expected it would be in the first place when I created it and a little bit of more official help would be very apreciatted by all of us Compiz community
      I cannot answer everything only with my experience...
      If there is any interest from AMD for these stuff just PM me or post here.

      Best Regards
      Last edited by djdoo; 18 April 2009, 11:07 PM.


      • Only 76 pages...
        Test signature


        • Is there any use in reporting bugs here


          • Hello there !

            I am total noob and extremly exited about Ubuntu. I have very powerfull card installed on my system 4870x2 and looks like I am having problems with it.

            After installation on Ubuntu I got informed that proprietary drivers are available for my ATI video card and I clicked okay for download and install. After restart right on moment when I would see desktop I see messed up screen and looks like system, freeze too. After that I format hard drive and install Ubuntu again and decided to download drivers from AMD web site. Installed it via very nice GUI and after reboot EXACTLY same thing happened. I mean even screen looked exactly messed up like before, you know sometimes it get messed up totally randomly ? No this one is same as before. Guys please help me out here I don't know what to do, I also tried to download 9.2 drivers but on install it saying that this version on Ubuntu not supported by 9.2 (something like that)

            Here is my system specs I hope you can help out. Right now I am in Ubuntu with no ATI stuff installed I did reformat hdd again cause I could not login again because of messed up screen.

            Mobo: Asus P6T Deluxe
            CPU: i7 920
            RAM: GSkill 1333 3x2gb sticks 6gb total
            Video: Asus 4870x2 TRI_FAN design
            Monitor: 24' ASUS 1920x1080
            PSU: Antex-1000 w1000

            I really down know what else to mention all I know is I think If I can remember at some point of time I had Ubuntu few versions before and it worked fine with my card. Again I "THINK". I hope guys you can help.

            Thank you very much in advanced !


            • ... and another one, and another one, and another one bites the dust!

              Now i think i know why the called it the "Spider" platform, cos people get stuck in the spider's web.

              Can you described "messed up" screen please?


              • Oh absolutely. It looks like Analog TV with no signal, no know dot's all over screen and if needed I can take a picture of screen, basically screen gets corrupted on first sign of a desktop. Please excuse me for my lack of better explanation, English is not my first language and I write what I see.

                Thank you


                • Here is video on what is going on + Pictures.



                  This is screen I see. Nothing is working all keys are dead...caps lock or anything else is not working.
                  I hope it helps.


                  • Just work with open-source drivers, really. Who cares about compiz?


                    • Are you talking to me ? What is compiz ? And what drivers are available for 4870x2 other than one listed in

                      Thanks ...