Announcement

Collapse
No announcement yet.

Do Devs play games or test what they do ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by bridgman View Post
    When you say "the drivers were out of the box" are you talking about Mesa 9.2 or the more recent ones ? My impression was that Mint 16 shipped with a 3.11 kernel and 9.2 Mesa but you seem to have a newer kernel as well as newer Mesa, and Mint doesn't seem to be particularly aggressive in terms of driver updates.

    The Mint Debian version (based on Debian testing) seems to have a newer kernel but it's still not obvious to me where you could be getting 10.2 Mesa from if you don't have a testing PPA enabled somehow...
    Yes. To improve performance on my Trinity APU i require at least Kernal 3.12 in order to recieve the performance improvements. Also mesa 9.2.5 is perfectly smooth and plays with no lag, with the driver set at 1.7.2.0 for x.server .. its as soon as Mesa goes beyond 10.1 that things slow down and frames don't appear in in a smooth equality timed sequence.

    Comment


    • #12
      Originally posted by asdfblah View Post
      hyperz was disabled in 10.2, did you enable it? you have to set a environment var:
      Code:
      R600_DEBUG=hyperz
      I didnt know that, Im also not sure how to do it

      now i feel dumb..

      I could test this though if i knew..

      Comment


      • #13
        Just load up and enter into a terminal before launching:
        Code:
        R600_DEBUG=hyperz
        /path/to/game/binary

        Comment


        • #14
          Don't the two commands (setting the environment variable and running the app) have to be on the same line ?

          R600_DEBUG=hyperz /path/to/game/binary

          Comment


          • #15
            Originally posted by bridgman View Post
            Don't the two commands (setting the environment variable and running the app) have to be on the same line ?
            Yep

            HTML Code:
            R600_DEBUG=hyperz /path/to/game/binary
            or two line:

            HTML Code:
            export R600_DEBUG=hyperz
            /path/to/game/binary

            Comment


            • #16
              Oh good

              My guess is that phill1978 will want to start with the first option, since that allows easy switching between "with" and "without' the setting...

              Comment


              • #17
                Originally posted by siavashserver
                For which cards is hyperz disabled by default?
                It is disabled for all cards which use r600 and radeonsi mesa drivers. Not sure, but only cards which have it enabled now by default are those who use r300 driver.

                r100 and r200 drivers does not have it implemented, so there is nothing to disable .
                Last edited by dungeon; 04-08-2014, 02:01 AM.

                Comment


                • #18
                  Originally posted by siavashserver
                  Is enabling hyperz supposed to give a big frame rate boost for all applications? I can't see any difference when running Unigine Heaven benchmark with hyperz being enabled/disabled. I'm using Linux kernel 3.14 and a little out dated Mesa 10.2-git on a RadeonHD4890.
                  Yes HYPERZ is known tehnics to boost frame rate

                  http://www.anandtech.com/show/635/4

                  . So it is known for ~15 years , but seems not 100% known to the opensource radeon developers to make stable implementation, so that it can deserve to be enabled by default .

                  For Unigine Heaven, yes some engines may use similar tehnics so hyperz does nothing there to improve performance .

                  Comment


                  • #19
                    I added the statement on its own, it may be a co-incidence though

                    R600_DEBUG=hyperz

                    ^

                    that one. And now i have slower performance. It would seem my FPS is capped at 50. Yet I have a 60hz monitor? GLX gears is 50 and CounterStrike fps is locked at 50fps.. this is presenting a slowed down / juddering motion as its not vsync'd properly.

                    could that command have caused this? if so how to i turn it off?

                    also how do i change my refresh? Im using cinnamon 2.0 and there isn't a refresh control option, so i changed to 1280 x 780 and that is running glxgears at 60fps .. so im thinking some of the weird performance here is that 1920 x 1080 is somehow now running at 50hz ..

                    such pains running FOSS and AMD, not being able to easily select refresh rates
                    Last edited by ForkedPython; 04-08-2014, 05:11 PM.

                    Comment


                    • #20
                      @phill1978

                      http://xorg.freedesktop.org/wiki/Rad...ture/#index2h2

                      Comment

                      Working...
                      X