Announcement

Collapse
No announcement yet.

So I built myself a new rig...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FutureSuture
    started a topic So I built myself a new rig...

    So I built myself a new rig...

    ...and Linux only boots off a live USB stick when using AMD's nonfree driver in UEFI mode. Linux won't boot when using free or nonfree drivers in Legacy mode or the free driver in UEFI mode. All I get is a blinking underscore during those instances.

    I consequently installed Linux by booting the live USB stick using AMD's nonfree driver in UEFI mode and then switched to AMD's free driver after upgrading to kernel 3.13 and uninstalled the nonfree driver. Now I get a blinking underscore when booting as well.

    My hardware:
    • Intel i5 4670K
    • AMD R9 290X
    • Gigabyte GA-Z87X-UD5H

    What can I do to fix this? It took long enough just to figure out how to boot Linux on this newly built rig of mine. I used SUSE Studio Image Writer to create the live USB stick and have tried Manjaro, openSUSE, and GParted Live.

  • Calinou
    replied
    Disable PCI-E 3.0 (and use PCI-E 2.0 instead) in the UEFI? There won't be any performance decrease, especially considering how the 290(X) is crippled under non-Windows OS...

    Leave a comment:


  • Kano
    replied
    For Kanotix gfxdetect mode it is not allowed to have Intel active. In that case i do not activate fglrx. Certainly i would use something i know that works, if it does not it is a driver fault. From usb key you can start Kanotix in uefi and mbr mode.

    Leave a comment:


  • FutureSuture
    replied
    Originally posted by Ouroboros View Post
    I had a very similar issue when I attempted to test a discrete GPU with Linux in my APU build. IIRC, the bios had some dual-GPU mode set by default and I had to switch it to auto for Linux to boot properly.
    I hate it when something is caused by an incorrect BIOS configuration :/ IIRC, the option was hidden and at the very end of all the configuration options on my ASRock board, too
    The thing is, my monitor is already connected to the GPU, and shows me everything up until the blinking underscore. Why would the CPU suddenly be a problem? And why is it not a problem only when booting the nonfree driver in UEFI mode?

    Leave a comment:


  • FutureSuture
    replied
    Originally posted by Kano View Post
    As you did not find it, I even downloaded the manual of your board. Guess what, you can find the setting in the Peripherals section:

    Internal Graphics - Disable (or Auto if available)

    Hard to believe that you did not see that...
    Oh, that? I already tried that and it did not help whatsoever. Please stop being so condescending. Thank you. I am looking for help, not accusations.

    Leave a comment:


  • Ouroboros
    replied
    I had a very similar issue when I attempted to test a discrete GPU with Linux in my APU build. IIRC, the bios had some dual-GPU mode set by default and I had to switch it to auto for Linux to boot properly.
    I hate it when something is caused by an incorrect BIOS configuration :/ IIRC, the option was hidden and at the very end of all the configuration options on my ASRock board, too

    Leave a comment:


  • Kano
    replied
    As i do not own Optimus i tested radeon+Intel, radeon+nouveau successfully, but i could not fake real Optimus with binary nvidia driver. 2 or more cards from the same vendor did not work as well. For nouveau i needed an override to init it with Intel first and kernel 3.13. Vdpau can be switched with PRIME, vaapi needed a patch. I got am hotfix for vaapi but it crashes inside the app still when you use a non supported card with it. Nouveau does not work on a system without CSM, can not test this with radeon as i only have got old Evergreen cards. But binary drivers do not really work well on Desktops when Intel onboard is active, even when no monitor is connected.

    Leave a comment:


  • DanL
    replied
    Originally posted by Kano View Post
    Which would be like an Optimus setup. Don't enable Intel GPU in your firmware when you don't know what you do. I guess Gigabyte has it as default as somebody with Nvidia GPU had the Intel GPU active as well with a Z87 board...
    Just having an integrated and discrete card does not make it a hybrid GPU setup...

    A discrete PCI-e card should automatically disable the integrated graphics on most motherboards.

    Leave a comment:


  • Kano
    replied
    As you did not find it, I even downloaded the manual of your board. Guess what, you can find the setting in the Peripherals section:

    Internal Graphics - Disable (or Auto if available)

    Hard to believe that you did not see that...

    Leave a comment:


  • FutureSuture
    replied
    Originally posted by Kano View Post
    It's simple why i wanted the full output. You see this:

    00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])

    and

    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii XT [Radeon HD 8970] [1002:67b0] (prog-if 00 [VGA controller])

    Which would be like an Optimus setup. Don't enable Intel GPU in your firmware when you don't know what you do. I guess Gigabyte has it as default as somebody with Nvidia GPU had the Intel GPU active as well with a Z87 board...
    Ahhh, I see what you mean now. I don't see how that happened, though. On my old desktop (built it myself too), I had an Intel CPU and a Nvidia GPU and never had that issue with booting live USB sticks. Is there a way to disable the Intel GPU in the UEFI? I haven't been able to find a way yet.

    Leave a comment:

Working...
X