Announcement

Collapse
No announcement yet.

8.42.3 TexturedVideo

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Porter
    replied
    I've found that using OpenGL output in VLC (with fglrx 8.42.3 or 7.11) results in smooth scaling, while Xv output has blocky edges. I use the OpenGL output full-time now because of that, despite the odd horizontal and 45deg diagonal tearing artifacts in fast motion, high contrast scenes.

    Leave a comment:


  • sundown
    replied
    Blocky and tearing for me.... it was always blocky and tearing, more than a year now.

    Leave a comment:


  • Christian_L
    replied
    I get blocky fullscreen as well, both in VLC and MPlayer. Mobility Radeon X1400.

    Leave a comment:


  • Whoopie
    replied
    I meant distorted so that I can't even imagine what I would see there.

    Leave a comment:


  • bridgman
    replied
    By "screwed" do you mean distorted or "blocky and tearing" ?

    Leave a comment:


  • Whoopie
    replied
    Hi,

    I get 4 XV ports when enabling TexturedVideo, but all movie players show a screwed picture.

    Do I have to change the config for e.g. mplayer so that it works with TexturedVideo?

    Thanks for your help,
    Whoopie

    Leave a comment:


  • dixon
    replied
    I can't get it working with fglrx So my question is - Can I get multiple xv ports with the opensource driver?

    Leave a comment:


  • MU_Engineer
    replied
    Originally posted by dixon View Post
    Hi.
    Is TexturedVideo working for anybody?
    Works just fine on my x1900GT.

    Leave a comment:


  • dixon
    started a topic 8.42.3 TexturedVideo

    8.42.3 TexturedVideo

    Hi.
    Is TexturedVideo working for anybody? I discovered this feature just week ago. I didn't need it really before, but to be able to use the new feature in skype(webcam support) I need multiple xv ports. When I enable the texturedvideo option in xorg.conf the videos are ok in original size, but when I resize the video or switch to fullscreen the video is blocky(also the subtitles) and there's also some tearing visible.

    I'm using Mobility R9700 with fglrx drivers(8.42.3).
    Here's my xorg.conf
    Code:
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"ZAxisMapping"		"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"		"/dev/psaux"
    	Option		"Protocol"		"auto-dev"
    	Option		"HorizEdgeScroll"	"0"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"stylus"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"eraser"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"cursor"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
    	Driver	"fglrx"
    	Option	"VideoOverlay" "on"
    	Option	"OpenGLOverlay" "off"
    	Option 	"TexturedVideo" "on"
    	Option	"XaaNoOffscreenPixmaps" "on"
    	BusID		"PCI:1:0:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"V?eobecn? monitor"
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
    	Monitor		"V?eobecn? monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Modes		"1024x768"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Option          "AIGLX"         "true"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    
    # Uncomment if you have a wacom tablet
    #	InputDevice     "stylus"	"SendCoreEvents"
    #	InputDevice     "cursor"	"SendCoreEvents"
    #	InputDevice     "eraser"	"SendCoreEvents"
    	InputDevice	"Synaptics Touchpad"
    EndSection
    
    Section "DRI"
            Mode 0666
    EndSection
    
    Section "Extensions"
    	Option "Composite" "Enable"
    EndSection
    Any help would be really appreciated THX
Working...
X