Announcement

Collapse
No announcement yet.

Suggestions about how to make a Radeon HD 7790 work decently?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • smitty3268
    replied
    Originally posted by Praxis View Post
    Code:
    $ glxinfo | grep OpenGL
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD BONAIRE
    OpenGL version string: 2.1 Mesa 10.1.0-devel (git-3b1195f saucy-oibaf-ppa)
    OpenGL shading language version string: 1.30
    OpenGL extensions:
    Does that seem like it is what I want?
    Yes, except that Mesa was compiled with LLVM 3.3 instead of 3.4, which is why you've only got GL 2.1 support. That also comes with a lot of bug fixes/improvements for SI drivers.

    Hopefully oibaf will start using 3.4 sometime soon. I think it's due to be released any time now, so that might fix his dependency issues he was having.

    Leave a comment:


  • bridgman
    replied
    I think that looks right. AFAIK as long as you get "Gallium 0.4 on AMD BONAIRE" then everything else is probably correct.

    Now it's just a matter of updating regularly to get the latest goodness

    Leave a comment:


  • Praxis
    replied
    Well, Fedora 20 won't help, I didn't bother to download it. It uses mesa 9x and 3.11 so it won't run radeon on a HD 7000, I don't think.
    http://www.phoronix.com/scan.php?pag...nchmarks&num=1

    On the plus side, (K)ubuntu 14.04 Alpha 1 has been released which seems to have mesa 10 (in a special repo, lined up for the release next April) and the 3.12 kernel, so it might well work. I'm downloading the live image and will report back how it does, though I'm hesitant to upgrade 13.10 to an Alpha release.

    I guess I'm meant to be using radeonSi, I have "ati" as the driver in my xorg.conf.
    Code:
    $ grep -i driver /var/log/Xorg.0.log
    [  7948.042]    X.Org Video Driver: 14.1
    [  7948.042]    X.Org XInput driver : 19.1
    [  7948.046] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
    [  7948.046]    Module class: X.Org Video Driver
    [  7948.046]    ABI class: X.Org Video Driver, version 14.1
    [  7948.047] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
    [  7948.047]    Module class: X.Org Video Driver
    [  7948.047]    ABI class: X.Org Video Driver, version 14.1
    [  7948.047] (II) RADEON: Driver for ATI Radeon chipsets:
    [  7948.057] (II) glamor: OpenGL accelerated X.org driver based.
    [  7948.271] (II) RADEON(0): [DRI2]   DRI driver: radeonsi
    [  7948.271] (II) RADEON(0): [DRI2]   VDPAU driver: radeonsi
    [  7948.432]    Module class: X.Org XInput Driver
    [  7948.432]    ABI class: X.Org XInput driver, version 19.1
    Code:
    $ glxinfo | grep OpenGL
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD BONAIRE
    OpenGL version string: 2.1 Mesa 10.1.0-devel (git-3b1195f saucy-oibaf-ppa)
    OpenGL shading language version string: 1.30
    OpenGL extensions:
    Does that seem like it is what I want? Wine still freezes my desktop up until I kill it, but on the plus side I can finally enable desktop effects on KDE. I'll post this and see if compiz still freezes my system.

    EDIT: fusion-icon segfaulted but it didn't lock up my system, PROGRESS!
    Last edited by Praxis; 12-20-2013, 07:02 PM.

    Leave a comment:


  • Praxis
    replied
    I tried installing the current AMD fglrx driver using their installation script, it failed, it gave me a cryptic message in its log which I posted a couple of days ago (along with a couple of screen shots), but that message didn't seem to get moderated to appear on the forum. I rebooted but the desktop was unusable, though I was able to get in to X. FWIW, my virtual consoles looked 640x480. I was forced to try reinstalling the fglrx driver using X forwarding from another machine since the desktop was almost completely unresponsive. The installer claimed there was a previous install, but even if I used the force it was an unhappy camper. The installer kept giving warnings not to use the force option, but wouldn't proceed and didn't give any alternative. Generally the installer would just stall out rather quickly and not advance. The fgrlx-install logs didn't clarify matters, so I gave up on fglrx. Maybe by the time Jessie becomes stable it will work in Debian.

    I reverted to radeon with oibaf. Every time I start a wine program it just about freezes my desktop, I see one of my 6 cores taking 100% of my CPU (not always the same core). 20-45 MB a day of new updates from http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu/ don't seem to be making my issues disappear. But for now I can play videos and interact with the desktop as long as I don't start a wine program. Wine works fine over X forwarding from another machine, BTW. So I guess I can limp along until 14.04 appears. I may try the Fedora 20 live image next week, which seems to have the right mesa drivers and kernel to work, but I hate using Fedora, seems like the devs just delight in throwing up irritating obstacles. sbin not in root's path, what's up with that? Even if Fedora works like greased lightning with radeon I don't think I'll install it, but I'll report back my experience.

    Leave a comment:


  • flim
    replied
    Ignore my previous post (the part with disabling radeon); misunderstood something ^^
    Last edited by flim; 12-12-2013, 05:53 PM.

    Leave a comment:


  • flim
    replied
    Originally posted by A Laggy Grunt View Post
    If you think fglrx was installed, you might want to walk through exactly how you installed it.

    Here's how I did it:
    Become root
    Run fglrx-xxxxx.sh
    Choose the "Install" option (not the generate packages option)
    Finish the install
    Reboot
    And don't forget to disable/ prevent the radeon module from loading (radeon.modeset=0).

    It's easy to tell if it is installed and running: press ctrl+alt+f1 (then alt+f5 or f7 to get back to X)
    Using the open-source radeon driver, the virtual terminal displays at my native resolution (1600x1200) with very small text.
    Using fglrx, it's 640x480.
    Well not always. In my case, the resolution with fglrx is native at 1920x1080 (7970 and A10-5800K).

    --
    Also, I suggest not messing with beta drivers. They're a good way to mess things up.

    Leave a comment:


  • Praxis
    replied
    Originally posted by mmstick View Post
    If you read what my script does, you'll know what it does. It first looks to see if you have an NVIDIA GPU or have fglrx installed. If you have fglrx installed the script exits with a message telling you to uninstall it if you want the latest and greatest foss. If you have an NVIDIA GPU it installs NVIDIA's proprietary graphics. Otherwise it then checks to see if you are running Ubuntu 12.04, and if so, it will add Pali's PPA for the latest open source drivers, else it will add Oibaf's PPA for the latest open source drivers, then it installs the open source drivers. Then, it automatically downloads the latest stable Linux kernel (3.12) unless you remove grep -v rc which will make it install the latest RC kernel (3.13-rc3?). It can be rerun as many times as you want, really. I designed it to be fault-proof to work on any machine. If you want HDMI audio and DPM enabled by default, use the RC kernels; but don't complain if RC kernels are unstable.
    I glanced over the script and though I'm not too wise in the ways of BASH it seemed like it did what I have already done, mmstick. But I figured I'd give it a throw, so I saved it to a text file & made it executable and tried to run it, but kept getting errors.

    $ sudo ./mmstick.sh
    ./mmstick.sh: line 10: syntax error near unexpected token `fi'
    ./mmstick.sh: line 10: ` fi'

    I don't know enough about scripting to fix the error on my own. This is what I have:
    Code:
    #!/bin/bash
    ## Install Latest Kernel and GPU Drivers
    # Note: If you want to download RC kernels, edit kernelURL section below to remove the grep -v rc option.
    if [ -n "$(lspci | grep NVIDIA)" ]
       then
          isNVIDIA=true
       else if [ -n "$(lsmod | grep fglrx)" ]
          echo "You are currently using Catalyst. Uninstall Catalyst (sudo apt-get remove fglrx) and re-run this script after rebooting if you want the latest kernel and open source graphics drivers."    
          exit 0                                                                                                            
       fi                                                                                                                   
    fi
    
    ## Install GPU drivers
    if [ "$isNVIDIA" == "true" ]
       then
          sudo apt-get install nvidia-current-updates nvidia-settings -y
       else
          if [ -n "$(cat /etc/lsb-release | grep precise)" ]
             then
                sudo add-apt-repository -y ppa:pali/graphics-drivers -y
             else
                sudo add-apt-repository -y ppa:oibaf/graphics-drivers -y
          fi
    
          sudo apt-get update
          sudo apt-get upgrade -y
          sudo apt-get dist-upgrade -y
    
    fi
    
    ## Install Kernel
    if ! [ "$isNVIDIA" == "true" ]
      then
          sudo apt-get install lynx -y # lynx must be installed
    
          cd /tmp
          sudo rm *.deb
    
          # Stable Kernels Only
          kernelURL=$(lynx -dump http://kernel.ubuntu.com/~kernel-ppa/mainline/ | grep -v rc | tail -1 | sed 's/^......//')
    
          echo "The latest kernel is $(echo $kernelURL | cut -d/ -f 6)."
          echo "The currently installed kernel is $(uname -r)."
    
          if [ "$(uname -m)" == "x86_64" ]
             then
                echo "Downloading the latest 64-bit kernel."
                wget $(lynx -dump -listonly -dont-wrap-pre $kernelURL | sed -n '16p' | sed 's/^......//')
                wget $(lynx -dump -listonly -dont-wrap-pre $kernelURL | sed -n '18p' | sed 's/^......//')
                wget $(lynx -dump -listonly -dont-wrap-pre $kernelURL | sed -n '19p' | sed 's/^......//')
             else
                echo "Downloading the latest 32-bit kernel."
                wget $(lynx -dump -listonly -dont-wrap-pre $kernelURL | sed -n '17p' | sed 's/^......//')
                wget $(lynx -dump -listonly -dont-wrap-pre $kernelURL | sed -n '18p' | sed 's/^......//')
                wget $(lynx -dump -listonly -dont-wrap-pre $kernelURL | sed -n '20p' | sed 's/^......//')
          fi
    
          echo "Installing Linux Kernel"
          sudo dpkg -i linux*.deb
          echo "Done. You may now reboot."
    fi
    I'll try it again if you can tell me what I have wrong. Anywho, tonight I'll either run that script or try AMD's fglrx stable, this time using their script rather than transmogrifying it in to a deb file. Man, the option of re-boxing the card and waiting until Tahr is looking more and more appealing.

    Leave a comment:


  • asdfblah
    replied
    To make sure fglrx is running, run: lsmod | grep fglrx and/or glxinfo | grep render

    Use this guide to make sure you are removing fglrx correctly: http://wiki.cchtml.com/index.php/Ubu...talyst.2Ffglrx

    I would do it this way: first, remove fglrx as the wiki says, and THEN add oibaf's repo, to make sure there is nothing wrong..

    Leave a comment:


  • mmstick
    replied
    Originally posted by A Laggy Grunt View Post
    If you think fglrx was installed, you might want to walk through exactly how you installed it.

    Here's how I did it:
    Become root
    Run fglrx-xxxxx.sh
    Choose the "Install" option (not the generate packages option)
    Finish the install
    Reboot

    It's easy to tell if it is installed and running: press ctrl+alt+f1 (then alt+f5 or f7 to get back to X)
    Using the open-source radeon driver, the virtual terminal displays at my native resolution (1600x1200) with very small text.
    Using fglrx, it's 640x480.
    --
    Also, I suggest not messing with beta drivers. They're a good way to mess things up.
    There's a problem with that and RadeonSI. Only the latest Beta drivers are good drivers. The stable driver is much glitchier/unstable/lower-performing. You're pretty much stuck between a rock and a hard place.

    Leave a comment:


  • A Laggy Grunt
    replied
    If you think fglrx was installed, you might want to walk through exactly how you installed it.

    Here's how I did it:
    Become root
    Run fglrx-xxxxx.sh
    Choose the "Install" option (not the generate packages option)
    Finish the install
    Reboot

    It's easy to tell if it is installed and running: press ctrl+alt+f1 (then alt+f5 or f7 to get back to X)
    Using the open-source radeon driver, the virtual terminal displays at my native resolution (1600x1200) with very small text.
    Using fglrx, it's 640x480.
    --
    Also, I suggest not messing with beta drivers. They're a good way to mess things up.

    Leave a comment:

Working...
X