No announcement yet.

Radeon+Gnome 3+AMD Xpress 1250 (Samsung R60) = Driver Glitches

  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon+Gnome 3+AMD Xpress 1250 (Samsung R60) = Driver Glitches

    I have a big problem...
    Gnome 3 (gnome-shell) bar is always corrupted.

    Restarting the shell (Ctrl-Alt-Backspace-Backspace) does not fix the issue.
    Machine had no graphical glitches on w xp.

    The issue stretches between OpenSuse 12.3 and Tumbleweed, with Kernel 3.7 and 3.11 accordingly.
    All these systems are vanilla, stock, untuned
    Upgrade was performed according to OpenSuse Tumbleweed upgrade SDB, process was not interrupted,
    all associated stacks are affected.

    In Tumbleweed new special effects appeared:
    when Gnome just started, the screen is split into four triangles (hypotenuses are faced towards display sides) that quickly flash with default color green.
    The "show" disappears within 4 seconds.

    Sometimes, invoking glxinfo or glxgears does not work, with response "Error opening display(null)", after some time or after restarting the shell it works.
    The glxinfo looks pretty normal to me, ie Mesa/sgi acceleration (NOT software), version 9.2.2 and GLSL 1.40.

    There are no errors in dmesg or Xorg.0.log.
    Xorg config of OpenSuse is extremely weird (but its taken stock and untouched) in /etc/X11/xorg.conf.d/*
    I can't figure out why and what extensions are loaded.. :/

    I have tried increasing GART size by means of "radeon.gart=1024" to grub2 kernel line, I can confirm via dmesg grep that 1GiB gart was loaded.

    I have tried using "radeon.dpm=1", but dmesg indicates no info of power management (pre3.11 or post3.11), I suggest this GPU does not use any kind of reclocking.

    Also, various posts over internet suggest xpress 1250 was working perfectly with opensource drivers even in 2010....

    Dmesg, 2.5Mb, plaintext

  • #2
    I found more confirmation of this problem for year 2012 and 2013.
    Yes, a lot of people still use this chipset, and it would be awesome if someone could fix it..

    Affects Gnome 3, Unity, Cinnamon.


    This bug on Ubuntu Launchpad here, here

    .... and freedesktop has a bugreport for this already


    • #3
      I have replaced 1GiB slot with 2GiB today. Look at special effects:

      I also updated the bug tracker info on freedesktop.

      To me, it looks like OpenGL texture transfer corruption, as I can see individual triangles at login.
      The text is damaged in exactly same way, this is 100% mesa/radeon bug.

      And no one responds

      I even wanted to buy a different notebook today, but they are all windows 8 infected without ANY freaking opt-out option.

      Dear radeon developers, your r300g driver is very very bad, please help us!!


      • #4
        Originally posted by brosis View Post
        And no one responds
        I counted 12 responses from developers just on ticket 35457, including code patches, register tweaks and setting changes to try. Where were you looking ?
        Test signature


        • #5
          Originally posted by bridgman View Post
          I counted 12 responses from developers just on ticket 35457, including code patches, register tweaks and setting changes to try. Where were you looking ?
          This very same error is going on since 2009, since near release of the notebooks with this chip in many many various instances. Developers responded, people tried, nothing really changed. This problem, reported many many times, is arguably longer unfixed than AMD program itself, yet 1250 works pretty well even in W7. Its a magic, no one understands why, so crying is the only thing left, all these threads are full of it


          • #6
            Just an update here, the driver is still completely broken.
            I think about selling R60 now, because of the issue. Great laptop for all other aspects though, everything works - from hibernation to networking. Really sad.