Announcement

Collapse
No announcement yet.

Radeon HDMI Audio issues with Kernel 3.12-rc2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • agd5f
    replied
    Originally posted by Hibbelharry View Post
    I don't get it. Alex writes exactly what users expect, audio should be enabled and turned on by default. Now the default is to initialize audio but not to enable it. So after all people still need to mess around either with kernel parameters or obscure xrandr calls. That's even more nice when no xserver is used (ok, that mostly obscure). I think that new behaviour not really what feels like any advantage. Why don't we just enable hdmi audio and turn it on by default ? Isn't that what all the other drivers do ?
    We'll probably enable audio by default in the next kernel. Previous there were still a number of corner cases which would result in blank screens or other display problems if audio was enabled, but I think we've fixed most of them at this point.

    Leave a comment:


  • Hibbelharry
    replied
    I don't get it. Alex writes exactly what users expect, audio should be enabled and turned on by default. Now the default is to initialize audio but not to enable it. So after all people still need to mess around either with kernel parameters or obscure xrandr calls. That's even more nice when no xserver is used (ok, that mostly obscure). I think that new behaviour not really what feels like any advantage. Why don't we just enable hdmi audio and turn it on by default ? Isn't that what all the other drivers do ?

    Leave a comment:


  • Tyler_K
    replied
    Alex pushed a related change today: http://lists.freedesktop.org/archive...er/047531.html

    Leave a comment:


  • ThereThere
    replied
    Originally posted by Death Knight View Post
    It's not broken but de-activated.
    For enable HDMI audio on 3.12 kernel\ you need to issue this command:

    Code:
    xrandr --output HDMI-0 --set audio auto
    Ok, thanks a lot, hdmi audio is working now but unfortunately the system crashes about a minute later I have issued that command

    I'm running on 3.12 rc5 kernel.

    Leave a comment:


  • Death Knight
    replied
    It's not broken but de-activated.
    For enable HDMI audio on 3.12 kernel\ you need to issue this command:

    Code:
    xrandr --output HDMI-0 --set audio auto

    Leave a comment:


  • Death Knight
    replied
    Still broken on RC4.

    Leave a comment:


  • Death Knight
    replied
    Thanks for the info

    Leave a comment:


  • Death Knight
    replied
    Forgot to say that using Radeon HD6850

    Leave a comment:


  • Death Knight
    started a topic Radeon HDMI Audio issues with Kernel 3.12-rc2

    Radeon HDMI Audio issues with Kernel 3.12-rc2

    I just wanted to test Linux 3.12.rc2 kernel from SuSE HEAD repo.
    Working good but HDMI audio.

    Does any one have a issues with 3.12.rc2 kernel? I have same issue with rc1 also.
    Do I need to adjust some settings?

    on dmesg, I can saw that Audio is enabled:

    [drm] Enabling audio 0 support

    But there is no sound.Any hints?
Working...
X