Announcement

Collapse
No announcement yet.

AMD Publishes HDA Audio GPU Documentation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic AMD Publishes HDA Audio GPU Documentation

    AMD Publishes HDA Audio GPU Documentation

    Phoronix: AMD Publishes HDA Audio GPU Documentation

    AMD has finally published NDA-free public programming documentation concerning the HDA audio support on Radeon GPUs...

    http://www.phoronix.com/vr.php?view=MTQ2NjU

  • fritsch
    replied
    With v2.0 specs released. Anssi could implement Bitstream Audio within minutes:



    :-)

    Thanks all involved.

    Leave a comment:


  • HokTar
    replied
    Originally posted by Tyler_K View Post
    What output do you get for:
    Code:
    cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v
    ~$ cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v
    X.Org X Server 1.13.4
    xrandr program version 1.3.5
    Server reports RandR version 1.4


    So is my xrandr version too old? That would be simple explanation, I guess.
    Btw, thanks for your help!

    Leave a comment:


  • Tyler_K
    replied
    Originally posted by HokTar View Post
    I'm using 3.12-rc1 from the ubuntu kernel ppa, I suppose it should be there, though I haven't checked.

    Edit: I checked that the patch was merged 3-4 days before rc1 was tagged so I suppose my kernel must have it, too.

    I only get:
    ~$ xrandr --output HDMI-0 --set audio enable
    X Error of failed request: BadName (named color or font does not exist)
    Major opcode of failed request: 140 (RANDR)
    Minor opcode of failed request: 11 (RRQueryOutputProperty)
    Serial number of failed request: 37
    Current serial number in output stream: 37

    If I write "auto", "on", etc. it's still the same story.
    As I said, with radeon.audio=1 works, which is already good enough for me until ubuntu sorts itself out.
    What output do you get for:
    Code:
    cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v

    Leave a comment:


  • HokTar
    replied
    Originally posted by agd5f View Post
    Are you sure you were using a recent 3.12 kernel? Make sure your kernel has:
    http://git.kernel.org/cgit/linux/ker...1b124a6d2fa5b0
    I'm using 3.12-rc1 from the ubuntu kernel ppa, I suppose it should be there, though I haven't checked.

    Edit: I checked that the patch was merged 3-4 days before rc1 was tagged so I suppose my kernel must have it, too.

    I only get:
    ~$ xrandr --output HDMI-0 --set audio enable
    X Error of failed request: BadName (named color or font does not exist)
    Major opcode of failed request: 140 (RANDR)
    Minor opcode of failed request: 11 (RRQueryOutputProperty)
    Serial number of failed request: 37
    Current serial number in output stream: 37

    If I write "auto", "on", etc. it's still the same story.
    As I said, with radeon.audio=1 works, which is already good enough for me until ubuntu sorts itself out.
    Last edited by HokTar; 09-22-2013, 05:30 PM.

    Leave a comment:


  • fritsch
    replied
    Here we go: http://mailman.alsa-project.org/pipe...er/066578.html

    Have fun with testing.

    Leave a comment:


  • agd5f
    replied
    Originally posted by HokTar View Post
    That didn't work. Setting radeon.audio=1 helped, though.
    Are you sure you were using a recent 3.12 kernel? Make sure your kernel has:
    http://git.kernel.org/cgit/linux/ker...1b124a6d2fa5b0

    Leave a comment:


  • darkbasic
    replied
    Originally posted by agd5f View Post
    Support for SI/TN and newer hardware was added in 3.12. Additionally, with 3.12 you no longer need to boot with radeon.audio=1. You can enable/disable audio on the fly with xrandr. E.g., xrandr --output HDMI-0 --set audio auto
    Really? I did some tests with 3.12 and I thought it didn't work because I didn't know of the new xrandr option.

    Any chance to fix QT's raster engine? SI is starting to be fast and supports lots of features, it's a pity being not able to use it

    Leave a comment:


  • HokTar
    replied
    Originally posted by agd5f View Post
    Support for SI/TN and newer hardware was added in 3.12. Additionally, with 3.12 you no longer need to boot with radeon.audio=1. You can enable/disable audio on the fly with xrandr. E.g., xrandr --output HDMI-0 --set audio auto
    That didn't work. Setting radeon.audio=1 helped, though.
    Trinity, 5800K.

    Thanks, this was the last big missing feature for me!
    Here's hoping that xbmc will work with vdpau -- but ubuntu doesn't even build the gallium state tracker in xorg-edgers yet.

    Leave a comment:


  • DeepDayze
    replied
    Now only if NVIDIA will follow suit with code for their HDMI audio implementations as used on their cards, but not holding my breath...

    Leave a comment:

Working...
X