No announcement yet.

radeon-profile: tool for changing profiles and monitoring some GPU parameters

  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by haagch View Post
    Editing is gone on phoronix? Yes, once powerplay support is implemented, it will work with amdgpu-pro since it uses the same amdgpu kernel driver.
    I believe Michael temporarily disabled editing for non-premium users due to a recent surge in spamming.


    • [...]to support multiple gpus at the same time.
      It does not work with multiple gpus at the same time. User can change gpu using this list in top left part of the window, and this change the device index and temperature reads and changes of profile affect only this card.

      hmm, is PowerPlay same thing for amdgpu as DPM is for radeonsi?


      • Just today changed to a Polaris GPU (Sapphire Nitro+ OC). This little tool worked perfectly on my previous HD7850. Currently I have two issues. First is this:

        It seems it can't read the clock data on the card. As I stated previously, it worked just fine on my Pitcairn chip.

        Second issue is fan control, specifically the custom curve. It does not seem to work. Every time I add a step it removes the previous on I have created. Also, when I save the profile and apply it, the percentage indicator at the top signals 100%, but the fan does not spin up at all.

        I downloaded a fresh copy and build it again just to be sure, but the issues still persist.


        • First issue, do you use it with daemon or as root? If with daemon you can try restart the daemon:
          systemctl restart radeon-profile-deamon.service
          I also pushed some modifications to it, so if this won't work, try build new version.

          Second one. Do you have multiple curve definitions or just 'default' one? I had this problem before, I thought I've fixed it.


          • I don't run the daemon, just as root like I always have.
            As for the fan curves, I tried to make my own but the individual steps would not save. Every time I added one the previous step would get overwritten. Same deal if I try to change the "default" profile.


            • Does it print something out if you run it from terminal?
              Also, can you post files: /sys/class/drm/card0/device/uevent and /sys/kernel/debug/dri/0/amdgpu_pm_info?
              Apparently something is not detected properly.


              • If I run it without root I get:
                Daemon is not connected, therefore it can't be configured
                No data was found (you need debugfs active and either root access or radeon-profile-daemon)
                ... and the window does not show up.

                Running it with root it loads up, but with that "can't read data" error.

                Here are the contents of my uevent file:

                ~$ sudo cat /sys/class/drm/card0/device/uevent
                And amdgpu_pm_info:

                ~$ sudo cat /sys/kernel/debug/dri/0/amdgpu_pm_info
                GFX Clocks and Power:
                        300 MHz (MCLK)
                        300 MHz (SCLK)
                GPU Temperature: 42 C
                GPU Load: 0 %
                UVD: Disabled
                VCE: Disabled


                • Thanks. I pushed updates, clocks should work now.


                  • Works now. Thank you very much.

                    Something funny about the fan control section. In order to add steps and not have them be erased you need to save them to the profile, after which you can add another step without it replacing the previous one (like what was happening to me before). You need to do that each time for each step. Is that how it's supposed to work?

                    Now I just need to figure out why kdesudo is refusing to run it. I can only run it from Konsole using plain sudo.


                    • Thanks for the explanation. No, it should not behave like this, I pushed updates to fix that problem. Thanks for the report.