No announcement yet.

Texture errors with mesa-devel

  • Filter
  • Time
  • Show
Clear All
new posts

  • Texture errors with mesa-devel

    Hello. I installed mesa-devel, kernel 3.11, libdrm and sf86-ati from git on Debian Testing 64-bit.

    But games that use a more complex engine (nexuiz, tf2) have corrupted (or just black in tf2) textures. These crop up in the terminal (both games):

    EE r600_shader.c:1597 tgsi_unsupported - FSGE tgsi opcode unsupported
    EE r600_shader.c:158 r600_pipe_shader_create - translation from TGSI failed !
    EE r600_state_common.c:754 r600_shader_select - Failed to build shader variant (type=1) -22
    If i reinstall the system's mesa (9.1.6 now), the textures show up fine.

    mesa config:
    ./configure --sysconfdir=/etc --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu --enable-debug --enable-texture-float --with-gallium-drivers=r600,swrast --enable-glx --enable-vdpau --enable-dri --with-dri-drivers=radeon --enable-egl --enable-osmesa --enable-gles1 --enable-gles2 --enable-glx-tls --enable-64-bit --disable-32-bit --enable-driglx-direct CPPFLAGS=-D_FORTIFY_SOURCE=2 CXXFLAGS=-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Wall --enable-shared-glapi --with-dri-searchpath=/usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri --with-dri-driverdir=/usr/x86_64-linux-gnu/dri --enable-gallium-llvm --enable-xa --enable-r600-llvm-compiler --enable-xorg
    I tried different options, disabling llvm but they still have the same result. What should i do to be able to use mesa git?

    As the systems mesa implementation works, i assume either the git has bugs or i didnt do something right - i checked the package build flags on the debian qa site but didnt see anything out of the ordinary (some options i took from there, but to no avail).

    PS I installed for both 32 bit and 64 bit to have Steam covered, but it has the same error as the 64 bit nexuiz.

  • #2
    Use an earlier mesa, or wait a few days. Those new opcodes were added just days ago, and seems r600 wasn't yet updated.


    • #3
      Which version has the older opcodes?

      Edit: nevermind, 9.2 sems to have it. Thank you.
      Last edited by gradinaruvasile; 08-18-2013, 11:34 AM.


      • #4
        Had the same problem, but with the latest build it's working again.

        This commit fixed it: