No announcement yet.

8.42 - No direct rendering!

  • Filter
  • Time
  • Show
Clear All
new posts

  • 8.42 - No direct rendering!

    I've tried to install the new driver twice, once just the way I always have and again following a guide, same results.

    (Using Kubuntu 7.10 btw with an ATI x1400)

    fglrxinfo says that I am using the ATI driver, not Mesa.

    glxinfo says NO DIRECT RENDERING:

    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=vebose

    In glxinfo it says OpenGL Mesa, so I don't get the difference. I also don't know what to do with that LIBGL_DEBUG line.

    If anyone can offer a suggestion, I would REALLY appreciate it! BTW because I have no direct rendering, my computer is going slow as molasses, so if I can get it to load a few files and a webpage, I will try and post the full text of fglrxinfo, glxinfo, and my xorg.conf...

    Thank you in advance!

  • #2
    I have a same problem. Please help.
    I am on ubuntu 7.10 x86_64.
    I got the ATi drivers installed (with that new package file) but I dont have Direct Rendering.


    • #3
      My xorg.conf:

      # xorg.conf (xorg X Window System server configuration file)
      # This file was generated by dexconf, the Debian X Configuration tool, using
      # values from the debconf database.
      # Edit this file with caution, and see the xorg.conf manual page.
      # (Type "man xorg.conf" at the shell prompt.)
      # This file is automatically updated on xserver-xorg package upgrades *only*
      # if it has not been modified since the last upgrade of the xserver-xorg
      # package.
      # If you have edited this file but would like it to be automatically updated
      # again, run the following command:
      #   sudo dpkg-reconfigure -phigh xserver-xorg
      Section "ServerLayout"
      	# Uncomment if you have a wacom tablet
      	#	InputDevice     "stylus"	"SendCoreEvents"
      	#	InputDevice     "cursor"	"SendCoreEvents"
      	#	InputDevice     "eraser"	"SendCoreEvents"
      	Identifier	"Default Layout"
        screen 0 "aticonfig-Screen[0]" 0 0
      	Inputdevice	"Generic Keyboard"
      	Inputdevice	"Configured Mouse"
      	Inputdevice	"Synaptics Touchpad"
      Section "Files"
      Section "Module"
      	Load		"glx"
      Section "InputDevice"
      	Identifier	"Generic Keyboard"
      	Driver		"kbd"
      	Option		"CoreKeyboard"
      	Option		"XkbRules"	"xorg"
      	Option		"XkbModel"	"pc105"
      	Option		"XkbLayout"	"us"
      Section "InputDevice"
      	Identifier	"Configured Mouse"
      	Driver		"mouse"
      	Option		"CorePointer"
      	Option		"Device"	"/dev/input/mice"
      	Option		"Protocol"	"ImPS/2"
      	Option		"ZAxisMapping"	"4 5"
      	Option		"Emulate3Buttons"	"true"
      Section "InputDevice"
      	Identifier	"Synaptics Touchpad"
      	Driver		"synaptics"
      	Option		"SendCoreEvents"	"true"
      	Option		"Device"	"/dev/psaux"
      	Option		"Protocol"	"auto-dev"
      	Option		"HorizEdgeScroll"	"0"
      Section "InputDevice"
      	Identifier	"stylus"
      	Driver		"wacom"
      	Option		"Device"	"/dev/input/wacom"
      	Option		"Type"	"stylus"
      	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
      Section "InputDevice"
      	Identifier	"eraser"
      	Driver		"wacom"
      	Option		"Device"	"/dev/input/wacom"
      	Option		"Type"	"eraser"
      	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
      Section "InputDevice"
      	Identifier	"cursor"
      	Driver		"wacom"
      	Option		"Device"	"/dev/input/wacom"
      	Option		"Type"	"cursor"
      	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
      Section "Monitor"
      	Identifier	"aticonfig-Monitor[0]"
      	Option		"VendorName"	"ATI Proprietary Driver"
      	Option		"ModelName"	"Generic Autodetecting Monitor"
      	Option		"DPMS"	"true"
      Section "Device"
      	Identifier	"aticonfig-Device[0]"
      	Driver		"fglrx"
      	Option		"VideoOverlay"	"on"
      	Option		"OpenGLOverlay"	"on"
      Section "Screen"
      	Identifier	"aticonfig-Screen[0]"
      	Device		"aticonfig-Device[0]"
      	Monitor		"aticonfig-Monitor[0]"
      	Defaultdepth	24
      	SubSection "Display"
      		Viewport	0	0
      		Depth	24
      Section "Extensions"
      	Option		"Composite"	"0"

      display: :0.0  screen: 0
      OpenGL vendor string: ATI Technologies Inc.
      OpenGL renderer string: ATI Mobility Radeon X1400
      OpenGL version string: 2.0.6958 Release

      name of display: :1.0
      display: :1  screen: 0
      direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
      server glx vendor string: SGI
      server glx version string: 1.2
      server glx extensions:
          GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
          GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
          GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
          GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
      client glx vendor string: SGI
      client glx version string: 1.4
      client glx extensions:
          GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
          GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
          GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
          GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
          GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
          GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
          GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
      GLX version: 1.2
      GLX extensions:
          GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
          GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
          GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
      OpenGL vendor string: Mesa project:
      OpenGL renderer string: Mesa GLX Indirect
      OpenGL version string: 1.2 (2.1 Mesa 7.0.1)
      OpenGL extensions:
          GL_ARB_depth_texture, GL_ARB_fragment_program, GL_ARB_imaging,
          GL_ARB_multitexture, GL_ARB_point_parameters, GL_ARB_point_sprite,
          GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
          GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
          GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
          GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
          GL_ARB_texture_non_power_of_two, GL_ARB_texture_rectangle,
          GL_ARB_transpose_matrix, GL_ARB_vertex_program, GL_ARB_window_pos,
          GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
          GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
          GL_EXT_clip_volume_hint, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
          GL_EXT_fog_coord, GL_EXT_framebuffer_object, GL_EXT_multi_draw_arrays,
          GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_polygon_offset,
          GL_EXT_rescale_normal, GL_EXT_secondary_color,
          GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
          GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
          GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
          GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
          GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
          GL_EXT_vertex_array, GL_APPLE_packed_pixels, GL_ATI_texture_env_combine3,
          GL_ATI_texture_mirror_once, GL_ATIX_texture_env_combine3,
          GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
          GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_NV_blend_square,
          GL_NV_point_sprite, GL_NV_texgen_reflection, GL_NV_texture_rectangle,
          GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
          GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
          GL_SGIX_shadow, GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays
         visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
       id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
      0x2c 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
      0x2d 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
      0x2e 32 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 Ncon
      0x2f 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon

      I would REALLY appreciate any advice! Been at this for 3 hours now, and I was so looking forward to this driving... gonna pull my hair out soon.


      • #4
        Try to comment (or remove) this part on your xorg.conf:

        Section "Extensions"
        	Option		"Composite"	"0"
        But I still can't get direct rendering too.


        • #5
          Thanks Janus - I actually added that line in to see if it would help, it didn't. I removed it though to double-check, no help. Still no direct rendering. This is really depressing.


          • #6
            Post up the contents of /var/logs/Xorg.0.log

            I'd bet DRI cant initialize properly because of an older kernel module version.


            • #7
              Alright the log came out to over 40,000 characters and the board will only allow 10,000... lol

              Didn't know what to do about that so I put it as a post on my blog. Sorry about that.


              Thank you for trying to help.


              • #8
                Strange, given that I do see in your log :
                (II) fglrx(0): Direct rendering enabled
                And I see that there are a number of aiglx messages. I also see GLX_EXT_texture_from_pixmap in your extensions. And it seems clear to me that the you are using is from mesa and not from ati, because your glxinfo shows :
                OpenGL vendor string: Mesa project:
                OpenGL renderer string: Mesa GLX Indirect
                OpenGL version string: 1.2 (2.1 Mesa 7.0.1)
                Try to see why it is using of mesa and not of ati. As a brute force workaround, you can save a copy of existing and link / copy the fglrx driver's in its place (you don't even have to restart X, the result would be immediate .) In gentoo linux for example, to change it, one runs 'eselect opengl set ati'.

                Btw, you may enable composite and aiglx in your xorg.conf (should do no harm).


                • #9
                  Thanks hdas... how the hell do I do that? *grin*

                  I may be a computer tech, but I know windows. I'm learning Linux on my own time (love it, use it exclusively at home, but I am still lost with alot of it...)

                  Not sure where that file is or what I'm doing. Noob here.

                  I did however notice that it said directed rendering was enabled in the log... *shrug*


                  • #10
                    Erm, sorry about that (forgot I was not in gentoo forums ). It typically should be /usr/lib/, but it is usually a link to the actual in some other place. Before proceeding, I would ask you to first run the following command 'ldconfig' (or /sbin/ldconfig) to make sure all library paths and links are good.

                    If that doesn't solve the problem, first find all instances of in your system - since they are usually in /usr/lib/, do 'find /usr/lib/ | grep'. Then use 'ls -la /usr/lib/' to find out the actual file it is linked to. Make a backup of existing link or file (mv /usr/lib/ /usr/lib/ and create a new link to one of the ati you found using 'find /usr/lib/ | grep'. (Example, 'ln -s /usr/lib/opengl/ati/lib/ /usr/lib/', and run 'ldconfig'). Then see if that works. (Note that this may not be permanent - try to see if there are any environment variables in your distro used at startup that tell which to use.) (PS : To revert, 'rm /usr/lib/' and 'mv /usr/lib/ /usr/lib/'.)