No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • "and if you get it started, then go the configuration center, search for the daemons configuration (i don't know how this is called, but you should see a list of services as acpid, cups, xdm, alsa and similar listed on the base of different levels 3 - terminal login without xorg, 5 - graphical login, 0 - shutdown, 6 - restart). you'll know when you'd have found it because you'll see these services listed there and you'd be asked for a root password to access it in administrator mode.

    I go there and do what?
    btw i can't find what is that!

    despite that ie followed the other steps and after changing some things in xorg like have 2 times the indentifier zone per device that made occurs some errors I got this workin and this is the result of the comand:

    cat /var/log/Xorg.0.log | grep EE
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (EE) Failed to load module "type1" (module does not exist, 0)
    (II) Loading extension MIT-SCREEN-SAVER

    i guess I don't have type1..

    another question is:
    would this solve my problems?
    the slow compiz i guess not because i've just tried it out again...
    Last edited by Neo4; 31 October 2007, 09:31 PM.


    • i guess I don't have type1..
      comment the type1 module in the modules sections.

      would this solve my problems?
      the slow compiz i guess not because i've just tried it out again...
      no. compiz is slow. i get about 100-200fps with compiz while get at best 1900fps without aiglx and beryl. i've read around that there are some problems with compiz, so if you want 3d effects use beryl (on my board doesn't slowed after i set the options right) or try using xgl-compiz.

      as for the services:

      you have to look for something like this:

      it seems it is called sys-rc-conf (that's the name of that thing)

      here's a guid on how to speed up your ubuntu/kubuntu box. look at it on how to add or remove a service at init time. from what i've learned you just have to add the file to /etc/rcx.d where x is the runlevel you want it added.


      • but what i do? active that service atieventsd? what is that for?
        and active it in which number? 1,2,3...?!
        it is already active in number 2, 3, 4, 5.

        sorry but you are being to vague in what is needed.

        i've commented the tipe1 after i've seen that error

        Last edited by Neo4; 01 November 2007, 10:23 AM.


        • it is already active in number 2, 3, 4, 5.
          then it starts normally as you start the pc.

          if you do a /etc/init.d/atieventsd status
          it should give a started or running status.

          the atieventsd is the ATI Event handler service. it's normally used by ati cards to communicate with other processes like xorg and others. by default it should be started, but it's not always like that, and that may prevent you from using susped/hibernate, or have various xorg locks or application errors.
          the levels are from 0 (shutdown to 6 reboot). the other levels are for distinguishing from xorg-window-login (level 5) to terminal login (level 3) while others like 2 or 4 should be out of order but you never know for sure. for example, on my pc i run in level 3 with xdm started at half the boot process to have a graphical/konsole login.
          if i were to chose the level 5 i would have started kdm automatically but would have to say to it to login to the console before having a konsole/kdm login. for distros like ubuntu/kubuntu opensuse or fedora, the levels simply mean that in level 3 you have only the services needed for running a konsole and without any service needed for xorg and that in level 5 you'd have all the services needed for running a full xorg login system.


          • is there hope?

            Hej all,

            I'm new in here and did register because of thinkable reasons....

            Some days ago I bought two digital 19 inch LCDs and a GeCube HD2600Pro AGP card with two DVI outputs. I had to choose AGP because my mainboard (Intel D865GB Intel PIV, 3 GHz, 1,5 MB RAM) does not have a PCIe slot. I'm not a gamer, my plan is to have much space to work on. I had Beryl running on my old graphic subsystem ? just for fun ? but after spending some money in this powerful hardware I want the system to be able to bring up a funny animated desktop like compiz-fusion, which seems to be the actual reunited project. So long-term object is to have two independent cubes but my trouble begins a lot closer:

            After assembling the card to my board, the onboard Intel-graphic was automatic disabled and the two new monitors showed the booting Linux in cloned mode. By the way, I'm running Debian Etch with gnome desktop. The xserver didn't start of course. I installed the ATI driver 8.42.3 (successfully I think) and built an initial xorg.conf by running aticonfig ?initial=dualhead. I had to edit /etc/modules and add fglrx manually. Also, after having a lot of successless tries, I checked the symbolic link issue with the (as far as I remember ? I tried a lot before posting) ? without changing anything. I also deinstalled driver 8.42.3 and switched to 8.41.7 ? with same effect. I read this whole thread and found that I seem to have quite a seldom card but I am not alone with the log entries but with the concrete trouble:

            After starting the xserver, the monitors switch to 1280x1024 both, one with mouse the other without (that's pretty good so far). The mouse can be moved for about two or three seconds before the whole system freezes and has to be cold booted.

            It hurt from the beginning but after days of trying ang reading and hacking it hurts a lot.... But still I am full of hope and post in here those parts of the logs that I consider to keep the secret. I find the lines containing complains concerning interrupt handling to be the most interesting, that's why I also tried to speed down the AGP-Bus by adding 'Option ?AGPMask? ?0x00000216?' and 'Option ?AGPv3Mask? ?0x00000001?'. I think my mainboard does not support AGPx8 but AGPx4.

            Of course, I can post more logs or all...

            Is there hope??


            nl-ws-boris:~# less /var/log/Xorg.0.log | grep EE
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
            (EE) fglrx(0): Failed to enable interrupts.

            nl-ws-boris:~# lsmod | grep fglrx
            fglrx 1487084 0
            agpgart 29896 2 fglrx,intel_agp

            nl-ws-boris:~# dmesg | grep fglrx
            fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
            [fglrx] Maximum main memory to use for locked dma buffers: 1414 MBytes.
            [fglrx] ASYNCIO init succeed!
            [fglrx] PAT is enabled successfully!
            [fglrx] module loaded - fglrx 8.42.3 [Oct 19 2007] on minor 0

            nl-ws-boris:~# less /var/log/syslog | grep AGP
            Oct 28 16:29:47 localhost kernel: agpgart: AGP aperture is 16M @ 0xfd000000
            Oct 28 16:37:51 localhost kernel: [fglrx] IRQ_MGR is disabled until GART_CACHABLE memory will be implemented<6>[fglrx] Internal AGP support requested, but kernel AGP support active.
            Oct 28 16:37:51 localhost kernel: [fglrx] Have to use kernel AGP support to avoid conflicts.
            Oct 28 16:37:51 localhost kernel: [fglrx] AGP detected, AgpState = 0x1f004a1b (hardware caps of chipset)
            Oct 28 16:37:51 localhost kernel: agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
            Oct 28 16:37:51 localhost kernel: agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
            Oct 28 16:37:51 localhost kernel: agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
            Oct 28 16:37:51 localhost kernel: [fglrx] AGP enabled, AgpCommand = 0x1f004312 (selected caps)


            • ah ok now i've understood thanks for all the support. by now i'vnt had that disgusting pixel at the right corner of the desktop and around the mouse!

              btw the glxgears shows +- 4800fps


              • Commenting out type1 would not do anything with regards to the beryl/compiz situation. X will continue to load regardless if the module is present or not.

                Regarding slow compiz, it is noticebly slower, but not incredibly slow (like 100-200fps in gears). Still in the thousands, but it takes a performance hit.

                BruderB...ah...dual heads >_> Fun...


                • by now i'vnt had that disgusting pixel at the right corner of the desktop and around the mouse!
                  neo, i assume that i'vnt stands for i haven't, am i right?

                  BruderB, you have some problems there, that we'll try to solve...

                  1. you have to verify if your lcds have the possibility of modifying the screen resolution on dvi. mine for example doesn't on dvi, but only on the old vga. so you may need to use the dvi-vga converter or a dvi-vga cable to make the screen get the resolution you want. for this you just have to read the manual of the lcd and you'll know if you are able to adjust you resolution (default should be about 1280x1024 which is quite low for a 19'')
                  2. you have an agp board... and that has some real bad issues with fglrx, and you have a new r600 which is supported from the 8.41.
                  now, it seems that fglrx had some real troubles with agp and that that issue should have been corrected in the 8.42, so you should use the 8.42.
                  3. for compiz-fusion, you HAVE to use at least the 6.0 version or it won't work for some known bugs, that should be fixed in the next release.
                  4. make sure you use kernel 2.6.22 if you've not applied the 2.6.23 kernel patch.
                  5. the dual head is also a little problem for what i know, and you need xinerama enabled.
                  first detach one monitor and go the page 51 of this thread and search for the xorg.conf that i've posted there. i'll assume you're using the 8.42.3 driver from now on.
                  take that and modify:
                  - look in the /usr/lib directory and see if you have the file. if not do this:
                  ln -s /usr/lib/opengl/ati/lib/ /usr/lib/
                  and substiture lib64 to lib if you're on 64bit architecture.
                  - the screen section where you paste your screen configuration for both screens
                  - the name of the board, which should be the one found by ati-config (which is known to break sometimes without generating a working configuration)
                  - the bus id should be the one your ati-config found.
                  - xinerama would be on and clone also should be on.
                  - with the XAANoOffscreenPixmaps you have to use the force copy for texture mode.
                  - with compiz and beryl force aiglx rendering.
                  - comment the modules and the fonts (or adjust them if you have them installed - even if this isn't really important) that don't load cause they're not in the system.

                  then add the following to your device section:

                  Option "AGPv3Mask" "0x00000001" #forces agp 8x
                  Option "AGPv3Mask" "0x00000002" #forces agp 4x
                  Option "BusType" "AGP" # tell xorg that this is an agp board and have him use as that
                  Option "KernelModuleParm" "agplock=1"
                  now you have to make sure some things:
                  you can also verify if the gart loads if the fglrx assigns to xorg a gart aperture. see the log for that.
                  you need to look out at boot about the agpgart and see if it loads. if you have it there, then you have to put this line (you use kernel agpgart):
                  Option "KernelModuleParm" "agpgart=3"
                  if after loading xorg it gives you failures then use this other line instead (this uses the fglrx agpgart):
                  Option "KernelModuleParm" "agpgart=0"
                  if after both of these options it fails to load agpgart (no kernel or fglrx loads) try this instead:
                  Option "KernelModuleParm" "agp_try_unsupported=1"
                  after that use the maxgartsize if fglrx recognizes different ram from the one of your board with this:
                  Option "MaxGARTSize" "integer"
                  whre integer = 256 for 256MBytes. use this ONLY if fglrx don't recognizes in the right way (undersets your ram).
                  do not use pbuffer with opengloverlay off.
                  Option "Stereo" "off"
                  - this will be needed with bigdesktop option. it should be off by default and would be off with videooverlay on, but it's better to have it off just in case.
                  this is the last thing:
                  Option "UseInternalAGPGART" "boolean"

                  Enable or disable the usage of an internal agpgart module. If you set this option to "yes", the driver will not use the kernel's AGPGart module. Instead it will make use of the "built-in" AGP support. The default is "no", as long as the graphics driver's kernel module detects the presence of an agpgart kernel module.
                  [Warning] Warning

                  If you set this option to "yes" you must ensure, that you don't have the kernel AGP support compiled in. Instead compile it as modules.
                  for this as for the agp options you have to make sure how the kernel agp works.

                  then if everything works out and you're able to use your single monitor, then add this and test the second head:
                  Option "DesktopSetup" "0x00000200"
                  this will set your xorg on bigdesktop with the primary display left.
                  this are the possible options for bigdesktop:
                  Big Desktop mode(s):

                  There is a single big frame buffer that gets split either horizontally or vertically and each half is sent to a single monitor. Both monitors have to operate with the same video mode settings and only one window manager can be used. The orientation is set with:
                  Parameter (integer) Mode
                  "0x00000200" Primary display is left.
                  "0x00000201" Primary display is right.
                  "0x00000300" Primary display is top.
                  "0x00000301" Primary display is bottom.
                  if you want instead dual head mode use:
                  Option "DesktopSetup" "0x00000000"
                  this sets your monitors on dual head mode:

                  Dual head mode:

                  A dual head setup uses separate frame buffers, independent displays and video modes for each monitor. Two window managers can be used.

                  [Note] Note

                  A connected digital display is always the primary display. If two display devices are connected, the primary head is: the bottom DVI port on FireGL X1, LCD output on MOBILITY RADEON M9 and the only DVI port on other cards. The secondary head is: the top DVI port on FireGL X1 and the VGA port on all other cards.
                  here there are some descriptions for some xorg options: . i've already selected the ones that should do for you but if you want to test more or if something isn't clear have a look there.
                  you may also want to stay tuned on the radonhd driver to see how it evolves. for now they're at the 0.0.2 version (for what i know).
                  Last edited by givemesugarr; 01 November 2007, 04:43 PM.


                  • Hej givemesugarr,

                    first let me send a big THANK YOU for your reply. I read it all and will follow step by step but have one additional question first:
                    Since I'm using Debain Etch, my system runs on kernel 2.6.18. Do I have to have a newer kernel?


                    Last edited by BruderB; 01 November 2007, 05:00 PM.


                    • Since I'm using Debain Etch, my system runs on kernel 2.6.18. Do I have to have a newer kernel?
                      no, for what i know. you only need the .deb of the linux-headers and of the linux source that you're currently using. the module builds up for the kernel in use that should be in /usr/src/linux.

                      the problems arises when you try the driver with the lastes kernel release as in the case of the 2.6.23.

                      i'm not really sure, but maybe you'll have to upgrade xorg.

                      here are the release notes:
                      they say that you need the following:

                      # XOrg 6.7, 6.8, 6.9, 7.0, 7.1, 7.2 or 7.3; XFree86 version 4.3
                      # Linux kernel 2.4 or higher
                      # glibc version 2.2 or 2.3
                      # POSIX Shared Memory (/dev/shm) support is required for 3D applications

                      here is what you need as packages:

                      For best performance and ease of use, AMD recommends the following:

                      * Kernel module build environment - should include the following:
                      o Kernel source code: Either the Kernel Source or Kernel Headers packages
                      * The rpm utility should be installed and configured correctly on your system, if you intend to install via RPM packages

                      The following packages must be installed in order for the ATI Catalyst? Linux driver to install and work properly:

                      * XFree86-Mesa-libGL
                      * libstdc++ <-------- this is the v3 versio of gcc-3 libs and the driver WON'T absolutely work without it.
                      * libgcc
                      * XFree86-libs
                      * fontconfig
                      * freetype
                      * zlib