Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • brouhaha
    replied
    Fedora 7 x86_64: X server crashes

    With either 8.41.7 or 8.42.3, when I try to start the X server it fails with a backtrace. I'm using a Visiontek HD2600 Pro AGP.

    I've seen a few other postings by people who have seen this problem, but no indication of any solution. Any ideas? I'd really like to get this card working. If there's a way to do that with the current driver, that would be great, but if not it would be nice if it could be fixed in 8.43.

    The full details including configuration, xorg.conf, and log can be seen in this bug report

    Leave a comment:


  • toxigenicpoem
    replied
    Sorry if this has been mentioned in the last 50 pages of the post, I tried to read and find anything that might help me.

    X200M, AIGLX - Ubuntu 7.10. Only X11 video is providing any play back I can watch. OpenGL flickers TONS, Xv displays nothing but black... Wait till 8.44 or is there something I missed a couple posts back? Thanks.

    Leave a comment:


  • d2kx
    replied
    Michael, but Fedora 8 does not use Xserver 1.4. The version used is

    xorg-x11-server-Xorg-1.3.0.0-33.fc8.i386.rpm

    Or am I missing something?

    Leave a comment:


  • Michael
    replied
    Originally posted by peper View Post
    Anyone tested it under latest test release of Fedora 8? What about compatibility with FC7 both 32 and 64 bits?

    If you patch it for 2.6.23, it will work with F8. However, AIGLX won't work with X server 1.4. Fedora 7 is compatible with 8.42 but not with the stock version of Compiz.

    Leave a comment:


  • peper
    replied
    Anyone tested it under latest test release of Fedora 8? What about compatibility with FC7 both 32 and 64 bits?

    Leave a comment:


  • givemesugarr
    replied
    Thanks again!
    mine xorg.conf is one generated with the first fglrx version i was using under suse 9.2, the first distro i was using some time ago. then i had it tuned over the time and now it has reached a good state. i still have to fix the fonts since on gentoo i dont't have most of them, but i don't really the time to do that.
    since this xorg.conf works flawlessly with one of the worst ati boards it should work without any problems with other boards.
    the settings there set everything to default standard values, so you might lose some performance but you'll have some extra stability.

    Leave a comment:


  • happycampers
    replied
    Thanks!

    Originally posted by givemesugarr View Post
    xorg.conf for Neo4:... new xorg.conf:

    Many thanks to givemesugar for posting the example xorg.conf. I had the corruption in the lower corner and around the mouse cursor and had about given up on this driver (actually, I had already reverted it), but I saw a couple of flags in the xorg posted for Neo4 that I had not tried and thought to give it one more shot. I grabbed the Server, Layout and Device flags from the post and have been working for 3 days now without screen corruption with AIGLX / Compositing on or off. I had tried many of the other xorg "fixes" to no effect. Thanks again!

    Leave a comment:


  • peper
    replied
    Does those drivers finally supports properly FC7 x86 and x86_64 ???

    Leave a comment:


  • Octoguy
    replied
    Thank god this update's come out.

    Can't wait to use Compiz.

    Leave a comment:


  • givemesugarr
    replied
    My facts about the libGL.so ? stuff:
    this is the one that apps will use:
    lrwxrwxrwx 1 root root 26 2007-11-04 18:24 /usr/lib/libGL.so.1 -> /usr/lib/xorg/libGL.so.1.2
    the needs are there. the timestamp and similar depend on your system or on the creation date of the ati-driver, but that isn't important.
    So, I'm little confused about that. Can you give a mor detailed specification about what file is needed (date-/timestamp, size)?
    maybe the differences in the paths vary on the linux distros used. and usually debian has a different version.
    by the way, there wasn't a real need to upgrade debian. the driver should have worked also with the old one, but since you switched let's see that.

    I though about your words concerning my lcds having the possibility to modify the resolution. Well, I don't know for sure if my monitors use this feature but I'm very optimistic that they do: I didn't force any resolution in my xorg.conf using the vesa driver and the resolution was 1280x1024. The connectors are DVI on ATI-card-side as well as on monitor-side.
    take their manual and read where there's the dvi connection. from what you say they don't support modified resolution on dvi, since with vesa you're on 1280x1024. if i remember well vesa is 1024x768, but on this i might get wrong. anyway in the manual it's clearly said if the dvi supports different resolutions.

    At last, I built a xorg.conf following your hints up to the AGP-stuff that I didn't include yet. But I tried my own xorg.conf with the AGP-speed reduced to 4x and get the same result with both files:
    Fatal server error:
    Caught signal 11. Server aborting
    (I guess chrisr also wrote about this (page37?). By the way: Is there a way to search within a thread?)
    what does /var/log/Xorg.0.log says?! it's pretty important to know what makes it go wrong.

    and this from Xorg.0.log:
    (EE) fglrx(0): Failed to enable interrupts.
    only from this i don't understand what goes wrong. maybe from the entire log would be interesting.

    however, this is very interesting:
    Nov 4 19:58:46 nl-ws-boris kernel: [fglrx] IRQ_MGR is disabled untill GART_CACHABLE memory will be implemented<6>[fglrx] Internal AGP support requested, but kernel AGP support active.
    you now have to remove agpgart from kernel. first go to device drivers->character device and then write down every modules that automatically selects it and remove every one of them. after you've removed the modules that require it, then agpgart should give you the possibility to remove agpgart. remove it, recompile the kernel reboot and retry to start xorg, with internal agpgart set to yes. that should fix the problem and let you start xorg.

    Leave a comment:

Working...
X