No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • I checked /var/log/Xorg.0.log, and found that AIGLX was trying to initialize an old copy of, which was located in /usr/lib/xorg/modules/dri/

    I copied the new version (which the ati installed installed in /usr/lib/dri/ over the one in the old location, and now compiz starts up with no white screen.
    I installed the driver on Gutsy with a Radeon 1650 Pro 512MB AGP card. THe install went fine, but I got the White Screen of Death. The above fix worked like a charm for me.

    Thanks spotman!

    I noticed that scrolling in firefox and my terminal are both pretty slow, but cube spinning performance is lightning quick. Anyone else experience slow scrolling?
    My terminal is fine, but my Firefox is choppy when scrolling. I haven't really noticed an increase in speed (all my benchmarks are about the same), but system performance is better now that I'm not running XGL.

    Here's hoping things only get better from here!


    • Originally posted by cornelius View Post
      Installed and running 8.42.3. I had to do a "ln -s" to fix the missing libGL issue.

      • Suspend still doesn't work on Ubuntu 7.10, Ubuntu bug #121653, as the new SLUB allocator prevents fglrx from suspending.
      • Selecting xv in xine crashes X (returns to gdm).
      • Non-xv video (with TexturedVideo enabled) runs and is smooth, but it flickers a lot (in fullscreen too).
      • Same for OpenGL apps.
      • OpenGL apps and videos (with TexturedVideo) are drawn directly on screen, i.e. compiz can't zoom them or map them onto the sides of the cube while rotating, they remain on the screen in their original size/position.
      • Getting occasional compiz freezes (with mouse pointer still moving) as in Ubuntu bug #108527 and in Compiz Fusion bug #524. After the freeze I was able to do Alt-SysRq-R and switch to a terminal to see compiz.real using 100% cpu (infinite loop somewhere?).
      • Typing on gnome text-editor is really slow (holding a key pressed), while doing it on emacs-gtk seems as fast as before.
      • Scrolling in Firefox is pretty slow, compared to when Compiz is not running.

      I think introducing AIGLX support is a pretty big step for AMD, and hopefully we'll see it get better and better in terms of performance, right Michael?

      BTW Michael, which of these problems can we expect to be fixed in next month's driver?
      Incorrect on the SLUB allocator count. My laptop with 2.6.22 and SLUB now suspends fine. Now waking from suspend and trying to go to X, another story, but the driver doesn't block sleep like the older driver did with SLUB.


      • Output from kernel after resume trying to do X stuff

        When I successfully slept and resumed (avoiding the chvt back to X, of course) I tried to killall -9 Xorg, restart Xorg, that failed, so I tried to rmmod fglrx, and the kernel refused to deal. Here is the kernel output with stack traces:

        [ 1089.592000] BUG: unable to handle kernel paging request at virtual address f91800f8
        [ 1089.592000] printing eip:
        [ 1089.592000] f93b2a90
        [ 1089.592000] *pde = 369df067
        [ 1089.592000] *pte = 00000000
        [ 1089.592000] Oops: 0002 [#1]
        [ 1089.592000] SMP
        [ 1089.592000] Modules linked in: sbs battery ac thinkpad_acpi thermal fan button e1000 ndiswrapper nfs lockd sunrpc af_packet fglrx(P) rfcomm l2cap vboxdrv ppdev ipv6 acpi_cpufreq cpufreq_ondemand cpufreq_powersave cpufreq_stats cpufreq_conservative freq_table cpufreq_userspace container bay dock video parport_pc lp parport snd_hda_intel snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy joydev snd_seq_oss irtty_sir sir_dev snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq nsc_ircc pcmcia snd_timer snd_seq_device irda iTCO_wdt iTCO_vendor_support hci_usb serio_raw bluetooth snd wlan crc_ccitt pcspkr soundcore psmouse yenta_socket rsrc_nonstatic pcmcia_core intel_agp shpchp pci_hotplug agpgart snd_page_alloc evdev ext3 jbd mbcache sr_mod cdrom sg sd_mod ata_piix ata_generic ahci libata scsi_mod ehci_hcd uhci_hcd usbcore processor fuse apparmor commoncap
        [ 1089.592000] CPU: 1
        [ 1089.592000] EIP: 0060:[<f93b2a90>] Tainted: P VLI
        [ 1089.592000] EFLAGS: 00013286 (2.6.22-14-generic #1)
        [ 1089.592000] EIP is at vWriteMmRegisterUlongViaAddr+0x10/0x20 [fglrx]
        [ 1089.592000] eax: 0000003e ebx: f5d04800 ecx: f9180000 edx: 10000000
        [ 1089.592000] esi: 0000003e edi: f9180000 ebp: f3a0de30 esp: f3a0de30
        [ 1089.592000] ds: 007b es: 007b fs: 00d8 gs: 0033 ss: 0068
        [ 1089.592000] Process Xorg (pid: 7717, ti=f3a0c000 task=efc92f90 task.ti=f3a0c000)
        [ 1089.592000] Stack: f3a0de60 f93b29d8 f9180000 0000003e 10000000 00000073 c011f2f5 00000073
        [ 1089.592000] 10000000 0000003e f5d04800 f5d048f0 f3a0de80 f939f7a3 f5d04800 0000003e
        [ 1089.592000] 10000000 f5d048f0 f5d04800 bfc6afc0 f3a0dea0 f938a770 f5d04800 10000000
        [ 1089.592000] Call Trace:
        [ 1089.592000] [<f93b29d8>] vWriteMmRegisterUlong+0x68/0xf0 [fglrx]
        [ 1089.592000] [<c011f2f5>] __ioremap+0xe5/0x110
        [ 1089.592000] [<f939f7a3>] WriteAsicConfigMemsize+0xc3/0x140 [fglrx]
        [ 1089.592000] [<f938a770>] CAILExit+0x20/0x140 [fglrx]
        [ 1089.592000] [<f937e607>] firegl_pci_getinfo+0x167/0x1f0 [fglrx]
        [ 1089.592000] [<f937ec6c>] firegl_cail_free+0x3c/0x70 [fglrx]
        [ 1089.592000] [<c01fed0e>] copy_from_user+0x2e/0x70
        [ 1089.592000] [<f937df03>] firegl_init_asic+0xf3/0x1f0 [fglrx]
        [ 1089.592000] [<f937de10>] firegl_init_asic+0x0/0x1f0 [fglrx]
        [ 1089.592000] [<f93757ae>] firegl_ioctl+0x1ae/0x230 [fglrx]
        [ 1089.592000] [<f93698fc>] ip_firegl_ioctl+0x1c/0x30 [fglrx]
        [ 1089.592000] [<f93698e0>] ip_firegl_ioctl+0x0/0x30 [fglrx]
        [ 1089.592000] [<c018ca74>] do_ioctl+0x84/0xc0
        [ 1089.592000] [<c02f5d99>] do_page_fault+0x389/0x690
        [ 1089.592000] [<f93698e0>] ip_firegl_ioctl+0x0/0x30 [fglrx]
        [ 1089.592000] [<c018cb0c>] vfs_ioctl+0x5c/0x290
        [ 1089.592000] [<c018cdb2>] sys_ioctl+0x72/0x90
        [ 1089.592000] [<c01041d2>] sysenter_past_esp+0x6b/0xa9
        [ 1089.592000] =======================
        [ 1089.592000] Code: 8b 55 08 85 d2 74 06 8b 4d 0c 8b 04 8a 5d c3 8d b6 00 00 00 00 8d bf 00 00 00 00 55 89 e5 8b 4d 08 85 c9 74 09 8b 55 10 8b 45 0c <89> 14 81 5d c3 8d 74 26 00 8d bc 27 00 00 00 00 55 31 c0 89 e5
        [ 1089.592000] EIP: [<f93b2a90>] vWriteMmRegisterUlongViaAddr+0x10/0x20 [fglrx] SS:ESP 0068:f3a0de30
        [ 1089.596000] [fglrx:firegl_release] *ERROR* device busy: 1 0
        [ 1089.596000] [fglrx] release failed with code -EBUSY


        • omg...this driver is crap....
          im going to wait till someone makes a howto for opensuse 10.3 64 bit....

          im sure 64 bit is where my troubles are... never again ati....never again....


          • jesus isnt anyone getting good results ?

            The phoronix people seem to have gotten things going right, at least that's what the review leads to believe. But they seem to be the only one's praising this driver..

            Im not questioning their integrity, ... , but its a tad strange to me, thats all ill say.

            By the way why wont AMD ATI themselves release any comment on their drivers? If its really a full rewrite of the code and if you have 'known issues' then just say it .. if its beta quality software than just label it so .. This kind of hype / disapointment is really demeaning your company's reputation in the community .. were not stupid; I know for me that if it takes another 4 months to get fast and stable drivers I wont complain. Its just a pain when you say itll be something and then turns out not to be that..


            • yea, im curious of how they got their setups working so flawlessly, to say the least.

              maybe its the years of configging x servers for their living that makes them so good at it...^^

              but seriously, a writeup for howtos for different distros would be fantabulastic.


              • Originally posted by gummybearx View Post
                yea, im curious of how they got their setups working so flawlessly, to say the least.

                maybe its the years of configging x servers for their living that makes them so good at it...^^

                but seriously, a writeup for howtos for different distros would be fantabulastic.
                I think you'll find that those of us who have a working setup just don't post as much ... what is there to post about!

                FTR: Mobility x1600 worked straight away for me, AIGLX/Compiz as well but not with fantastic performance. Textured video (XV), dual displays and 3d apps (GoogleEarth, ET:QW) are all apparently fine also. I do have some years of wrangling with difficult Linux drivers behind me however.

                As for writeups for different distros: is where they lie. It might take a few days to get it all updated for 8.42, but they're pretty quick usually... in fact the Ubuntu Gutsy one is up already, but no others that I can see.


                • Can't wait to boot up Linux just to try this at home.


                  • HAHAHA ;D i love this driver, except 1 thing, same with last one.

                    Okey i got a vga display, NOT DVI, HDMI or any other digital crap.

                    so, it doesnt detect my screen correctly, just change settings in xorg.conf youreself. and you got aiglx and a perfect driver in youre hand.

                    but, whitelist in compiz how ? eeek


                    • Well heres my experence so far from the new driver. The PCIE-AGP bridge issue has been resolved. Thank god. The driver runs very very well for me. However I could not get this driver to work in Ubuntu but works like a charm in Debian.

                      I haven't been able to get compiz running yet, but 3d is very fast. And runs very well. Compiz isn't a huge deal to me but if its supposed to work, I'd like to see it work. But so far I'm very impressed.