Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ages?

    i have been waiting for this "child" since gutsy was released, but it does not solve https://bugs.launchpad.net/ubuntu/+s...22/+bug/121653

    Comment


    • Originally posted by bit7 View Post
      @rdvaughan: I have the same ATI card as you. How did you install the new driver?
      I did it like way from the ubuntu wiki, but i got only this:




      How does your xorg.conf look like?
      If you successfully installed the drivers then did you enable the ATI restricted drivers (System>Administration>Restricted Drivers Manager)?

      Here is my xorg.conf:

      Section "ServerLayout"

      # Uncomment if you have a wacom tablet
      # InputDevice "stylus" "SendCoreEvents"
      # InputDevice "cursor" "SendCoreEvents"
      # InputDevice "eraser" "SendCoreEvents"
      Identifier "Default Layout"
      screen 0 "aticonfig-Screen[0]" 0 0
      Inputdevice "Generic Keyboard"
      Inputdevice "Configured Mouse"
      EndSection

      Section "Files"
      EndSection

      Section "Module"
      Load "glx"
      EndSection

      Section "InputDevice"
      Identifier "Generic Keyboard"
      Driver "kbd"
      Option "CoreKeyboard"
      Option "XkbRules" "xorg"
      Option "XkbModel" "pc101"
      Option "XkbLayout" "us"
      EndSection

      Section "InputDevice"
      Identifier "Configured Mouse"
      Driver "mouse"
      Option "CorePointer"
      Option "Device" "/dev/input/mice"
      Option "Protocol" "ImPS/2"
      Option "ZAxisMapping" "4 5"
      Option "Emulate3Buttons" "true"
      EndSection

      Section "InputDevice"
      Identifier "stylus"
      Driver "wacom"
      Option "Device" "/dev/input/wacom"
      Option "Type" "stylus"
      Option "ForceDevice" "ISDV4"# Tablet PC ONLY
      EndSection

      Section "InputDevice"
      Identifier "eraser"
      Driver "wacom"
      Option "Device" "/dev/input/wacom"
      Option "Type" "eraser"
      Option "ForceDevice" "ISDV4"# Tablet PC ONLY
      EndSection

      Section "InputDevice"
      Identifier "cursor"
      Driver "wacom"
      Option "Device" "/dev/input/wacom"
      Option "Type" "cursor"
      Option "ForceDevice" "ISDV4"# Tablet PC ONLY
      EndSection

      Section "Monitor"
      Identifier "Generic Monitor"
      Horizsync 28.0 - 51.0
      Vertrefresh 43.0 - 60.0
      Option "DPMS"
      EndSection

      Section "Monitor"
      Identifier "aticonfig-Monitor[0]"
      Option "VendorName" "ATI Proprietary Driver"
      Option "ModelName" "Generic Autodetecting Monitor"
      Option "DPMS" "true"
      EndSection

      Section "Device"
      Identifier "Generic Video Card"
      Driver "fglrx"
      Busid "PCI:5:0:0"
      EndSection

      Section "Device"
      Identifier "aticonfig-Device[0]"
      Driver "fglrx"
      Option "VideoOverlay" "on"
      Option "OpenGLOverlay" "off"
      EndSection

      Section "Screen"
      Identifier "Default Screen"
      Device "Generic Video Card"
      Monitor "Generic Monitor"
      Defaultdepth 24
      SubSection "Display"
      Modes "1024x768"
      EndSubSection
      EndSection

      Section "Screen"
      Identifier "aticonfig-Screen[0]"
      Device "aticonfig-Device[0]"
      Monitor "aticonfig-Monitor[0]"
      Defaultdepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      EndSubSection
      EndSection

      Section "Extensions"
      Option "Composite" "1"
      EndSection

      Section "ServerFlags"
      Option "AIGLX" "on"
      EndSection


      I hope this helps.

      Comment


      • @Cerebral
        Originally posted by Cerebral View Post
        @superyounan1:

        Getting the double-free all the time - see a few posts back, my first post on the forum was to report it. I also have a dual-head config - I wonder if that's related.
        I really need the dual-head, its one the main reasons i dont simply use the open ati driver, but i'll try switching to single head and see what happens.

        I saw your post just after I posted mine, I noticed you have the AIGLX option off, you should be able to turn it on now, but that won't affect the problem we're having.

        I also can't seem to kill X anymore, hitting ctrl+alt+backspace just brings a black screen and i have to restart, you getting that too?

        Comment


        • Originally posted by superyounan1 View Post
          I really need the dual-head, its one the main reasons i dont simply use the open ati driver, but i'll try switching to single head and see what happens.

          I saw your post just after I posted mine, I noticed you have the AIGLX option off, you should be able to turn it on now, but that won't affect the problem we're having.

          I also can't seem to kill X anymore, hitting ctrl+alt+backspace just brings a black screen and i have to restart, you getting that too?
          I hear you - I need the dual-head as well. I also have the X-freezing issue, but only if AIGLX and "RENDER" extensions are enabled.

          I'm still, however, getting graphical artifacts in the bottom-right hand of my screen (and underneath my mouse) from time to time.

          Comment


          • Originally posted by Cerebral View Post
            I hear you - I need the dual-head as well. I also have the X-freezing issue, but only if AIGLX and "RENDER" extensions are enabled.

            I'm still, however, getting graphical artifacts in the bottom-right hand of my screen (and underneath my mouse) from time to time.
            ditto. I'm new to phoronix, should we start a separate thread? there is at least one other person with this problem here

            Comment


            • On Gutsy, I found a way to enable AIGLX (the GLX_ext_texture_from_pixmap ext. was not found), but it's a bit tricky and I don't know how to use compizconfig-settings-manager with it.

              I call LIBGL_ALWAYS_INDIRECT=true compiz.real --indirect-rendering --replace gconf. Then, the Window manager doesn't launches, so I invoke "gtk-window-decorator" and it finally 'works'. Unfortunately it uses gconf : it doesn't use compizconfig-settings-manager, and I don't know how to make it use it.

              good luck...

              EDIT: I found a way to make it use the compizconfig-settings-manager... replace 'gconf' with 'ccp'
              LIBGL_ALWAYS_INDIRECT=true compiz.real --indirect-rendering --replace ccp
              works for me, but it's not the best thing out there...

              EDIT2: unfortunately this method is *very* slow and not usable. XGL must be a lot faster...
              Last edited by zmaster; 10-23-2007, 09:41 PM.

              Comment


              • Originally posted by Cerebral View Post
                I hear you - I need the dual-head as well. I also have the X-freezing issue, but only if AIGLX and "RENDER" extensions are enabled.

                I'm still, however, getting graphical artifacts in the bottom-right hand of my screen (and underneath my mouse) from time to time.
                I getting the artifacts, too - once again only in dual-head mode.

                I'm currently in "big desktop" mode, but I can't get the monitors to show up in different resolutions..hatin' it.

                Comment


                • install but?

                  I have installed on a 64 bit Ubuntu Gutsy--no problem wth the help above. It is clear the fglrx module is loaded. However, fglrxinfo gives the following

                  fglrxinfo: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

                  Help?

                  Comment


                  • This seems like a package-related issue... Create a symbolic link as follows :
                    ln -s /usr/lib/libGL.so.1.2 /usr/lib/libGL.so.1

                    Comment


                    • rdvaughan;16120]If you successfully installed the drivers then did you enable the ATI restricted drivers (System>Administration>Restricted Drivers Manager)?
                      I had to turn off the ATI restricted driver. And after installed the driver again it works now!

                      My FPS with glxgears is a bit lower than yours. I got about 5900 FPS with desktop effects activated.

                      I got black flickring windows, when i play videos. Not so nice. I think i have to turn desktop effects off.

                      Thank you for your xorg.conf.

                      Comment

                      Working...
                      X