No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Janus View Post
    Nothing works for me
    What distro are you running and how far have you gotten?


    • @rdvaughan: I have the same ATI card as you. How did you install the new driver?
      I did it like way from the ubuntu wiki, but i got only this:

      Display: :0.0 screen: 0
      OpenGL vendor string: Mesa project:
      OpenGL renderer string: Mesa GLX Indirect
      OpenGL version string: 1.4 (2.1 Mesa 7.0.1)

      How does your xorg.conf look like?


      • Originally posted by NaterGator View Post
        Did you try to use aticonfig from the command line? ...
        Yes, I have tried a number of combinations including forcing TVout to "on" all to no avail. After exhausting "aticonfig" as an option I had hoped that the Catalyst Control Centre would work but that has not been the case.

        If AMD/ATI provided better documentation for the "aticonfig --add-cvmode=WIDTH,HEIGHT,FLAGS,BASEWIDTH,BASEDHEIGHT,RE FRESH." command with examples I might get some where. For instance what the heck are "FLAGS" and what are acceptable values?

        I have spent many hours searching the net, using "aticonfig" and even building my own xorg.conf all with no results. I even went through my working Windows Catalyst Control Centre *.xml profile trying to find out what settings could be used.

        The search goes on.


        • does any body solved the problem with compiz and his GLX_EXT_texture_from_pixmap thing?

          whitelist, fglrx-force, checkskip, editing a path to libGL
          still doesn't work..
          nobody had this problen?


          • Not building on x86_64 Fedora 8 / Rawhide

            FYI: Just tried to build it on x86_64 Fedora 8 / Rawhide. First of all it needs that kernel 2.6.23 patch that someone graciously posted earlier in the thread. Then it builds but it fails with not being able to find a directory with X11R6 in it. Finally, if I extract the files to say ./tmp and manually try ./ --listpkg I get an error. It only works when I do ./ - --listpkg. If more info is required lemme know and I'll have another go and post the exact logs/output.


            • works, except swicthing to console


              I'm glad to see AIGLX finally working. First I had to comment GLCore from the modules section in xorg.conf, then the cubes where working...

              But I have a problem: switching to the console totally hangs my system. And my Ubuntu (Gutsy) does switch to the text console for a second after starting GDM, resulting so in a system crash.

              Any recommendations?

              help plz


              • anyone else getting this? I'm so close!

                display: :0.0  screen: 0
                OpenGL vendor string: ATI Technologies Inc.
                OpenGL renderer string: RADEON 9800 PRO
                OpenGL version string: 2.0.6958 Release
                display: :0.0  screen: 1
                OpenGL vendor string: ATI Technologies Inc.
                OpenGL renderer string: RADEON 9800 PRO
                OpenGL version string: 2.0.6958 Release
                *** glibc detected *** fglrxinfo: double free or corruption (!prev): 0x08062000 ***
                ======= Backtrace: =========
                ======= Memory map: ========
                08048000-0804b000 r-xp 00000000 03:42 1589707    /usr/bin/fglrxinfo
                0804b000-0804c000 rw-p 00002000 03:42 1589707    /usr/bin/fglrxinfo
                0804c000-08475000 rw-p 0804c000 00:00 0          [heap]
                a5f86000-a5f87000 rw-p a5f86000 00:00 0 
                a6249000-ae249000 rw-s 00003000 00:0e 19461      /dev/dri/card0
                ae249000-ae50b000 rw-p ae249000 00:00 0 
                ae50b000-ae511000 rwxp ae50b000 00:00 0 
                ae511000-ae584000 rw-p ae511000 00:00 0 
                ae584000-aec84000 rw-s 00005000 00:0e 19461      /dev/dri/card0
                aec84000-aec94000 rw-s 00004000 00:0e 19461      /dev/dri/card0
                b6b00000-b6b21000 rw-p b6b00000 00:00 0 
                b6b21000-b6c00000 ---p b6b21000 00:00 0 
                b6c7a000-b6c84000 r-xp 00000000 03:42 491587     /lib/
                b6c84000-b6c85000 rw-p 0000a000 03:42 491587     /lib/
                b6c94000-b6cb7000 r-xp 00000000 03:42 525587     /lib/tls/i686/cmov/
                b6cb7000-b6cb9000 rw-p 00023000 03:42 525587     /lib/tls/i686/cmov/
                b6cb9000-b6cc0000 r-xp 00000000 03:42 525609     /lib/tls/i686/cmov/
                b6cc0000-b6cc2000 rw-p 00006000 03:42 525609     /lib/tls/i686/cmov/
                b6cc2000-b7a7b000 r-xp 00000000 03:42 4161553    /usr/lib/dri/
                b7a7b000-b7b00000 rw-p 00db9000 03:42 4161553    /usr/lib/dri/
                b7b00000-b7c5a000 rw-p b7b00000 00:00 0 
                b7c5a000-b7c5c000 r-xp 00000000 03:42 525585     /lib/tls/i686/cmov/
                b7c5c000-b7c5e000 rw-p 00001000 03:42 525585     /lib/tls/i686/cmov/
                b7c5e000-b7c62000 r-xp 00000000 03:42 1590579    /usr/lib/
                b7c62000-b7c63000 rw-p 00003000 03:42 1590579    /usr/lib/
                b7c63000-b7c64000 rw-p b7c63000 00:00 0 
                b7c64000-b7c66000 r-xp 00000000 03:42 1590568    /usr/lib/
                b7c66000-b7c67000 rw-p 00001000 03:42 1590568    /usr/lib/
                b7c67000-b7c7b000 r-xp 00000000 03:42 525605     /lib/tls/i686/cmov/
                b7c7b000-b7c7d000 rw-p 00013000 03:42 525605     /lib/tls/i686/cmov/
                b7c7d000-b7c7f000 rw-p b7c7d000 00:00 0 
                b7c7f000-b7dc3000 r-xp 00000000 03:42 525579     /lib/tls/i686/cmov/
                b7dc3000-b7dc4000 r--p 00143000 03:42 525579     /lib/tls/i686/cmov/
                b7dc4000-b7dc6000 rw-p 00144000 03:42 525579     /lib/tls/i686/cmov/
                b7dc6000-b7dc9000 rw-p b7dc6000 00:00 0 
                b7dc9000-b7dd6000 r-xp 00000000 03:42 1590583    /usr/lib/
                b7dd6000-b7dd7000 rw-p 0000d000 03:42 1590583    /usr/lib/
                b7dd7000-b7ec4000 r-xp 00000000 03:42 1590562    /usr/lib/
                b7ec4000-b7ec8000 rw-p 000ed000 03:42 1590562    /usr/lib/
                b7ec8000-b7f4e000 r-xp 00000000 03:42 901308     /usr/lib/xorg/
                b7f4e000-b7f50000 rw-p 00086000 03:42 901308     /usr/lib/xorg/
                b7f50000-b7f53000 rw-p b7f50000 00:00 0 
                b7f5e000-b7f60000 rw-s 00002000 00:0e 19461      /dev/dri/card0
                b7f62000-b7f63000 rw-p b7f62000 00:00 0 
                b7f63000-b7f7d000 r-xp 00000000 03:42 491540     /lib/
                b7f7d000-b7f7f000 rw-p 00019000 03:42 491540     /lib/
                bfa34000-bfa47000 rwxp bfa34000 00:00 0          [stack]
                bfa47000-bfa4a000 rw-p bfa47000 00:00 0 
                ffffe000-fffff000 r-xp 00000000 00:00 0          [vdso]
                Aborted (core dumped)


                • @superyounan1:

                  Getting the double-free all the time - see a few posts back, my first post on the forum was to report it. I also have a dual-head config - I wonder if that's related.


                  • Installed and running 8.42.3. I had to do a "ln -s" to fix the missing libGL issue.

                    • Suspend still doesn't work on Ubuntu 7.10, Ubuntu bug #121653, as the new SLUB allocator prevents fglrx from suspending.
                    • Selecting xv in xine crashes X (returns to gdm).
                    • Non-xv video (with TexturedVideo enabled) runs and is smooth, but it flickers a lot (in fullscreen too).
                    • Same for OpenGL apps.
                    • OpenGL apps and videos (with TexturedVideo) are drawn directly on screen, i.e. compiz can't zoom them or map them onto the sides of the cube while rotating, they remain on the screen in their original size/position.
                    • Getting occasional compiz freezes (with mouse pointer still moving) as in Ubuntu bug #108527 and in Compiz Fusion bug #524. After the freeze I was able to do Alt-SysRq-R and switch to a terminal to see compiz.real using 100% cpu (infinite loop somewhere?).
                    • Typing on gnome text-editor is really slow (holding a key pressed), while doing it on emacs-gtk seems as fast as before.
                    • Scrolling in Firefox is pretty slow, compared to when Compiz is not running.

                    I think introducing AIGLX support is a pretty big step for AMD, and hopefully we'll see it get better and better in terms of performance, right Michael?

                    BTW Michael, which of these problems can we expect to be fixed in next month's driver?
                    Last edited by cornelius; 23 October 2007, 11:15 PM.


                    • Originally posted by Cerebral View Post

                      Getting the double-free all the time - see a few posts back, my first post on the forum was to report it. I also have a dual-head config - I wonder if that's related.
                      I'm getting the same error - but only in dual-head mode.

                      In fact, I keep losing the symbolic link to fglrx.ko and have to boot to a console to re-create it just to use the driver --- things are amiss.