Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unfortunately I still get panics, when switching to console and back (notebook doesn't even respond to pings any more).

    Other than that I works quite well.

    Comment


    • Originally posted by aznabaal View Post
      I have performance boost in glxgears, but no compiz
      ...
      Let me know is somebody figured this out, I have
      seen this problem in this thread.
      I turn on compiz closing "fusion-icon" on system tray and reloading it. Then select compiz as window manager.

      In my opinion: AIGLX is enabled, but unusable

      Comment


      • hi, i'm using this guide it works pretty well with 8.40.4. Doing it with the 8.42.3 wont work.... this is what i get:

        Code:
        [email protected]:~$ fglrxinfo
        display: :0.0  screen: 0
        OpenGL vendor string: Mesa project: www.mesa3d.org
        OpenGL renderer string: Mesa GLX Indirect
        OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
        found this in my xorg log:

        Code:
        (II) LoadModule: "fglrx"
        (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
        (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
                compiled for 7.1.0, module version = 8.42.3
                Module class: X.Org Video Driver
        is my graphics card being detected as a firegl? I'm using a laptop x1600.... :s

        any ideas?
        Last edited by CiberWizZ; 10-23-2007, 06:49 PM.

        Comment


        • AIGLX works nicely with Kanotix and my latest script. Btw. it adds the 2.6.23 patches and the 64 bit build patch. The firgl ids are still gone, only 2 new cards are supported:

          ATI Radeon HD 2900 GT (R600 9405)
          RV610 94CC (RV610 94CC)

          I guess for compiz you should wait for updated startup scripts or hack am, beryl works fine.

          http://kanotix.com/files/install-fglrx-debian.sh

          Comment


          • Well, I just tried out the magical new driver on gentoo, and it has been a total failure for me. The installation worked fine (via modifying ebuilds), BUT:

            1) Corruption in the first line of the screen
            2) X tends to hang upon switching VTs
            3) XV is still badly broken when used in combination with anything but mplayer
            4) Using a compositing windows manager (not AIGLX stuff) results in severe screen corruption
            5) amdcccle dies with either segfault or invalid instruction... WTF!?
            6) driconf cannot be used to change DRI settings
            7) fgl_fglxgears crashes when using pbuffer

            Oh, apart from 1-7, I got a nice boost in 3D performance. I should mention that all these problems (except 5 and 6, dunno about them) already were present in 8.41., but I did expect them to get ironed out between the two releases. My machine is a Thinkpad T60 with a X1300 mobility, running gentoo stable, kernel 2.6.20 and xorg-server 1.2.

            I didn't ever join in ATI bashing before since I never got into real trouble with their propietary driver, but I now guess I simply was lucky. I am using this machine for work and am not seriously interested in desktop eye-candy like compiz, I don't take ultimate insult on binary blobs (if they are at well done, although I definitely DO prefere FOSS solutions), but I do care about a stable, reliable driver that works fine for everyday use, and already issue 1 is a showstopper there.

            Dear ATI, please stop hurling out bug-ridden crapware like this, if it isn't possible for your developer(s?) to create a proper driver for your hardware, then at least hurry up with pushing out the specs so that novell can create an opensource driver fit for everyday use.

            Comment


            • mobility radeon x2300, debian sid ker 22, xorg - 7.3, compiz fusion 5.5

              added fglrx to whitelist in compiz
              LIBGL_ALWAYS_INDIRECT=true
              skip check is also set

              and still i have a message
              Fatal: Failed test: texture_from_pixmap support

              what am I doing wrong?!

              Comment


              • Originally posted by DirtyHairy View Post
                Well, I just tried out the magical new driver on gentoo, and it has been a total failure for me. The installation worked fine (via modifying ebuilds), BUT:
                Did you compile X with -fmcpu=pentiumd -O365 -frerolled-loops?

                Comment


                • That's great! AMD is doing well lately!!!
                  nice job!!!

                  Comment


                  • An year of waiting for what? AIGLX with this driver is 50% slower than XGL.

                    My system:
                    Acer TM8204, Centrino DUO T2500
                    2GB RAM
                    ATI Mobility Radeon X1600

                    I'm getting back to 8.37.6 + XGL and wait for a better release...

                    Comment


                    • anybody tried TV-out?

                      Comment

                      Working...
                      X