Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by spotman View Post
    anyone having any issues running amdcccle?

    I had no problems with 8.40, but for whatever reason it just hangs upon execution with 8.42, never even paints a window, no error messages in terminal either.
    yeah, amdcccle never worked on my slackware 12.0

    Comment


    • Hi everybody !

      I'm french and new here, please be indulgent because i dont speak english very well :S !

      I've a RADEON XPRESS 200G (PCIE integrated) and before this release of fglrx 8.42 i used XGL with Compiz Fusion under linux Fedora 7.
      XGL is very very slow and i waited this new release for erase compeletely XGL from my drive and play with compiz fusion or games (ut2004) !
      When i saw fglrx 8.42, i immediatly downloaded it and installing it with --buildpkg command.
      When restarting, i checked if fglrx has started and it has :

      [[email protected] Scias]# fglrxinfo
      display: :0.0 screen: 0
      OpenGL vendor string: ATI Technologies Inc.
      OpenGL renderer string: ATI Radeon Xpress Series
      OpenGL version string: 2.0.6958 Release

      [[email protected] Scias]# glxinfo
      name of display: :0.0
      display: :0 screen: 0
      direct rendering: Yes
      server glx vendor string: SGI
      server glx version string: 1.2
      server glx extensions:
      ....
      OpenGL vendor string: ATI Technologies Inc.
      OpenGL renderer string: ATI Radeon Xpress Series
      OpenGL version string: 2.0.6958 Release
      OpenGL extensions:
      .....
      I tried a "glxgears" and it is very smoothly than the fglrx 8.40 :

      [[email protected] Scias]# glxgears
      3885 frames in 5.0 seconds = 976.899 FPS
      with fglrx 8.40, i was around 600 FPS.

      Then, i tried to launch "fusion-icon" but it's not working !!

      [[email protected] Scias]# fusion-icon
      * Using the GTK Interface
      GTK Accessibility Module initialized
      * Searching for installed applications...
      /usr/bin/ccsm
      /usr/bin/compiz
      /usr/bin/gtk-window-decorator
      /usr/bin/emerald
      /usr/bin/metacity
      * gnome session
      * Decorator "" is invalid.
      ... choosing gtk-window-decorator --replace as default decorator
      * No GLX_EXT_texture_from_pixmap present with direct rendering context
      ... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
      * Executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
      /usr/share/fusion-icon/interface_gtk.py:238: GtkWarning: Icon cache '/usr/share/icons/hicolor/icon-theme.cache' is invalid

      gtk.main()
      /usr/share/fusion-icon/interface_gtk.py:238: GtkWarning: Icon cache '/usr/share/pixmaps/hicolor/icon-theme.cache' is invalid

      gtk.main()
      compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
      compiz (core) - Error: Failed to manage screen: 0
      compiz (core) - Fatal: No manageable screens found on display :0.0
      And also i tried "fgl_glxgears" and it not work too !

      [[email protected] Scias]# fgl_glxgears
      Using GLX_SGIX_pbuffer
      X Error of failed request: GLXUnsupportedPrivateRequest
      Major opcode of failed request: 143 (GLX)
      Minor opcode of failed request: 16 (X_GLXVendorPrivate)
      Serial number of failed request: 41
      Current serial number in output stream: 42
      AMDCCCLE is working and it says that i'm running on fglrx 8.42.3 (no problem)

      my Xorg.conf (I tried enabling composite and AIGLX in xorg.conf but no results)


      Code:
      Section "ServerLayout"
      	Identifier     "Default Layout"
      	Screen      0  "aticonfig-Screen[0]" 0 0
      	InputDevice    "Keyboard0" "CoreKeyboard"
      EndSection
      
      Section "Files"
      	ModulePath   "/usr/lib/xorg/modules"
      EndSection
      
      Section "InputDevice"
      	Identifier  "Keyboard0"
      	Driver      "kbd"
      	Option	    "XkbModel" "pc105"
      	Option	    "XkbLayout" "fr"
      	Option	    "XkbVariant" "latin9"
      EndSection
      
      Section "Monitor"
      	Identifier   "aticonfig-Monitor[0]"
      	Option	    "VendorName" "ATI Proprietary Driver"
      	Option	    "ModelName" "Generic Autodetecting Monitor"
      	Option	    "DPMS" "true"
      EndSection
      
      Section "Device"
      	Identifier  "aticonfig-Device[0]"
      	Driver      "fglrx"
      EndSection
      
      Section "Screen"
      	Identifier "Screen0"
      	Device     "Videocard0"
      	DefaultDepth     24
      	SubSection "Display"
      		Viewport   0 0
      		Depth     24
      	EndSubSection
      EndSection
      
      Section "Screen"
      	Identifier "aticonfig-Screen[0]"
      	Device     "aticonfig-Device[0]"
      	Monitor    "aticonfig-Monitor[0]"
      	DefaultDepth     24
      	SubSection "Display"
      		Viewport   0 0
      		Depth     24
      	EndSubSection
      EndSection
      I'm on Fedora 7 on kernel 2.6.22.9-91.fc7
      ATI XPRESS 200G

      Can somebody help me please ?
      Last edited by Scias; 10-23-2007, 06:19 PM.

      Comment


      • IT WORRRRKKKKSSSS!

        Ubuntu 7.10. X1950XTX. Haven't found anything that doesn't work. I did have to add fglrx to the driver whitelist in /usr/bin/compiz before Compiz would start.

        Not a benchmakrk glxgears reports 11099FPS, which is about 1% better than 8.41.7, which in turn was about 3% slower than 8.38.X

        Comment


        • Fun with 8.42/Ubuntu 7.10/X1300

          Okay, installed manually (with apt-get install -f to fix my previous driver install) and got incredible performance...but fglrxinfo killed the X server.

          Reinstalled using GUI installer - which killed the drivers completely.

          Uninstalled everything, rebooted and reinstalled, ran aticonfig commands and enabled composite in xorg.conf.

          Modest increase in fps and no desktop effects.

          glxgears -info:
          Code:
          10643 frames in 5.0 seconds = 2128.420 FPS
          10659 frames in 5.0 seconds = 2131.615 FPS
          10667 frames in 5.0 seconds = 2133.226 FPS
          fglrxinfo:
          Code:
          [email protected]:/etc/X11$ fglrxinfo
          display: :0.0  screen: 0
          OpenGL vendor string: ATI Technologies Inc.
          OpenGL renderer string: ATI Mobility Radeon X1300
          OpenGL version string: 2.0.6958 Release
          xorg.conf(edited for clarity):
          Code:
          Section "Module"
          EndSection
          
          Section "Device"
                  Identifier  "aticonfig-Device[0]"
                  Driver      "fglrx"
                  Option      "VideoOverlay" "on"
                  Option      "OpenGLOverlay" "off"
          EndSection
          
          Section "Screen"
                  Identifier "aticonfig-Screen[0]"
                  Device     "aticonfig-Device[0]"
                  Monitor    "aticonfig-Monitor[0]"
                  DefaultDepth     24
                  SubSection "Display"
                          Viewport   0 0
                          Depth     24
                  EndSubSection
          EndSection
          
          Section "Extensions"
                  Option      "Composite" "1"
          EndSection
          Did I forget anything?

          Comment


          • Originally posted by rbmorse View Post
            IT WORRRRKKKKSSSS!

            Ubuntu 7.10. X1950XTX. Haven't found anything that doesn't work. I did have to add fglrx to the driver whitelist in /usr/bin/compiz before Compiz would start.

            Not a benchmakrk glxgears reports 11099FPS, which is about 1% better than 8.41.7, which in turn was about 3% slower than 8.38.X
            Oh wait...I have the Xv flickers with video playback. Setting mplayer to X11 works good, though.

            Comment


            • compiz don work with me but on my debian / testing compiz 0.5.2 i dont have any whitelist in /usr/bin/compiz.
              should i add it

              Comment


              • For Ubuntu/Debian users:


                64bit package generation is broken. My bad. I didn't get the updated scripts to AMD in time for inclusion in 8.42. I think the workaround was posted already here.

                32bit packages should be OK though.

                Comment


                • Originally posted by chikazuku View Post
                  I run 10.3 64-bit, I don't get your error but it doesn't run. (see my earlier posts)
                  Well I finally managed to get direct rendering working. But compiz won't start with the same GLXFBConfig error many others here are reporting.

                  Adam

                  Comment


                  • I confirm, 8.42.3 is working fine with x1600 at Ubuntu Gutsy x86_64 but:
                    video flickers a lot (I can live with X11 settings)
                    all GL apps flicker and that's killing me - I could live without GoogleEarth, games etc. but I need this to work with VariCAD 3D and that makes me to return to 8.40.

                    Anytime someone will find fix for GL apps I'll return to 8.42 immediately.

                    Comment


                    • Despite my bugs & problems with compiz fusion and fgl_glxgears, ut2004 is very playable with default settings !

                      I tried fglrx in a older kernel but same errors....

                      I'm desperated !

                      Comment

                      Working...
                      X