Announcement

Collapse
No announcement yet.

AMD Has Massive Radeon Patch Set - Power Management!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • This is the error message:
    [drm:rv730_stop_dpm] *ERROR* Could not force DPM to low

    The flickering happens on boot and after wake up from sleep. If I play something with UVD the flickering stops.

    Comment


    • hi, with radeon 5450

      [email protected]:~$ dmesg | grep dpm
      [ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.10.0-rc5+ root=UUID=a5e19752-b6d5-48ca-a793-f66bfba01dc2 ro quiet splash radeon.audio=1 radeon.dpm=1 vt.handoff=7
      [ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.10.0-rc5+ root=UUID=a5e19752-b6d5-48ca-a793-f66bfba01dc2 ro quiet splash radeon.audio=1 radeon.dpm=1 vt.handoff=7
      [ 2.294877] [drm] radeon: dpm initialized
      [ 873.276844] [drm:cypress_dpm_set_power_state] *ERROR* rv770_restrict_performance_levels_before_switch failed

      Comment


      • Thnaks to AMD & all developers

        Thnaks to AMD & all the developers who worked to bring first UVD and now PM to the open source radeon drivers for Linux. It is very much appreciated.

        Comment


        • Originally posted by commiethebeastie View Post
          Hi, all. I installed linux-drm-next-3.11, firmwares, libdrm, xorg-radeon and mesa from git. And with radeon.dpm=1 the performance is much lower than with power_profile=high.

          05:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Barts PRO [Radeon HD 6850] [1002:6739]
          I have Radeon Mobility 6470 and same problem here. When dpm is enabled performance is even lower than high profile without dpm. With enabled dpm my notebook is not useable - everything is slooow.

          lspci:
          01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6400M/7400M Series]

          @agd5f: Can you look at this problem?

          Comment


          • Some more info *without* dpm:

            "high" profile is slower then "default"

            debug info for default profile:
            Code:
            glxgears --> 5000 FPS (with Option SwapbuffersWait off)
            $ sudo cat /sys/kernel/debug/dri/0/radeon_pm_info
            default engine clock: 750000 kHz
            current engine clock: 749950 kHz
            default memory clock: 900000 kHz
            current memory clock: 899430 kHz
            voltage: 1100 mV
            PCIE lanes: 16
            debug info for high profile:
            Code:
            glxgears --> 1850 FPS (with Option SwapbuffersWait off)
            $ sudo cat /sys/kernel/debug/dri/0/radeon_pm_info
            default engine clock: 750000 kHz
            current engine clock: 299980 kHz
            default memory clock: 900000 kHz
            current memory clock: 299950 kHz
            voltage: 900 mV
            PCIE lanes: 16
            debug info for low profile:
            Code:
            glxgears --> 580 FPS (with Option SwapbuffersWait off)
            $ sudo cat /sys/kernel/debug/dri/0/radeon_pm_info
            default engine clock: 750000 kHz
            current engine clock: 99990 kHz
            default memory clock: 900000 kHz
            current memory clock: 149970 kHz
            voltage: 900 mV
            PCIE lanes: 16

            Comment


            • hi guyz anyone with an Cape Verde XT card[7770] can use DPM? i upgrade everything but KMS at he nanosecond it tries to start freeze my entire PC to the point sysrq or ssh don't work. i just wanna discard if my card have something weird or is a general issues with the Cape Verde XT

              Comment


              • Here is some more info with enabled dpm

                dpm performance mode:
                Code:
                glxgears --> 616 FPS (with Option SwapbuffersWait off)
                $ cat /sys/class/drm/card0/device/power_method 
                dpm
                $ cat /sys/class/drm/card0/device/power_dpm_state 
                performance
                dpm battery mode:
                Code:
                glxgears --> 590 FPS (with Option SwapbuffersWait off)
                $ cat /sys/class/drm/card0/device/power_method 
                dpm
                $ cat /sys/class/drm/card0/device/power_dpm_state 
                battery
                So when dpm is enabled performance is definitly worse.

                @agd5f: Do you know what to do? How to increase performance with enabled dpm? I'd like to see same performace with dpm as "default" profile has.

                If you need additional info or tests, let me know what is needed.

                Comment


                • Originally posted by pali View Post
                  Here is some more info with enabled dpm

                  dpm performance mode:
                  Code:
                  glxgears --> 616 FPS (with Option SwapbuffersWait off)
                  $ cat /sys/class/drm/card0/device/power_method 
                  dpm
                  $ cat /sys/class/drm/card0/device/power_dpm_state 
                  performance
                  dpm battery mode:
                  Code:
                  glxgears --> 590 FPS (with Option SwapbuffersWait off)
                  $ cat /sys/class/drm/card0/device/power_method 
                  dpm
                  $ cat /sys/class/drm/card0/device/power_dpm_state 
                  battery
                  So when dpm is enabled performance is definitly worse.

                  @agd5f: Do you know what to do? How to increase performance with enabled dpm? I'd like to see same performace with dpm as "default" profile has.

                  If you need additional info or tests, let me know what is needed.
                  first if you even expect a reply show Xonotic or some other game because glxgears is not a benchmarks, it just says how fast you can flip and other really simple operations, in your case if your CPU downclock cuz it enter in battery profile too it will affect heavilly glxgears result and it does not put enough load on the GPU to force them UP

                  Comment


                  • Originally posted by jrch2k8 View Post
                    first if you even expect a reply show Xonotic or some other game because glxgears is not a benchmarks, it just says how fast you can flip and other really simple operations, in your case if your CPU downclock cuz it enter in battery profile too it will affect heavilly glxgears result and it does not put enough load on the GPU to force them UP
                    Ok, I can test something other, but I do not know that is needed for devs. Maybe devs already know this problem and do not need testing...

                    I see that desktop with enabled dpm is slower than with disabled. Also all KDE4 kwin effects are very very slow. So it is really problem (and not only bad output from glxgears)

                    Comment


                    • Originally posted by pali View Post
                      Ok, I can test something other, but I do not know that is needed for devs. Maybe devs already know this problem and do not need testing...

                      I see that desktop with enabled dpm is slower than with disabled. Also all KDE4 kwin effects are very very slow. So it is really problem (and not only bad output from glxgears)
                      well i read the performance adjustments come a bit later, for now is more like compatibility and features, and is still missing debug infrastructure pminfo which make it hard to check the real clocks.

                      so i guess the load in the GPU is not enough to push it outside the ULP mode and probably many cores are gating off too[depending your GPU] but without pminfo i don't know how to detect it properly

                      Comment

                      Working...
                      X