Announcement

Collapse
No announcement yet.

AMD Has Massive Radeon Patch Set - Power Management!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by GreatEmerald View Post
    Though speaking of UVD, how is that RV790 UVD going?
    ^? Anyone?

    Comment


    • Originally posted by GreatEmerald View Post
      ^? Anyone?
      If the UVD Firmware is available, then, i think you can try it again. If i remember correctly last time the firmware was removes because of the problems.

      Comment


      • While DPM seems to work fine on my HD6870 I'm getting some strange behaviour while using a multi-monitor/dual-head setup. I'm getting a lot of tearing, like you would when dpms was enabled and it switched power mode, and artifacts while moving windows around (using KWin with OpenGL 2 compositing enabled) and after a while the system completely breaks with one monitor being covered in a black overlay (except for a few horizontal lines at the top of the screen) while the other one has strange horizontal lines. After this happens I have to do a hard reboot.
        If I unplug the other monitor it works pretty much perfectly with no weird behaviour that I have seen. It also works just fine if I don't enable DPM and enable profiles instead, so it definitely has something to do with that.

        I would like to thank everyone involved with this patch though, proper power management is the only thing I have missed from fglrx.

        Comment


        • Originally posted by droste View Post
          Same for me (wip-4). "power_method" says "dpm", "power_dpm_state" says "performance" and never changes and I have no way to actually tell if it's changing clocks because of the missing "radeon_pm_info" in debugfs. I tested with and without compositing.
          Curious, since the code to have that file is definitely still there: http://cgit.freedesktop.org/~agd5f/l...ext-3.11-wip-4

          Comment


          • Originally posted by GreatEmerald View Post
            That's really cool. As soon as it hits Portage I'll try and get it running. Given that the device has overheating issues, this should be absolutely marvellous! Especially combined with UVD! Though speaking of UVD, how is that RV790 UVD going?
            There is already a thread for UVD, and Deathsimple really must feel like a broken record answering the same questions over and over again

            Comment


            • Originally posted by PuckPoltergeist View Post
              Originally posted by Tommy666 View Post
              Yes and here is what files you need for your card.
              http://wiki.gentoo.org/wiki/Radeon#Firmware
              This is not up2date. As far as I see, for PM a new firmware file with *_smc.bin is needed.
              I updated whe wiki article now. Some information I had to guess, so you may want to double-check that I did not make a mistake.

              Comment


              • thanks to everyone involved with the patch for power management!

                Comment


                • Originally posted by curaga View Post
                  Curious, since the code to have that file is definitely still there: http://cgit.freedesktop.org/~agd5f/l...ext-3.11-wip-4
                  The debug file is never created when using dpm. I added the code to create it in the dpm init function, but the values never changed. So if I were to guess the new code requires some dpm specific code to get the engine clock, memory clock values etc which hasn't been implemented yet. Either that or dpm doesn't actually work here yet (the fan speed goes up and down occasionally though, so something is definitely working).

                  Comment


                  • Originally posted by chithanh View Post
                    I updated whe wiki article now. Some information I had to guess, so you may want to double-check that I did not make a mistake.
                    According to your Wiki their is no *.smc firmware for r500 and r600 cards. Maybe that would be an explanation why this doesn't work on my HD3200? Damn, got to test this on my HD6870 now.

                    Comment


                    • There is no r500 or r600 smc firmware at http://people.freedesktop.org/~agd5f/radeon_ucode/ and I also see no references to such firmware in the code. Also there is no smc firmware for APUs apparently.

                      Comment

                      Working...
                      X