Announcement

Collapse
No announcement yet.

Legacy ATI fglrx Drivers For R200 Products on Fedora Core 6 Zod

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    The unknown symbols is due to the Linux 2.6.20 kernel and some compatibility problems.

    With the relaunch of the Phoronix site some of the directories got messed up, so I'll work on getting it reuploaded to that location or tell you the new location.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #22
      The unknown symbols is due to the Linux 2.6.20 kernel and some compatibility problems.
      I see. I am indeed running 2.6.20. Is there any way around this? Any nonessential parts of the driver I can comment out/disable for now? or is downgrading the kernel the only option?

      I should add that the X drivers work well, I am able to get output from the DVI to the HDMI of my HDTV where it wouldn't work with the packaged radeon X driver. I'm merely trying to get the kernel module to load to get XV working so as to hopefully speed up video playback for HD video files.

      With the relaunch of the Phoronix site some of the directories got messed up, so I'll work on getting it reuploaded to that location or tell you the new location.
      Ah! Much thanks!
      Last edited by acediac; 04-21-2007, 09:45 AM.

      Comment


      • #23
        Originally posted by acediac View Post
        * * *

        The other thing is if anyone has any ideas about the unknown symbol problem I'm getting, I would be grateful to hear about it. (Another similar thread was posted, but the problem was solved by re-running Michael's "updated" script, which was what I was trying to do!)

        Many thanks.
        Hi,

        As for me - I gave up. I was unable to get 9200SE working. I was crashing my mind for 2 weeks after work.

        * * *
        sudo modprobe fglrx

        fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
        fglrx: Unknown symbol firegl_cail_powerdown
        fglrx: Unknown symbol firegl_cail_powerup
        fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
        fglrx: Unknown symbol firegl_cail_powerdown
        fglrx: Unknown symbol firegl_cail_powerup
        fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
        fglrx: Unknown symbol firegl_cail_powerdown
        fglrx: Unknown symbol firegl_cail_powerup

        Xorg.lof ->

        (II) Reloading /usr/lib/xorg/modules/linux/libdrm.so
        drmOpenDevice: node name is /dev/dri/card0
        drmOpenDevice: open result is -1, (No such device or address)
        drmOpenDevice: open result is -1, (No such device or address)
        drmOpenDevice: Open failed
        [drm] failed to load kernel module "fglrx"
        (WW) fglrx(0): Failed to open DRM connection

        And I just bought 7300GT and didn't get any problems of that kind. After ATi Nvidia really amazed me.

        Comment


        • #24
          And I just bought 7300GT and didn't get any problems of that kind. After ATi Nvidia really amazed me.
          Yes I might have to do the same and buy a cheap nvidia 6200 or something. I just found out that XvMC doesn't work with ATi drivers, and I sorely need that with the old box that I'm setting up for someone due to the slower processor. I myself have a new box with an nVidia card that didn't have any problems.

          Comment


          • #25
            Originally posted by kirsche View Post
            Hi,

            As for me - I gave up. I was unable to get 9200SE working. I was crashing my mind for 2 weeks after work.

            * * *
            sudo modprobe fglrx

            fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
            fglrx: Unknown symbol firegl_cail_powerdown
            fglrx: Unknown symbol firegl_cail_powerup
            fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
            fglrx: Unknown symbol firegl_cail_powerdown
            fglrx: Unknown symbol firegl_cail_powerup
            fglrx: Unknown symbol firegl_cmmqs_get_pageaddr_from_vm
            fglrx: Unknown symbol firegl_cail_powerdown
            fglrx: Unknown symbol firegl_cail_powerup

            Xorg.lof ->

            (II) Reloading /usr/lib/xorg/modules/linux/libdrm.so
            drmOpenDevice: node name is /dev/dri/card0
            drmOpenDevice: open result is -1, (No such device or address)
            drmOpenDevice: open result is -1, (No such device or address)
            drmOpenDevice: Open failed
            [drm] failed to load kernel module "fglrx"
            (WW) fglrx(0): Failed to open DRM connection

            And I just bought 7300GT and didn't get any problems of that kind. After ATi Nvidia really amazed me.
            I found a work around for the Unknown symbols displayed above.

            For kernel 2.6.20-1.2933 You need to change
            firegl_cail_powerdown and firegl_cail_powerup
            to firegl_powerdown and firegl_powerup in all ocurrences in firegl_public.c and firegl_public.h

            As for the firegl_cmmqs_get_pageaddr_from_vm this is more off a pain,
            you need to remove all reference to it. There is a case section to do with paging, the initial call to this has been added in there as a new page function. if you remove this and the functions that it calls you can compile the driver and it appears to be stabe. (On an R250 anyway) this version of the driver finally allows hibernate and suspend to work on my card. Unfortunately ive lost my code changes and need to wait for Michael's files to be re-uploaded so i can check on the latest kernel 2.6.20-1.2944.

            Comment


            • #26
              Amazing!

              Originally posted by ijbrooks View Post
              I found a work around for the Unknown symbols displayed above.

              For kernel 2.6.20-1.2933 You need to change
              firegl_cail_powerdown and firegl_cail_powerup
              to firegl_powerdown and firegl_powerup in all ocurrences in firegl_public.c and firegl_public.h

              As for the firegl_cmmqs_get_pageaddr_from_vm this is more off a pain,
              you need to remove all reference to it. There is a case section to do with paging, the initial call to this has been added in there as a new page function. if you remove this and the functions that it calls you can compile the driver and it appears to be stabe. (On an R250 anyway) this version of the driver finally allows hibernate and suspend to work on my card. Unfortunately ive lost my code changes and need to wait for Michael's files to be re-uploaded so i can check on the latest kernel 2.6.20-1.2944.
              OMG, nice trick! But I think this should be done by ATi.
              Also, I can only suppose that it would be great if someone will make a distro with these bugs fixed for FC6. Too much human time wasted already on fighting with stupid ATi "installer".

              Comment


              • #27
                Cannot Download firegl_public Code

                Hi Michael,

                I have successfully run the fc6 legacy script in the past, but when I tried to run the script this afternoon, it failed to locate the firegl_public code on the phoronix website.

                Have the download files been moved? If so, where can I download the tar file?

                Thanks.

                Jeff

                Comment


                • #28
                  Originally posted by moorejeff View Post
                  Hi Michael,

                  I have successfully run the fc6 legacy script in the past, but when I tried to run the script this afternoon, it failed to locate the firegl_public code on the phoronix website.

                  Have the download files been moved? If so, where can I download the tar file?

                  Thanks.

                  Jeff
                  When the new site launched the file locations changed, but the firegl_public code had failed to do so. I am still trying to find a backup I had of the firegl_public code otherwise I'll need to make the patch over again.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #29
                    Could someone please e-mail me the generator script?
                    404 file not found

                    Thanks.

                    Jeff

                    jrpinjapan_aaat_yahoo_daht_cahm

                    Comment


                    • #30
                      Originally posted by zx5000 View Post
                      Could someone please e-mail me the generator script?
                      404 file not found

                      Thanks.

                      Jeff

                      jrpinjapan_aaat_yahoo_daht_cahm
                      http://kirsche.jino-net.ru/fglrx-fc6...y-generator.sh
                      http://kirsche.jino-net.ru/fedora-fc...-build_mod.tar
                      Last edited by kirsche; 05-18-2007, 06:53 PM. Reason: Oops.script was patched :(((

                      Comment

                      Working...
                      X