Announcement

Collapse
No announcement yet.

Radeon UVD Support Merged Into Mesa

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vim_User
    replied
    Originally posted by Deathsimple View Post
    Well I can confirm that we are still working on it, but can't say anything when or even if we are ever able to release it.

    Cheers,
    Christian.
    Is it in legal review or are you working on the code? Hope that I can see this getting released.

    Leave a comment:


  • Deathsimple
    replied
    Originally posted by AnonymousCoward View Post
    I use RS780 and RS880. Any news regarding these?

    Thanks and have a nice day
    Well I can confirm that we are still working on it, but can't say anything when or even if we are ever able to release it.

    Cheers,
    Christian.

    Leave a comment:


  • AnonymousCoward
    replied
    Originally posted by upalmin View Post
    Any progress with UVD on RV770/RV790?
    I use RS780 and RS880. Any news regarding these?

    Thanks and have a nice day

    Leave a comment:


  • Kano
    replied
    Basically you could even try UVD in live mode with Kanotix Dragonfire Linuxtag Special iso.

    Leave a comment:


  • duby229
    replied
    Yeah that is true for upstream kernels. Some distro's did back port it to 3.9 though. gentoo-sources for example has it starting at 3.9.2

    Leave a comment:


  • agd5f
    replied
    Originally posted by droste View Post
    a) The kernel is too old and does not contain UVD support (it was introduced in 3.9 IIRC)
    For UVD support you need kernel 3.10.

    Leave a comment:


  • droste
    replied
    You're currently not using UVD. It's probably a kernel problem:

    a) The kernel is too old and does not contain UVD support (it was introduced in 3.9 IIRC)
    b) The firmware for UVD is missing ( http://people.freedesktop.org/~agd5f/radeon_ucode/ ). You need an updated SUMO_rlc.bin and SUMO_uvd.bin
    c) The radeon kernel driver is built as an module is loaded via initrd/initramfs --> the initrd is missing the firmware mentioned in b)

    Leave a comment:


  • renkin
    replied
    no decode abilities

    Code:
    AMD A8-3530MX APU with Radeon(tm) HD Graphics
     product: BeaverCreek [Mobility Radeon HD 6620G]
    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD SUMO
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.0-devel (git-36ffd08)
    OpenGL core profile shading language version string: 1.40
    OpenGL core profile context flags: (none)
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 9.2.0-devel (git-36ffd08)
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    Code:
    /. vdpauinfo 
    display: :0   screen: 0
    API version: 1
    Information string: G3DVL VDPAU Driver Shared Library version 1.0
    
    Video surface:
    
    name   width height types
    -------------------------------------------
    420    16384 16384  NV12 YV12 
    422    16384 16384  NV12 YV12 UYVY YUYV 
    444    16384 16384  NV12 YV12 Y8U8V8A8 V8U8Y8A8 
    
    Decoder capabilities:
    
    name               level macbs width height
    -------------------------------------------
    MPEG1                16 1048576 16384 16384
    MPEG2_SIMPLE         16 1048576 16384 16384
    MPEG2_MAIN           16 1048576 16384 16384
    Can anyone tell me why I'm not getting all the UVD goodies? I can only decode the older formats according to vdpauinfo

    Leave a comment:


  • pheldens
    replied
    Thanks it works for me on HD4670, full HD h264 video at 1-2% cpu ;p

    tip: make sure you dont use mplayer -vf in your config or it will error.
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    [h264_vdpau @ 0x7fef86ef8040]decode_slice_header error
    [h264_vdpau @ 0x7fef86ef8040]no frame!
    Error while decoding frame!
    mplayer:
    mplayer -noconfig all -vo vdpau -vc ffh264vdpau,ffodivxvdpau,ffmpeg12vdpau,ffwmv3vdpau ,ffvc1vdpau %f


    kernel:
    CONFIG_EXTRA_FIRMWARE RV710_uvd.bin R700_rlc.bin

    mesa:
    ./configure --with-dri-drivers= --disable-gallium-radeon --enable-gallium-r600 --enable-vdpau
    Last edited by pheldens; 06-12-2013, 02:18 PM.

    Leave a comment:


  • upalmin
    replied
    UVD on RV770 [Radeon HD 4850]

    Originally posted by Deathsimple View Post
    We removed the RV770 firmware image from the download side and the related RV770 code from the patches, because they currently doesn't work.

    The RS780, RS880 and RV770 chipset generations have some differences in their UVD block which needs to be handled first before we can release any code for them. R6xx have similar (but still different) issues.

    I think I'm on a good way of solving that, but can't promise anything.

    Cheers,
    Christian.
    Any progress with UVD on RV770/RV790?

    I am sad owner of Radeon HD 4850.

    Thanks
    Uro?

    Leave a comment:

Working...
X