No announcement yet.

AMD's Catalyst Legacy Linux Driver Updated To 13.1

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by Hibbelharry View Post
    Rather well for anything i tested. What's the point of sticking to the old fglrx cruft ?
    One point would be to have UVD support on RS780/880.


    • #22
      By using xvba ? Now, where even xbmc removed code for the flawed xvba from mainline code, which software does really support xvba in a meaningful and useful way ?


      • #23
        Originally posted by Hibbelharry View Post
        By using xvba ? Now, where even xbmc removed code for the flawed xvba from mainline code, which software does really support xvba in a meaningful and useful way ?
        AFAIK, MPlayer does.


        • #24
          AFAIK mplayer supports va-api, and by using vaapi-xvba wrapper it is possible to use some acceleration. That wrapper is functionality limited and flawed, also out of maintenance for some years, so i don't think it is of much worth.


          • #25
            Originally posted by petlab View Post
            I tried playing TF2 with the 12.6 driver. However, I got tired of applying workarounds and patches, so it never played for me. Then I went back to the opensource drivers, and I can play it pretty well with my HD 4290. It is only at 640x480 mind you, and with lowest settings. But it plays fine!
            Mobility radeon 3650 256MB of shared memory, Catalyst 13.1, TF2 low to medium settings, ~30 FPS at 1680x1050.
            No problem with TF2, Portal 1, Half-Life 2 (can play on med-high!), Amnesia TDD, even Amnesia AMFP is playable.

            I highly doubt I could achieve it with the os radeon driver but I guess there will still be people claiming it's 'in excellent state' just because it won't turn my laptop into a ball of fire.


            • #26
              A while back, I bought a small Acer netbook - specifically to play HD videos over the HDMI port. And it did, courtesy of MPlayer-vaapi. I'd only had the thing for a couple of months, when AMD kindly announced they were stopping supporting it with immediate effect! The legacy driver (13.1) is a pile of steaming excrement that will only work with antique kernels and xorgs. Even then, it regularly causes my laptop to freeze solid when xorg tries to start. However, I have put up with it until today, when the most recent updates to my system (and yes, I did opt out of any xorg or kernel updates) broke it yet again!

              The open-source drivers don't support HD video playback on this hardware, so I'm left with a useless lump of expensive plastic, thanks to AMDs support policy!

              I should add that I've been an enthusiastic AMD customer since the days of the K6-2 processor, but I will NEVER AGAIN touch anything with AMD or Ati graphics inside. I cannot afford to have expensive equipment reduced to junk well inside its normal service life by such an unreliable vendor.



              • #27
                Ubuntu 12.04 kernel 3.11 & Legacy Driver 13.1 for HD4570

                I have an old notebook with VGA HD 4570, Catalyst 13.1 is the latest driver support for this card.
                This version of Catalyst required kernel 3.5 (or below) but at this time my notebook is running on Ubuntu 12.04 and using kernel 3.11
                When I tried to install CCC 13.1, fglrx was crashed but catalyst still installed completely with bugs (windows flickering when move...)
                Please help me fix this issue


                • #28
                  Sounds like you're running 12.04.4 with new kernel *and* new (basically 13.10's graphics stack), not 12.04 -- is that right ?

                  If so, you're probably better off focusing on the open source drivers.
                  Test signature