No announcement yet.

AMD Catalyst 13.1 For Linux Officially Does X.Org 1.13

  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Catalyst 13.1 For Linux Officially Does X.Org 1.13

    Phoronix: AMD Catalyst 13.1 For Linux Officially Does X.Org 1.13

    Catalyst 13.1 for Linux was released on Thursday as the first AMD Linux binary blob of 2013. This driver is notable since it officially supports X.Org Server 1.13...

    Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux server benchmarks, Linux benchmarking, Desktop Linux, Linux performance, Open Source graphics, Linux How To, Ubuntu benchmarks, Ubuntu hardware, Phoronix Test Suite

  • #2


    • #3
      This must be the end of the world or somethin' AMD published the release note! Unfortunately the number of bugs that are fixed is too small. With the previous version of Catalyst (9.00), X crashes unexpectedly on KDE (both 4.8.x and 4.9.x) so I downgraded Catalyst to 8.98. I hope they have fixed this annoying bug so far.


      • #4
        Still no news about legacy drivers. -.-


        • #5
          Originally posted by asim75 View Post
          Still no news about legacy drivers. -.-
          Was there supposed to be a new release for those too?

          Anyway, release notes! WOOHOOO!! Off to test this version.


          • #6
            [367245]: X crash for AMD PowerXpress™*A+I High-Performance mode on Ubuntu 12.10
            Not helpful. What crash? With what software versions is it supposed to work?

            I tried it with an AMD Enduro notebook. "Downgraded" to all the stable versions, X.Org X Server 1.13.1, mesa 9.0.1 and xf86-video-intel 2.20.18.

            Didn't work. X start looks ok, until…
            [   749.149] (EE) fglrx(0): Map intel primary surface to user space failed!
            [   749.149] 
            Fatal server error:
            [   749.149] AddScreen/ScreenInit failed for driver 0
            Any plans to make it work on current stable versions?

            1. Downgraded to xf86-video-intel 2.20.2, and 1.12, no difference.
            2. Added
            Option  "Ignore"  "true"
            to the Monitor section in the pxp amd xorg.conf. Difference!
            [  2496.156] (II) fglrx(0): Output LVDS1 using monitor section aticonfig-Monitor[0]-0
            [  2496.156] (**) fglrx(0): Option "Ignore" "true"
            [  2496.228] (II) fglrx(0): Output VGA1 using monitor section aticonfig-Monitor[0]-0
            [  2496.300] (II) fglrx(0): Output HDMI1 using monitor section aticonfig-Monitor[0]-0
            [  2496.343] (II) fglrx(0): Output DP1 using monitor section aticonfig-Monitor[0]-0
            [  2496.344] (II) fglrx(0): Output HDMI2 using monitor section aticonfig-Monitor[0]-0
            [  2496.356] (II) fglrx(0): Output HDMI3 using monitor section aticonfig-Monitor[0]-0
            [  2496.396] (II) fglrx(0): Output DP2 using monitor section aticonfig-Monitor[0]-0
            [  2496.436] (II) fglrx(0): Output DP3 using monitor section aticonfig-Monitor[0]-0
            [  2496.436] (WW) fglrx(0): No outputs definitely connected, trying again...
            [  2496.436] (WW) fglrx(0): Unable to find connected outputs - setting 1024x768 initial framebuffer
            [  2496.436] (II) fglrx(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
            [  2496.436] (II) fglrx(0): Kernel page flipping support detected, enabling
            [  2496.436] (EE) fglrx(0): No modes.
            [  2496.436] (WW) fglrx(0): PreInit PowerXpress failed!(EE) 
            [  2496.436] (EE) Backtrace:
            [  2496.436] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x58a426]
            [  2496.436] (EE) 1: /usr/bin/X (0x400000+0x18e279) [0x58e279]
            [  2496.437] (EE) 2: /usr/lib/ (0x7fabdbc24000+0xf1e0) [0x7fabdbc331e0]
            [  2496.437] (EE) 3: /usr/lib/xorg/modules/drivers/ (xdl_xs113_atiddxFreeScreen+0xd4) [0x7fabd8e32114]
            [  2496.437] (EE) 4: /usr/bin/X (xf86DeleteScreen+0x84) [0x480c74]
            [  2496.437] (EE) 5: /usr/bin/X (InitOutput+0xc4e) [0x47a0fe]
            [  2496.437] (EE) 6: /usr/bin/X (0x400000+0x26786) [0x426786]
            [  2496.437] (EE) 7: /usr/lib/ (__libc_start_main+0xf5) [0x7fabda8a8a15]
            [  2496.437] (EE) 8: /usr/bin/X (0x400000+0x26cad) [0x426cad]
            [  2496.437] (EE) 
            [  2496.437] (EE) Segmentation fault at address 0x38
            [  2496.437] 
            Fatal server error:
            [  2496.437] Caught signal 11 (Segmentation fault). Server aborting
            Is there any documentation on what configuration is supposed to work?
            Last edited by ChrisXY; 18 January 2013, 08:02 AM.


            • #7
              I've just updated ebuild for it on my Gentoo ( 64-bit on Phenom 955BE/HD6850 - 3 monitor setup) and replaced last 12.11-beta11

              A couple annoying bugs seem to have been fixed. Otherwise, no big differences. Not that I would even notice 3D performance changes as I'm not big gamer.


              • #8
                No news about HD Audio bitstream?


                • #9
                  One positive thing I noticed is that ground in is no longer transparent, like it was with 12.10 drivers. Graphical glitches in Cinnamon are still there.

                  Another major pleasant change is that card now automatically clocks down, to 300 and 150 Mhz for Core and Memory, respectively, when there's no heavy load. With 12.10 drivers it was 500, 1250 minimum, and I used to get annoying fan noise.

                  Ubuntu 12.04, Radeon 7950.


                  • #10
                    Thank you, AMD, for making an effort to publish a Linux release log. I recently upgraded my AMD Radeon HD 4870 to a HD 7850 due to the legacy graphics drivers (for both Linux & Window). I wasn't please that my old card became "unsupported" after only 3 years (and I still am not), but I am happy that my new 7850 runs Arch + GnomeShell very smoothly. There's no difference between the framerate of the Unigine Heaven Tech Demo running on Windows 8 + DirectX 11 and Linux 3.6 + OpenGL, even at very high settings with Tesselation. Blender + Dyntopo is running very smooth as well. Awesome