Announcement

Collapse
No announcement yet.

R600 Gallium3D Getting Close On OpenGL 3.3 Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • marek
    replied
    Originally posted by ChrisXY View Post
    It was my impression, that the ddx was called "radeonsi" or at least "radeon" and not "ati".
    The DDX is really called "ati", which should load "radeon" for you.

    Originally posted by ChrisXY View Post
    Edit:
    Code:
    --with-dri-drivers=radeon
    Pretty sure, that doesn't do anything. But it may be necessary to put swrast there if it doesn't compile because of som stupid build system dependency. If not, Just a space character will be interpreted as an empty list, otherwise it will build some default like r300 I think.
    "--with-dri-drivers=radeon" builds the R100 driver. Just set empty "--with-dri-drivers=" and set "--with-gallium-drivers=" to one of r300, r600, radeonsi. I think you also need to enable EGL.
    Last edited by marek; 01-22-2013, 04:06 PM.

    Leave a comment:


  • ChrisXY
    replied
    Originally posted by rrohbeck
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Driver "ati"
    It was my impression, that the ddx was called "radeonsi" or at least "radeon" and not "ati".

    Your Xorg.0.log says
    Code:
    [  1169.313] (II) LoadModule: "radeon"
    so your Device section with the "ati" driver is probably not used.


    Edit:
    Code:
    --with-dri-drivers=radeon
    Pretty sure, that doesn't do anything. But it may be necessary to put swrast there if it doesn't compile because of som stupid build system dependency. If not, Just a space character will be interpreted as an empty list, otherwise it will build some default like r300 I think.
    Last edited by ChrisXY; 01-21-2013, 09:01 PM.

    Leave a comment:


  • agd5f
    replied
    Originally posted by rrohbeck
    Yes, the current Device section is
    /opt/xorg/share/X11/xorg.conf.d/50-Device:Section "Device"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Identifier "HD7850"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Driver "ati"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "AccelMethod" "glamor"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: BusID "PCI:6:0:0"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-HDMI-0" "S273HL1"
    /opt/xorg/share/X11/xorg.conf.d/50-Device:# Option "Monitor-DVI-1" "S273HL2"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DVI-0" "Shimian"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DisplayPort-0" "QNIX1"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DisplayPort-1" "QNIX2"
    /opt/xorg/share/X11/xorg.conf.d/50-Device:EndSection
    Is it actually getting picked up by the xserver however? Previously it was not. Can you post your xorg log? It would be easier to track all of this if you opened a bug:
    https://bugs.freedesktop.org

    Leave a comment:


  • agd5f
    replied
    Originally posted by rrohbeck
    That didn't change anything. But maybe the new fglrx will work for me, I'll try it now.
    Have you fixed your configuration so that the accelmethod option is actually picked up by the xserver?

    Option "AccelMethod" "glamor"

    Leave a comment:


  • Veerappan
    replied
    Originally posted by rrohbeck
    I just rebuilt everything and it still doesn't work for me.
    Could somebody check what I'm doing wrong?
    xorg.conf.d: http://pastebin.com/7yzcnFtT
    Xorg.0.log: http://pastebin.com/AepK2XDq
    build_radeonsi.sh: http://pastebin.com/HZGhh0fq

    Basically what I do is (some of this may be redundant but I never checked what exactly I need):
    Download/build/install 3.8 kernel from git://people.freedesktop.org/~airlied/linux origin/drm-next branch
    Download/build/install LLVM from git://people.freedesktop.org/~tstellar/llvm
    Download/build/install entire stack with git://anongit.freedesktop.org/git/xorg/util/modular util/modular
    Download/build/install xorg-server-1.11.4 from tarball with --enable-glx-tls --enable-xorg --disable-dmx --disable-xvfb --disable-xnest --disable-xwin
    Download/build/install git://anongit.freedesktop.org/git/xorg/driver/xf86-video-ati with --enable-gallium-radeon --with-egl-platforms=x11,drm --enable-glamor
    Download/build/install git://anongit.freedesktop.org/mesa/mesa with --with-dri-driverdir=$PREFIX/lib/dri --with-egl-platforms=x11,drm --with-gallium-drivers=swrast,r300,r600,radeonsi --enable-gbm --enable-shared-glapi --enable-glx-tls --with-dri-drivers=radeon
    Download/build/install git://anongit.freedesktop.org/git/mesa/drm
    Download/build/install git://anongit.freedesktop.org/git/xorg/driver/glamor with --enable-glx-tls

    kdmrc has
    ServerCmd=/opt/xorg/bin/X -verbose 9 -logverbose 9 -configdir /opt/xorg/share/X11/xorg.conf.d

    and I'm still getting
    [ 1169.968] (WW) RADEON(0): Direct rendering disabled
    [ 1169.968] (II) RADEON(0): Acceleration disabled


    IIRC: You need to rebuild mesa with the --enable-glx-tls and the other options BEFORE you build xf86-video-ati. When I've seen glamor guides in the past, they basically recommended MESA -> GLAMOR -> xf86-video-ati. The xf86-video-ati configure log might also be useful here.

    Leave a comment:


  • MrCooper
    replied
    Originally posted by rrohbeck
    [ 1169.968] (II) RADEON(0): Acceleration disabled
    Looks like it's not picking up Option "AccelMethod" "glamor". I think maybe the xorg.conf.d/ snippets must be named *.conf, or it might be easier to just put it in /etc/X11/xorg.conf.

    BTW, this sort of problem report should rather go to a relevant mailing list.

    Leave a comment:


  • entropy
    replied
    Originally posted by agd5f View Post
    Both 3D and rotation are working. You just have to use glamor and a pre-1.13 xserver at the moment until the issues with xserver 1.13 are sorted out.
    Does it work with zaphod configurations now?

    Leave a comment:


  • Serafean
    replied
    Originally posted by rrohbeck
    I'm building the whole stack every few days to see if HW acceleration finally works. No it doesn't so still no rotation support

    I shouldn't have gotten a HD7xxx board. I had (falsely) assumed at least fglrx would work.
    I'm running an HD7950 with catalyst, and it works like a charm. (Well, apart for the "unsupported hardware logo").
    OTOH having an APU with a discreet card was a PITA to get running. Proof :
    Code:
    # fglrxinfo 
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 7900 Series
    OpenGL version string: 4.2.11986 Compatibility Profile Context
    Back on topic : Awesome! with steam coming, a working and up to date graphics stack is a must. Kudos to all involved.

    Serafean

    Leave a comment:


  • agd5f
    replied
    Originally posted by rrohbeck
    I'm building the whole stack every few days to see if HW acceleration finally works. No it doesn't so still no rotation support

    I shouldn't have gotten a HD7xxx board. I had (falsely) assumed at least fglrx would work.
    Both 3D and rotation are working. You just have to use glamor and a pre-1.13 xserver at the moment until the issues with xserver 1.13 are sorted out.

    Leave a comment:


  • Kano
    replied
    Well you can use RBDoom3BFG natively. Just without bink videos but it should require the same extensions. Would be a really good test. Running Rage via wine is usally no problem as well when you use binary drivers (for amd you would need 12-11 beta at least).

    Leave a comment:

Working...
X