No announcement yet.

12.8 up on site, but broken link

  • Filter
  • Time
  • Show
Clear All
new posts

  • 12.8 up on site, but broken link

    Just saw that catalyst 12.8 is listed on the amd download site, but the link is broken. Somehow this feels familiar . Anyone else having any better luck trying to download it?

  • #2

    404 so far.


    • #3
      404 Not Found Catalyst 12.8

      Yea I saw the new update as well went to dload it and got 404 Not Found too, Hope they get it up soon. (just came out today) Will reply if I see it come up.


      • #4
        Now this is strange xD also says broken for me however CodeBase a german website has the 12.8 linux driver uploaded today on their website for download lol


        • #5
          Strange Indeed.

          Hmm, This whole thing has been strange (wonder if the upload of 12.8 from CodeBase is legit) Otherwise I'm gonna keep trying to see if the link gets fixed. Tried again before this post (still 404)


          • #6
            not sure lol Decided to install for fun of it they work at least lol even if they might not be legit xD Bet some idiot has gone and just changed the 12.6 thinking they are funny lol However the CCC information matches the information of the 12.8 driver for windows lol
            Last edited by xillius200; 16 August 2012, 12:48 AM.


            • #7
              Yeah it's offline again. I'll try it anyway in a few minutes.


              • #8
                download here, as the link is still broken

                checked the link, still broken. but you can find it here:
                Auf Planet 3DNow! gibt es alle wichtigen Informationen für AMD-User: News, Downloads, Support, Tests

                Have not yet installed the driver, is there any news on what's fixed in this one?


                • #9
                  I find work mirror:

                  Catalyst 12.8 for Linux x86 x64
                  Auf Planet 3DNow! gibt es alle wichtigen Informationen für AMD-User: News, Downloads, Support, Tests

                  Happy testing


                  • #10
                    Right something is certainly wrong with the Link however you can still obtain the file from the ati server by changing the url to this and then extracting the zip You will then have ati catalyst 12.8 what amazes me is that they have not spoke about the issue yet tried to fix it even with a few people saying about it on their own forums....