Announcement

Collapse
No announcement yet.

Open-Source ATI Driver Gets TV-Out

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • lynn
    replied
    Which header files and dev packages, specifically? I've been installing various things that sound related, such as xorg-dev and xlibs-dev, but I keep getting the same make error.

    Thanks
    -Lynn

    Leave a comment:


  • mlau
    replied
    Originally posted by lynn View Post
    Hi,

    I'm having trouble building the driver. autogen.sh runs smoothly, but when I use the make command I get this:



    Does anyone know the solution?
    Looks like you're missing some headerfiles from the xorg-server package (and maybe other X libs)
    Forgot to install the appropriate -devel package(s)?
    Last edited by mlau; 08-15-2007, 03:15 PM.

    Leave a comment:


  • lynn
    replied
    Hi,

    I'm having trouble building the driver. autogen.sh runs smoothly, but when I use the make command I get this:

    make all-recursive
    make[1]: Entering directory `/home/lynn/Desktop/xf86-video-ati'
    Making all in src
    make[2]: Entering directory `/home/lynn/Desktop/xf86-video-ati/src'
    /bin/bash ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/xorg -I/usr/include/drm -I/usr/include/X11/dri -g -O2 -MT ati.lo -MD -MP -MF .deps/ati.Tpo -c -o ati.lo ati.c
    gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/xorg -I/usr/include/drm -I/usr/include/X11/dri -g -O2 -MT ati.lo -MD -MP -MF .deps/ati.Tpo -c ati.c -fPIC -DPIC -o .libs/ati.o
    In file included from ati.c:65:
    radeon_probe.h:46:22: error: xf86Crtc.h: No such file or directory
    In file included from ati.c:65:
    radeon_probe.h:225: error: expected specifier-qualifier-list before 'xf86CrtcPtr'
    ati.c:228: error: 'PACKAGE_VERSION_MAJOR' undeclared here (not in a function)
    ati.c:228: error: 'PACKAGE_VERSION_MINOR' undeclared here (not in a function)
    ati.c:228: error: 'PACKAGE_VERSION_PATCHLEVEL' undeclared here (not in a function)
    make[2]: *** [ati.lo] Error 1
    make[2]: Leaving directory `/home/lynn/Desktop/xf86-video-ati/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/lynn/Desktop/xf86-video-ati'
    make: *** [all] Error 2
    Does anyone know the solution?

    Thanks
    -Lynn

    Leave a comment:


  • yoshi314
    replied
    but of course.

    Leave a comment:


  • Trek1701
    replied
    Hi,

    Is the video overlay working properly with this driver?


    Trek1701

    Leave a comment:

Working...
X