Announcement

Collapse
No announcement yet.

VBE Modesetting Dumps For Avivo R500 Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • glisse
    started a topic VBE Modesetting Dumps For Avivo R500 Driver

    VBE Modesetting Dumps For Avivo R500 Driver

    Originally posted by chrisr View Post
    Fair enough, he needs information. So what kind of information can people provide? Are we talking about dumps from people who are successfully using these graphics cards with the fglrx driver and an LCD panel? I have a laptop with an embedded FireGL 5250 (R530, I believe) which sort-of-works with the fglrx. Maybe if someone could provide a script that would generate the useful information then we could get the 0.1.0 release out the door after all?
    What i need is a vbe modesetting bios dump for 800x600, 1024x768, 1280x1024 (and for native resolution). For doing this grab http://people.freedesktop.org/~glisse/vbespy.tar.bz2 and make then ./vbetest 2> /dev/null note mode number corresponding to resoltuion 800x600 8:8:8 ... then q then
    ./vbetest -m <800600modenumber> 2> firegl5250-800x600
    ./vbetest -m <1024768modenumber> 2> firegl5250-1024x768
    ...

    You should see some colored picture on screen. Once you got all dumps pack them together bzip2 and send them to me or put them somewhere on the net.

    PS: You need to be root under console and it's better if X is not running and that fglrx is not loaded (in fact it's better doing them after cold boot without X being loaded so flgrx can't mess up with the card).

  • surfer
    replied
    Re: X1800 results

    Oops! Nevermind!
    Last edited by surfer; 04-11-2008, 04:01 PM.

    Leave a comment:


  • glisse
    replied
    Originally posted by kostekjo View Post
    My vbe tests for resolutions : 600x480, 800x600 and 1024x768 :http://student.agh.edu.pl/~kostekjo/x1200vbetest.tar.gz
    I hope that will help.

    Other ifno:
    I'm running a 64-bit fedora 8 on a Toshiba Satellite A210-11B Turion TL-52.

    If there is any other way I could help please contact me kostekjo [at] o2.pl
    We no longer need dump, by reading phoronix you should know that AMD as now released documentations. See phoronix.com, you could try one of the two driver now supporting your card either radeon or radeonhd.

    Leave a comment:


  • kostekjo
    replied
    radeon x1200

    My vbe tests for resolutions : 600x480, 800x600 and 1024x768 :http://student.agh.edu.pl/~kostekjo/x1200vbetest.tar.gz
    I hope that will help.

    Other ifno:
    I'm running a 64-bit fedora 8 on a Toshiba Satellite A210-11B Turion TL-52.

    If there is any other way I could help please contact me kostekjo [at] o2.pl

    Leave a comment:


  • raiden
    replied
    Here is another pci id to add to the radeonhd driver.
    Saphire Radeon X1600 512mb AGP,

    (II) RADEONHD(0): Initializing INT10
    (II) RADEONHD(0): Primary V_BIOS segment is: 0xc000
    (==) RADEONHD(0): Depth 16, (--) framebuffer bpp 16
    (WW) RADEONHD(0): Unknown card detected: 0x71C2:0x174B:0x0850.
    Your card might not work or might not work optimally.
    To rectify this, please contact [email protected].
    Include your X log, the full name of the device
    and the conntest (found in utils/conntest) output.
    (--) RADEONHD(0): Detected an RV530 on an unidentified card
    (EE) RADEONHD(0): Cannot map connectors on an unknown card!


    vbetest - results

    http://www.zshare.net/download/3872638618944e/

    http://www.zshare.net/download/3872638618944e/

    Leave a comment:


  • robm351
    replied
    Here's another run for an X1250 (0x791e) integrated chip on a Gigabyte motherboard.

    http://www.flipturn.org/X1250-vbespy.tgz

    Leave a comment:


  • paladin
    replied
    Hi
    I'm running a T60 with X1400.

    Trying vbetest before fglrx or X loaded the test does not work, I see no colored screen and get the same result for all resolutions:

    http://www.file-upload.net/download-...50.txt.gz.html

    In the last line it says "To switch video modes, this program must be run from the console" though I was in console before loading fglrx or X.

    When switching from X with fglrx driver to console and using the tool with my native resolution 1400x1050:

    http://www.file-upload.net/download-...-X.txt.gz.html

    PS: The current avivio driver version (git from today) freezes my computer (first some color flicker, then black screen) so I have to hard reset.

    Leave a comment:


  • oyvind
    replied
    Lenovo Thinkpad Z61m, ATI X1400

    Did vbetest on a Lenovo Thinkpad Z61m with an ATI X1400 in it.

    Could not find a mode corresponding to the native resolution of 1680x1050, but did the others.

    http://folk.uio.no/oyviste/vbetest

    Regards,
    oyvind

    Leave a comment:


  • flo2
    replied
    radeon x1950 xtx pcie dumpfiles

    http://mauss.dyndns.info/files/x1950xtx.tar

    thx & greets

    Leave a comment:


  • ReinisFMF
    replied
    It works now! Great work!

    http://www.phoronix.com/forums/showt...1795#post11795

    Leave a comment:

Working...
X