Announcement

Collapse
No announcement yet.

AMD Evergreen Compute Support Lands Mainline

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Pontostroy View Post
    I build all with this instruction, but all opencl-examples shows me
    Code:
     /home/downloads/git/opencl-example/hello_world 
    radeon: Failed to get PCI ID, error number -13
    There are 1 platforms.
    clGetDeviceIDs() failed: CL_DEVICE_NOT_FOUND
    I use hd6770 (juniper).
    In what may be the problem?
    error numbe -13 = EACCES (Permission denied). Maybe try as root as a workaround

    Comment


    • #12
      sup

      I have a Mobility Radeon 5400 Series Card, will this also affect me?

      I really can't wait to fully switch to the free Radeon Drivers...
      My current situation is that the free Drivers keep my fans spinning on my Laptop due to heat generation, therefore I am using the Proprietary ones.
      I have tried nearly everything to reduce the heat, but nothing ever worked (Options like ForceLowPowerMode/ClockGating/DynamicPM/etc).

      I guess my main question is, what will it improve?

      Actually I got another question... when will the free Radeon Drivers be usable with Wine?
      The last time I tried, I couldn't get 3D Acceleration working through wine, at least that's what DXDiag told me.

      Damn, this got me exited again!
      Keep it up AMD!
      ;D

      Comment


      • #13
        Originally posted by bug! View Post
        Actually I got another question... when will the free Radeon Drivers be usable with Wine?
        The last time I tried, I couldn't get 3D Acceleration working through wine, at least that's what DXDiag told me.
        Are you sure you had the proper drivers installed? I mean there is the case, where you have 64 bit system - then you have to install install 32 bit mesa alongside the 64 bit one in order to utilise hardware acceleration in wine.

        Comment


        • #14
          Originally posted by Hirager View Post
          Are you sure you had the proper drivers installed? I mean there is the case, where you have 64 bit system - then you have to install install 32 bit mesa alongside the 64 bit one in order to utilise hardware acceleration in wine.
          You are indeed correct, I was missing the 32bit libs, my bad!
          It works like a charm, dxdiag completes all Graphics related tests via. the Radeon Drivers perfectly.

          The 64 Bit Snake has bitten me once again... I should have known this.

          Now I'm off to tackle the Heat once more!
          Last edited by bug!; 02 June 2012, 07:24 PM.

          Comment


          • #15
            The power management options you mentioned mostly sound obsolete -- all the PM code is in the kernel these days rather than the X driver. Take a look at the following link and see if that helps :

            http://www.x.org/wiki/RadeonFeature#...gement_Options

            The dynpm options still has problems on a lot of systems, so try the profile approach first. Either low or mid should reduce the heat -- mid is the best option if your VBIOS includes a "mid" profile.

            Comment


            • #16
              Originally posted by tstellar View Post
              You need to run those programs as root if X is running.
              .
              It works (almost).
              Code:
              /home/downloads/git/opencl-example/hello_world 
              There are 1 platforms.
              There are 1 GPU devices.
              clCreateContext() succeeded.
              clCreateCommandQueue() succeeded.
              clCreateProgramWithSource() suceeded.
              clBuildProgram() suceeded.
              clCreateKernel() suceeded.
              clCreateBuffer() succeeded.
              clSetKernelArg() succeeded.
              radeon: The kernel rejected CS, see dmesg for more information.
              clEnqueueNDRangeKernel() suceeded.
              clEnqueueReadBuffer() suceeded.
              pi = 0.000000
              Code:
              [  424.341250] radeon 0000:01:00.0: evergreen_surface_check_linear_aligned:209 cb pitch 8 invalid must be aligned with 128
              [  424.341254] radeon 0000:01:00.0: evergreen_cs_track_validate_cb:422 cb[0] invalid (0x00000000 0x00000000 0x00000010 0x04000134)
              [  424.341257] radeon 0000:01:00.0: evergreen_packet3_check:2110 invalid cmd stream 628
              [  424.341259] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !

              Comment


              • #17
                Originally posted by Pontostroy View Post
                It works (almost).
                Code:
                /home/downloads/git/opencl-example/hello_world 
                There are 1 platforms.
                There are 1 GPU devices.
                clCreateContext() succeeded.
                clCreateCommandQueue() succeeded.
                clCreateProgramWithSource() suceeded.
                clBuildProgram() suceeded.
                clCreateKernel() suceeded.
                clCreateBuffer() succeeded.
                clSetKernelArg() succeeded.
                radeon: The kernel rejected CS, see dmesg for more information.
                clEnqueueNDRangeKernel() suceeded.
                clEnqueueReadBuffer() suceeded.
                pi = 0.000000
                Code:
                [  424.341250] radeon 0000:01:00.0: evergreen_surface_check_linear_aligned:209 cb pitch 8 invalid must be aligned with 128
                [  424.341254] radeon 0000:01:00.0: evergreen_cs_track_validate_cb:422 cb[0] invalid (0x00000000 0x00000000 0x00000010 0x04000134)
                [  424.341257] radeon 0000:01:00.0: evergreen_packet3_check:2110 invalid cmd stream 628
                [  424.341259] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
                What kernel version are you using?

                Comment


                • #18
                  Originally posted by tstellar View Post
                  What kernel version are you using?
                  Code:
                  uname -a
                  Linux linux-gyo1 3.4.0-5-desktop #1 SMP PREEMPT Fri May 25 15:45:36 UTC 2012 (64b97cd) i686 i686 i386 GNU/Linux
                  drm-next have same problem

                  Comment


                  • #19
                    Originally posted by Pontostroy View Post
                    Code:
                    uname -a
                    Linux linux-gyo1 3.4.0-5-desktop #1 SMP PREEMPT Fri May 25 15:45:36 UTC 2012 (64b97cd) i686 i686 i386 GNU/Linux
                    drm-next have same problem
                    Ok, you should file a bug at bugs.freedesktop.org. You might have better success with an older kernel, it was working on my Juniper with 3.2, and I've been using 3.1 for most of my testing.

                    Comment


                    • #20
                      Originally posted by Pontostroy View Post
                      I build all with this instruction, but all opencl-examples shows me
                      Code:
                       /home/downloads/git/opencl-example/hello_world 
                      radeon: Failed to get PCI ID, error number -13
                      There are 1 platforms.
                      clGetDeviceIDs() failed: CL_DEVICE_NOT_FOUND
                      I use hd6770 (juniper).
                      In what may be the problem?


                      libclc has same warnings at build time
                      Code:
                      LINK utils/prepare-builtins
                      LLVM-CC r600--/lib/workitem/get_global_id
                      LLVM-CC r600--/lib/workitem/get_global_size.cl.bc
                      LLVM-CC r600--/lib/convert.cl.bc
                      ./generic/lib/convert.cl:69:19: warning: shift count >= width of type [-Wshift-count-overflow]
                        return l > ((1UL<<32)-1) ? ((1UL<<32)-1) : l;
                                        ^ ~~
                      ./generic/lib/convert.cl:69:35: warning: shift count >= width of type [-Wshift-count-overflow]
                        return l > ((1UL<<32)-1) ? ((1UL<<32)-1) : l;
                                                        ^ ~~
                      2 warnings generated.
                      LLVM-CC r600--/lib/geometric/cross.cl.bc
                      LLVM-CC r600--/lib/geometric/dot.cl.bc
                      LLVM-CC r600--/lib/geometric/length.cl.bc
                      The code supports EVERGREEN (radeon HD 5xxx).
                      You have NORTHERN ISLANDS (radeon HD 6xxx).

                      Comment

                      Working...
                      X