Announcement

Collapse
No announcement yet.

Radeon Evergreen HDMI Audio Code Is Still M.I.A.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic Radeon Evergreen HDMI Audio Code Is Still M.I.A.

    Radeon Evergreen HDMI Audio Code Is Still M.I.A.

    Phoronix: Radeon Evergreen HDMI Audio Code Is Still M.I.A.

    For those that haven't noticed, the open-source Radeon Linux graphics driver still lacks HDMI audio support for the Radeon HD 5000 "Evergreen" series and newer graphics processors. This has been sought after for many months, but even with the Linux 3.2 kernel, AMD still doesn't have to go-ahead with the open-source audio support...

    http://www.phoronix.com/vr.php?view=MTAyMjc

  • Vincenzov
    replied
    Hi

    radeon 5450 dual screen 1920 x 1080 crt+ hdmi , audio works
    radeon 5450 only hdmi, audio and video slowed.
    Kernel 3.3.0-rc5, klbuntu 11.10 64bit. driver oibaf.
    Last edited by Vincenzov; 02-26-2012, 01:37 PM.

    Leave a comment:


  • Vincenzov
    replied
    Hi, kernel 3.3-rc2 hdmi audio work very good, (radeon 5450).
    Bye

    Leave a comment:


  • Qaridarium
    replied
    Originally posted by HokTar View Post
    Wow. Maybe another "Q already knows what bridgman doesn't" situation?
    We will see...
    Bridgman are forced to be quiet. He loses his job when he talks too much.

    Leave a comment:


  • Qaridarium
    replied
    Originally posted by Zajec View Post
    Wow, thanks for this info! I was always sure it's card specific that sometime HDMI mode doesn't work!
    sgcb: I'll contact you privately, let's try to fix that


    Oh, thanks for enlighting me about my development.
    Sure you can always chance stuff. And I'm happy about your work

    Leave a comment:


  • Qaridarium
    replied
    Originally posted by AnonymousCoward View Post
    Any news about UVD?
    do you mean "Video Codec Engine" (VCE) ?

    i think the "Video Codec Engine" (VCE) (hd7970) is more open-source friendly.

    Leave a comment:


  • Zajec
    replied
    Originally posted by sgcb View Post
    If/when this new code sees the light of day, will it also fix the blank screen/no signal issue that is seen on some monitors with hdmi audio on <= hd 4xxx? We just got a led-lcd and whenever radeon.audio=1, no signal seems to be recognized by the monitor, but on our regular lcd, everything works swimmingly.
    Wow, thanks for this info! I was always sure it's card specific that sometime HDMI mode doesn't work!
    sgcb: I'll contact you privately, let's try to fix that


    Originally posted by Qaridarium View Post
    no sorry. you have to wait for the official amd solution
    Oh, thanks for enlighting me about my development.

    Leave a comment:


  • AnonymousCoward
    replied
    Originally posted by Qaridarium View Post
    i think the official amd opensource HDMi support will be released in February 2012.
    Any news about UVD?

    Leave a comment:


  • HokTar
    replied
    Originally posted by Qaridarium View Post
    i think the official amd opensource HDMi support will be released in February 2012.
    Wow. Maybe another "Q already knows what bridgman doesn't" situation?
    We will see...

    Leave a comment:


  • Qaridarium
    replied
    Originally posted by sgcb View Post
    Dang it, have there been any developments since october [link]? How far along is the fixed code compared to the new code for evergreen+?
    i think the official amd opensource HDMi support will be released in February 2012.

    Leave a comment:

Working...
X