No announcement yet.

Installing The Avivo Driver On Ubuntu

  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing The Avivo Driver On Ubuntu

    Phoronix: Installing The Avivo Driver On Ubuntu

    It was just a month ago that the open-source Avivo driver for the ATI Radeon X1000 (R500) series was introduced to the public, but in this time we've seen some great progress made. This open-source R500 driver now contains RandR 1.2 support, support for a variety of R500 graphics cards, and most recently support for Shadow Framebuffer was added. The Avivo driver still isn't comparable when it comes to the features found in the fglrx driver or even the open-source Radeon driver for the R200/300/400 series, but it's a work in progress. If you are running into problems with the fglrx driver, stuck using the VESA driver for one reason or another, or just want to get rid of the binary blob and experiment with this open-source driver, we have written a guide for setting up the Avivo driver from source on Ubuntu.

    Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux server benchmarks, Linux benchmarking, Desktop Linux, Linux performance, Open Source graphics, Linux How To, Ubuntu benchmarks, Ubuntu hardware, Phoronix Test Suite

  • #2
    I have been following Phoronix coverage of both the avivo driver and ATI's binary blob for a while now, and I really appreciate having an up to date news source on these topics!
    Today I finally decided to test the avivo driver on my Dell Inspiron 6400 with an ATI Mobility X1400. The compilation went without any problems, but after switching to the avivo driver, xorg failed to start, with the following error at the end of the log:

    (II) avivo(0): Output LFP connected
    (II) avivo(0): I2C device "LFP connector 1:ddc2" registered at address 0xA0.
    (II) avivo(0): I2C device "LFP connector 1:ddc2" removed.
    (II) avivo(0): EDID for output LFP

    0: /usr/bin/X(xf86SigHandler+0x81) [0x80c8641]
    1: [0xffffe420]
    2: /usr/lib/xorg/modules/drivers// [0xb7b88d63]
    3: /usr/bin/X(xf86ProbeOutputModes+0x2c7) [0x80f7ee7]
    4: /usr/bin/X(xf86InitialConfiguration+0x83) [0x80f85c3]
    5: /usr/lib/xorg/modules/drivers// [0xb7b8a072]
    6: /usr/bin/X(InitOutput+0x9a4) [0x80a8304]
    7: /usr/bin/X(main+0x27b) [0x8076c7b]
    8: /lib/tls/i686/cmov/ [0xb7d08030]
    9: /usr/bin/X(FontFileCompleteXLFD+0x1ed) [0x80761b1]

    Fatal server error:
    Caught signal 11. Server aborting

    To me, it seems like the crash occurs when probing the LFP output for supported resolutions, but I have no idea what can be causing it. I have deactivated AIGLX and composite in xorg.conf. Any ideas?


    • #3
      Nice article, worked perfectly for me. Of course movies don't play but I tried Frozen Bubble and that worked fine. 2d performance seems good. This driver is moving along very smoothly. I'm impressed.